1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

PHP auf dem Mac Mini Server..

Dieses Thema im Forum "macOS & OS X Server" wurde erstellt von MacMapple, 03.02.10.

  1. MacMapple

    MacMapple Boskop

    Dabei seit:
    22.12.09
    Beiträge:
    205
    ...ich wollte gerade ein WordPress aufsetzen, und nun kommt das hier:
    Code:
    [B]Warning[/B]:  ftp_login() [function.ftp-login]: SSL is unknown to me in ...
    Hat jemand eine Idee, was ich tun kann?
     
  2. Samir2602

    Samir2602 Fießers Erstling

    Dabei seit:
    12.03.09
    Beiträge:
    127
    soweit ich weiß ist ssl nicht von beginn an aktiviert. musst es über den server manager oder das termial einschalten
     
  3. MacMapple

    MacMapple Boskop

    Dabei seit:
    22.12.09
    Beiträge:
    205
    Naja, diese Antwort war ja nicht wirklich hilfreich ;-(
    SSL grundsätzlich ist ja die eine Sache, aber FTPS aus PHP heraus ist eine andere.

    Erst wenn bei diesem kleinen Script der o.g. Fehler nicht mehr auftaucht, ist das Problem beseitigt.

    Code:
    <?php
    $conn_id = ftp_ssl_connect('localhost');
    $login_result = ftp_login($conn_id, 'ftp-user', 'ftp-password');
    echo ftp_pwd($conn_id);
    ftp_close($conn_id);
    ?>
    
     
  4. drlecter

    drlecter Wöbers Rambur

    Dabei seit:
    04.11.06
    Beiträge:
    6.442
    Lass dir einmal per phpinfo die Einstellungen von php ausgeben. Vielleicht fehlt die SSL Unterstützung in PHP.
     
  5. MacMapple

    MacMapple Boskop

    Dabei seit:
    22.12.09
    Beiträge:
    205
    Hallo drlecter,
    anbei erstmal die Ausgabe des Terminal Befehlszeile

    $ php --info | grep -i ssl

    Configure Command => '/var/tmp/apache_mod_php/apache_mod_php-53~1/php/configure' '--prefix=/usr' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--disable-dependency-tracking' '--sysconfdir=/private/etc' '--with-apxs2=/usr/sbin/apxs' '--enable-cli' '--with-config-file-path=/etc' '--with-libxml-dir=/usr' '--with-openssl=/usr' '--with-kerberos=/usr' '--with-zlib=/usr' '--enable-bcmath' '--with-bz2=/usr' '--enable-calendar' '--with-curl=/usr' '--enable-exif' '--enable-ftp' '--with-gd' '--with-jpeg-dir=/BinaryCache/apache_mod_php/apache_mod_php-53~1/Root/usr/local' '--with-png-dir=/BinaryCache/apache_mod_php/apache_mod_php-53~1/Root/usr/local' '--enable-gd-native-ttf' '--with-ldap=/usr' '--with-ldap-sasl=/usr' '--enable-mbstring' '--enable-mbregex' '--with-mysql=mysqlnd' '--with-mysqli=mysqlnd' '--with-pdo-mysql=mysqlnd' '--with-mysql-sock=/var/mysql/mysql.sock' '--with-iodbc=/usr' '--enable-shmop' '--with-snmp=/usr' '--enable-soap' '--enable-sockets' '--enable-sysvmsg' '--enable-sysvsem' '--enable-sysvshm' '--with-xmlrpc' '--with-iconv-dir=/usr' '--with-xsl=/usr' '--with-pcre-regex=/usr'
    Registered Stream Socket Transports => tcp, udp, unix, udg, ssl, sslv3, sslv2, tls
    SSL => Yes
    SSL Version => OpenSSL/0.9.8l
    openssl
    OpenSSL support => enabled
    OpenSSL Library Version => OpenSSL 0.9.8l 5 Nov 2009
    OpenSSL Header Version => OpenSSL 0.9.8k 25 Mar 2009
    OpenSSL support => enabled
     
  6. drlecter

    drlecter Wöbers Rambur

    Dabei seit:
    04.11.06
    Beiträge:
    6.442
    Hm, das ist statisch einkompiliert. Habe das gerade auch noch einmal bei mir überprüft. Ich müsste das einmal selber auf einer Maschine testen. FTP Support ist bei mir (10.5) auch drin. Das muss seit 5.2.2 sein. Es gibt auch keinen Fallback mehr auf ftp_connect wenn der Server kein SSL kann. Steht bei der Fehlermeldung die Zeile vom Connect oder vom Login?
    Kannst du vielleicht mal ein or die.... hinter dem Connect einfügen? Kann der FTP Server SSL? Vielleicht einmal mit einem Client testen.
     
  7. MacMapple

    MacMapple Boskop

    Dabei seit:
    22.12.09
    Beiträge:
    205
    @drlecter
    Boah ey, jetzt weiß ich gar nicht mehr was ich sagen soll.
    Ich wollte gerade den Debug starten......und ES GEHT JETZT!!!
    Ich habe nichts gemacht und das Problem existierte mehrere Wochen.
    Dadurch hatte ich die ganze Zeit einen Jobstopper.
    Offensichtlich hat der Server gemerkt :eek:, dass es ihm jetzt an den Kragen geht.
    Aber jetzt wollte ich das gleiche auf meinem MacBook durchziehen und da kommt bei:

    Code:
    $conn_id = ftp_ssl_connect('wilber');
    ein FALSE zurück, ohne jegliche Meldung.
    Das ist zwar kein Hindernis, aber schon merkwürdig zumal es exakt die gleiche Konfiguration ist.

    Aber grundsätzlich ist das Problem beseitigt, auch wenn die Ursache unklar bleibt.
     

Diese Seite empfehlen