1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

PDF-Problem: Vorschau stellt nicht richtig dar

Dieses Thema im Forum "macOS & OS X" wurde erstellt von makra, 29.06.09.

  1. makra

    makra Meraner

    Dabei seit:
    03.01.06
    Beiträge:
    229
    Hallo,

    die beiden angehängten Dateien entstammen derselben Publisher-Datei. Das PDF wurde einmal mit Publisher 2000/W2000 und PDFCreator 0.93 und einmal mit P2003/XP/PDFCr0.98 erstellt. Alle Einstellungen, die ich nur finden konnte, waren identisch.
    Wenn ich die Datei xp.pdf mit Vorschau ansehe, sind die Schriften nicht korrekt dargestellt, im AdobeReader schon.
    Bei genauerem Hinsehen im Reader: In W2000.pdf sind die betroffenen Schriften als Untergruppe eingebettet. In XP nicht. Wie ich den PDFCreator oder Windows oder wen auch immer dazu kriege, das auch in der neuen Version zu tun, gehört nicht hierher, sondern in ein Win-Forum. Aber was heißt das: "Eingebettete Untergruppe"? Und warum muckt Vorschau?
    Könnte damit leben, wenn ich wüsste, dass die Win-Leser unseres Gemeindebriefes und die Druckerei garantiert keine Probleme haben werden...

    Gruß, Martin
     

    Anhänge:

    • W2000.pdf
      Dateigröße:
      49,5 KB
      Aufrufe:
      340
    • XP.pdf
      Dateigröße:
      72,9 KB
      Aufrufe:
      317
    #1 makra, 29.06.09
    Zuletzt bearbeitet: 29.06.09
  2. awk

    awk Clairgeau

    Dabei seit:
    03.07.08
    Beiträge:
    3.687
    Welche Schriften sollen nicht richtig dargestellt sein?

    EDIT:

    Herausgefunden. Leider kann ich dir nicht weiterhelfen.
    Hinweis: Tippfehler: Oktonber.
     
  3. makra

    makra Meraner

    Dabei seit:
    03.01.06
    Beiträge:
    229

    :)

    Danke, war noch niemandem aufgefallen - ist aber die Nummer vom September letzten Jahres. Zufälliger Griff aus der Zeit des alten Computers.
     
  4. Rastafari

    Rastafari Golden Noble

    Dabei seit:
    10.03.05
    Beiträge:
    17.903
    Dass nicht alle Glyphen eines Fonts eingebettet wurden, sondern nur diejenigen die im Text auch tatsächlich vorkommen. Das spart Platz, vor allem bei Unicode-fähigen Schriften, die möglicherweise abertausende von Zeichen enthalten die ein Normalsterblicher nie benutzt. Das ist völlig üblich und normal.

    Darüber sind sich unsere beiden Rechner offenbar nicht so ganz einig.
    Wer oder was hier voll unter die noch warme Klobrille gelangt hat...???
    Na, sieh doch einfach selbst...

    Apple Preview.app 4.2 (Mac OS X 10.5.7)
    Adobe Reader 9.1.2 / OS X
    Adobe Reader 9.1.2 / Win32
    GNU Ghostscript 8.6.4

    Vielleicht solltest du das Dokument mal dezent an den Adobe Support schicken, damit die ihre total vermurkste Mac-Version mal auf Vordermann bringen?
     
    #4 Rastafari, 29.06.09
    Zuletzt bearbeitet: 29.06.09
  5. makra

    makra Meraner

    Dabei seit:
    03.01.06
    Beiträge:
    229
    :)
    Hallo Rastafari,
    sehr hübsch.
    Vielleicht war mein Text etwas verwirrend, aber mit dem W2000.pdf hatte ich auch keine Probleme unter Vorschau (auch nicht unter Reader!). Problematisch ist xp.pdf. Wie sieht das denn bei Dir aus?
    Gruß, Martin
     
  6. Rastafari

    Rastafari Golden Noble

    Dabei seit:
    10.03.05
    Beiträge:
    17.903
    [SIZE="+1"]GNAMPF![/SIZE]
    Mea culpa, mea vermalefizt culpa...
    Dem Mac-Reader fehlt nichts, die Darstellung dort ist auch korrekt. Ich hatte lediglich vergessen, die Farbensubstitution wieder abzustellen, die ich neulich mal genutzt hab.
    Ergo: "It's not a bug, just a feature..."

    Absolut besch....eiden.
    Grund: Dort sind schlicht gar keine Fonts eingebettet.
    Du hast im Adobe Reader die Option "Lokale Schriften verwenden" aktiviert, das gaukelt dir eine korrekte Anzeige vor - die benötigten Fonts werden statt aus dem PDF einfach aus deinem System entnommen.
    Stelle diese Voreinstellung unter "Seitenanzeige" ab und du wirst sehen, was später auch andere Leser sehen werden, die die von dir verwendeten Schriften nicht auf ihrem eigenen System installiert haben.
    Ergo: Nicht Vorschau zickt - du hast dich nur erfolgreich selbst überlistet. :)

    Tip:
    Es gibt zwei Arten von eingebetteten Fonts (und Fonts sollten grundsätzlich immer im PDF eingebettet sein):
    Entweder vollständig, also der gesamte Zeichenvorrat eines bestimmten Schriftschnittes.
    Oder aber als Untergruppe ("Subset") aus den tatsächlich verwendeten Zeichen, kombiniert zu einem synthetischen Pseudofont, den es nur innerhalb eines ganz bestimmten Dokuments gibt.
    Die Anzeige im Adobe Reader lautet hierfür "Eingebettet" bzw "Eingebettete Untergruppe".

    Sobald du dort allerdings eine Zeile "Originalschrift" vorfindest bedeutet das, dass du am Bildschirm bzw beim Druck eine völlig andere Schrift siehst, weil sie im PDF nicht gefunden wurde. Entweder ist das genau die gleiche Schrift, nur eben nicht dem PDF, sondern deinem allgemein verfügbaren Schriftenfundus entnommen. Falls du sie installiert hast und die lokalen Fonts verwendet werden sollen.
    Oder aber (und genau das ist bei "Vorschau" der permanente Dauerzustand) du hast die Benutzung der lokalen Fonts untersagt, dann wird eine fehlende Schrift mithilfe ganz spezieller Ersatzfonts möglichst annähernd nachgeahmt, zwar mit einem völlig anderen Schriftbild, aber ohne den Textumbruch und das allgemeine Layout zu zerstören. Die von Adobe hierfür eingesetzten Substitutionsschriften heissen "Adobe Serif MM" und "Adobe Sans MM".
     
    gatm gefällt das.
  7. makra

    makra Meraner

    Dabei seit:
    03.01.06
    Beiträge:
    229
    Besten Dank, das war erschöpfend. Hat schon was, seine Fragen von Dir beantwortet zu bekommen!

    Also werde ich mal auf Fehlersuche gehen - der Fehler hört ja vielleicht sogar auf den Namen Publisher und gibt mir den Schub, unseren Layouter dazu zu zwingen, sich jetzt endlich mit mir das schon angeschaffte InDesign anzutun. Und wohl auch GhostScript zu verlassen.

    Gruß, Martin
     
  8. makra

    makra Meraner

    Dabei seit:
    03.01.06
    Beiträge:
    229
    Fehlersuche beendet: Die im Dokument verwendete zehn Jahre alte Schrift Adelon (von einer CD der Fa. Softmaker) scheint wie die anderen Schriften der CD nicht XP-kompatibel zu sein: Sowohl mit Ghostscript als auch mit Acrobat7 gelingt es mir nicht, aus Word, Publisher oder InDesign heraus diese Schriften einzubetten. Drucken geht, aber PDF scheitert. Bei anderen Schriften kein Problem. Es kam beim PDF-Erzeugen aus InDesign heraus dann auch die Fehlermeldung: "Wegen Einschränkungen im Zeichensatz x konnte die Schrift nicht eingebettet werden." (oder so ähnlich)

    Also: Neue Schrift, ergo neues Layout, ergo endlich neues Programm. Nur damit keine Langeweile im Urlaub aufkommt.:-[
     
    #8 makra, 30.06.09
    Zuletzt bearbeitet: 30.06.09
  9. Rastafari

    Rastafari Golden Noble

    Dabei seit:
    10.03.05
    Beiträge:
    17.903
    Das hat nichts mit "XP-kompatibel" zu tun.
    Das ist eine lizenzrechtliche Sperrfunktion, die von älteren Ghostscript-Versionen noch nicht erkannt und respektiert wurde. Der Anbieter der Schrift kann damit verschiedene Verwendungsmöglichkeiten seines Fonts zulassen bzw sperren.

    Möglicherweise bekommst du sie doch eingebettet, wenn du den für Ghostscript verwendeten Pseudo-Drucker umkonfigurierst. Schicke TrueType-Schriften anstatt als "Typ 42 (TrueType nativ)" einfach als "Typ 1 (PS Outlines)", damit sollte es eigentlich wieder klappen (ist ungetestet, ich besitze keine gesperrten Fonts).
    Wichtig ist, dass du die folgenden Änderungen nicht über den Druckdialog, sondern global über die Systemsteuerung vornimmst (sonst gelten sie nur für das aktuell gedruckte Dokument).

    Systemsteuerung --> Drucker und Fax
    Den für die Ghostscript-Konvertierung verwendeten Drucker markieren.
    ---> Eigenschaften

    Erste Änderung:
    Panel "Allgemein" --> Druckeinstellungen... --> Erweitert...
    Die jeweils fett hervorgehobenen Werte (insgesamt sind es fünf) sind genau so einzustellen:
    Siehe Bild 1.
    Zweite Änderung:
    Panel "Geräteeinstellungen" -> Siehe Bild 2.

    Ausserdem solltest du (im Bild 2 sichtbar) die bereits bestehende Schriftenersetzungstabelle durchgehen und sicherstellen, dass bei ausnahmslos allen Fonts die Option "nicht ersetzen" eingestellt ist. (Nach den obigen Änderungen werden alle später neu hinzugefügten Fonts diese Einstellung erben.)

    Danach solltest du im Erstellerprogramm den zu verwendenden Drucker neu anwählen, damit diese neuen Werte auch zuverlässig aktiv werden. Vorsicht: Manche Programme speichern diese Einstellungen zusammen mit dem Dokument ab. Bei bereits existierenden Dokumenten also besser mal nachkontrollieren, ob da im Druckdialog die richtigen Werte aus der globalen Einstellung tatsächlich übernommen wurden.

    Und wenns damit nicht klappt bleibt dir evtl noch ein Ausweg. Der führt zwar zu etwas verringerter Darstellungsqualität, aber zur Not...
    Anstatt "Umriss" wählst du "Bitmap" und anstatt der "Null Pixel" jeweils 999 (oder den höchsten Wert der sich dort einstellen lässt?).
    Dann werden TrueType Fonts nicht mehr als Konturschrift, sondern als vorgerasterte kleine Schwarzweissbilder gesendet, idR mit 300 oder 600 dpi, je nach Druckermodell ("Typ 3 Font").
    Wie gesagt, das ist nicht grade toll (Text ist dann kein Text mehr, sondern nur noch Bilder von Text). "The last Resort" eben.
     
  10. makra

    makra Meraner

    Dabei seit:
    03.01.06
    Beiträge:
    229
    Das leuchtet ein - ich hatte auch schon an so etwas gedacht, aber nicht verstanden, warum ich bisher keine Probleme gehabt hatte...

    Deine Anweisung habe ich befolgt, leider flutscht es bisher nicht. Ist aber auch mal Zeit für eine neue Schrift...

    Vielen Dank noch mal.
     

Diese Seite empfehlen