1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Passwortabfrage bei Druckerinstallation

Dieses Thema im Forum "Drucker & Scanner" wurde erstellt von cfsatsss, 31.05.09.

  1. cfsatsss

    cfsatsss Idared

    Dabei seit:
    27.11.06
    Beiträge:
    27
    Ich habe zur Zeit bei der Installation Deinstallation von Druckern das Problem, dass ich immer das Passwort des zweiten Benutzers eingeben muss.

    Wortlaut der Meldung:

    "Geben Sie den Namen und das Kennwort des Benutzers in der Gruppe "Ipadmin" ein, um Systemeinstellungen zu erlauben, Änderungen vorzunehmen" Name: ******* Kennwort: ********"

    Erst nachdem ich mit dem Benutzer und dem Passwort des zweiten Adminbenutzers bestätigt habe, kann ich Drucker installieren oder wieder löschen.

    Ich habe bereits das Drucksystem zurückgesetzt und hoffe jemand kann mir sagen was es mit dem Ipadmin auf sich hat bzw. wie ich das abstellen kann.

    10.5.7 MBP Intel

    Vielen Dank
     
  2. pepi

    pepi Cellini

    Dabei seit:
    03.09.05
    Beiträge:
    8.741
    CUPS Config editieren:
    sudo vi /etc/cups/cupsd.conf

    <Limit Pause-Printer Resume-Printer Enable-Printer Disable-Printer Pause-Printer-After-Current-Job Hold-New-Jobs Release-Held-New-Jobs Deactivate-Printer Activate-Printer Restart-Printer Shutdown-Printer Startup-Printer Promote-Job Schedule-Job-After CUPS-Accept-Jobs CUPS-Reject-Jobs>
    AuthType Default
    Require user @AUTHKEY(system.print.admin) @admin @lpadmin
    Order deny,allow
    </Limit>

    Hier kann man die Einträge entfernen, die man nicht beschränken möchte. zB Pause-Printer, Resume-Printer, Pause-Printer-After-Current-Job.
    Danach die Datei speichern. Nach einem Neustart des Rechners können die entsprechenden Tätigkeiten auch ohne Admin Rechte durchgeführt werden.
    Gruß Pepi
     
  3. cfsatsss

    cfsatsss Idared

    Dabei seit:
    27.11.06
    Beiträge:
    27
    Hallo und Danke für die Antwort Pepi!

    Leider habe ich Probleme beim Umsetzten des Lösungsansatzes.

    Ich öffne das Terminal (habe damit noch nie gearbeitet) und gebe:
    sudo vi /etc/cups/cupsd.conf
    ein.
    Danach muss ich mein Passwort eingeben und es erscheint:

    LogLevel info
    SystemGroup admin
    SystemGroupAuthKey system.print.admin
    # Only listen for connections from the local machine.
    Listen localhost:631
    Listen /private/var/run/cupsd
    # Show shared printers on the local network.
    Browsing On
    BrowseOrder allow,deny
    BrowseAllow all
    DefaultAuthType Basic
    <Location />
    # Restrict access to the server...
    Order allow,deny
    </Location>
    <Location /admin>
    # Restrict access to the admin pages...
    Order allow,deny
    </Location>
    <Location /admin/conf>
    AuthType Default
    Require user @SYSTEM
    # Restrict access to the configuration files...
    Order allow,deny
    </Location>
    <Policy default>
    <Limit Send-Document Send-URI Hold-Job Release-Job Restart-Job Purge-Jobs Set-Job-Attributes Create-Job-Subscription Renew-Subscription Cancel-Subscription Get-Notifications Reprocess-Job Cancel-Current-Job Suspend-Current-Job Resume-Job CUPS-Move-Job>
    Require user @OWNER @SYSTEM
    Order deny,allow
    </Limit>
    <Limit CUPS-Add-Modify-Printer CUPS-Delete-Printer CUPS-Add-Modify-Class CUPS-Delete-Class CUPS-Set-Default>
    AuthType Default
    Require user @SYSTEM
    Order deny,allow
    </Limit>
    <Limit Pause-Printer Resume-Printer Enable-Printer Disable-Printer Pause-Printer-After-Current-Job Hold-New-Jobs Release-Held-New-Jobs Deactivate-Printer Activate-Printer Restart-Printer Shutdown-Printer Startup-Printer Promote-Job Schedule-Job-After CUPS-Accept-Jobs CUPS-Reject-Jobs>
    AuthType Default
    Require user @AUTHKEY(system.print.admin) @admin @lpadmin
    Order deny,allow
    </Limit>
    <Limit Cancel-Job CUPS-Authenticate-Job>
    Require user @OWNER @AUTHKEY(system.print.admin) @admin @lpadmin
    Order deny,allow
    </Limit>
    <Limit All>
    Order deny,allow
    </Limit>
    </Policy>

    NUN MEINE FRAGE:

    Was muss ich ändern, ich denke, die eine Stelle müsste bereits stimmen???

    Gibt es eine andere Möglichkeit das Problem zu lösen?

    Ich habe auch keine Ahnung wie es überhaupt zu dieser Restriktion gekommen ist. Wie entsteht das?

    THX
     
  4. cfsatsss

    cfsatsss Idared

    Dabei seit:
    27.11.06
    Beiträge:
    27
    Programme - Dienstprogramme - Verzeichnisdienste

    Danach Bearbeiten - Root aktivieren - root Passwort vergeben! Hier fertig!

    Bei der Nachfrage während der Installation Drucker als Benutzer root eingeben und danach das vergebene Passwort.

    Danach sollte der Spuk vorbei sein.
     
  5. bnetz

    bnetz Erdapfel

    Dabei seit:
    05.06.09
    Beiträge:
    3
  6. Knurrhahn

    Knurrhahn Jonagold

    Dabei seit:
    16.08.06
    Beiträge:
    19
    Genau das will ich nicht.

    Ich verwalte ein Netz, die Benutzerdaten und -Logins sind auf einem Server. Jedesmal, wenn jemand einen Drucker angehalten hat, kann er ihn nicht ohne Adminpassword wieder zum laufen kriegen. Da ich die Adminpasswörter nicht bekanntgeben will und auch nicht in den Gruppendefinitionen der Systemgruppen herumwurstel will, muss ich wohl auch diese Datei abändern.

    Wieso erlaubt Apple per default, dem OWNER einen Printjob zu unterbrechen, aber nicht, ihn wieder zu starten??
     
  7. pepi

    pepi Cellini

    Dabei seit:
    03.09.05
    Beiträge:
    8.741
    Dann stell doch im CUPS ein, daß ein User das selbst machen kann.
    Gruß Pepi
     

Diese Seite empfehlen