1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Parallels, Ubuntu und Vollbild auf dem zweiten Monitor

Dieses Thema im Forum "Linux auf dem Mac" wurde erstellt von DerKlops, 09.11.06.

  1. DerKlops

    DerKlops Jonagold

    Dabei seit:
    30.10.06
    Beiträge:
    18
    Hallo Allerseits!

    Auf der Arbeit bin ich Linux angewiesen, genauer gesagt Ubuntu. Ich habe dieses unkompliziert unter Parallels auf meinem MacBook installiert. Nur leider kann ich den Vollbildmodus nicht auf meinem externen Monitor korrekt aktivieren. Parallels skaliert maximal bis 1280x800 und nicht bis 1280x1024, sowie es der Monitor schaffen sollte. Mit WIndows XP unter Parallels ist das kein Problem. Da läuft das Wunderbar.

    Gibt es da einen Trick, oder muss ich was im Linux noch konfigurieren? Den X-Server habe ich schon angepasst und die entsprechenden Werte in die xorg.conf eingetragen. Leider ohne Erfolg.

    Für Hinsweise oder eine Lösung wäre ich dankbar.

    Gruß
    DerKlops
     
  2. stk

    stk Grünapfel

    Dabei seit:
    05.01.04
    Beiträge:
    7.141
    Moin,

    yep - kenne ich. Du mußt schon während der Installation von Ubuntu im Vollbildmodus arbeiten, dann erkennt der Installer die maximal Mögliche Auflösung. Ich nachhinein hab' ich's auch nicht mehr geändert bekommen.

    Gruß Stefan
     
  3. WuLF

    WuLF Jamba

    Dabei seit:
    27.05.05
    Beiträge:
    59
    Du kannst unter ubuntu die maximal auflösung in der gconf einstellen
    Die Datei findest du unter /etc/X11/

    Wenn mich meine Erinnerung nicht täuscht =)
     
  4. rohling

    rohling Gast

    ein

    sudo dpkg-reconfigure xserver-xorg

    sollte Dich durch die Konfiguration des X-Servers führen, wo Du am Ende die auflösung des Monitors einstellen kannst.
     
  5. blutaermer

    blutaermer Ingrid Marie

    Dabei seit:
    31.12.03
    Beiträge:
    273
    ich habe hier das gleiche problem:
    statt 1280x1024 macht das ding nur 1024x786 :(

    dpkg-reconfigure xserver-xorg habe ich dann versucht, aber da kam nur murks raus, ich weiss einfach nicht, was ich da einstellen muss.
    dann habe ich in der /etc/X11/xorg.conf rumgepfuscht und konnte auch die die aufloesung des anmeldebildschirms veraendern, aber nach der anmeldung ist x-server immer abgeschmiert und zu sehen war wieder der anmeldebildschirm :(

    vielleicht hat hier ja jemand eine xorg.conf die unter parallels funktioniert und wo genau gekennzeichnet ist, was man veraendern muss? *duck*

    das eintragen von alternativ-aufloesungen in parallels hat leider auch nix gebracht. und man kann das erst nach der installation machen - irgendwie bloed.

    das mit dem fulscreen modus wusste ich noch nicht. vielleicht sollte man sich fuer die installation dann einen externen monitor aussuchen, der eine moeglichst hohe aufloesung hat? skaliert ubuntu dann bei externen displays mit geringerer aufloesung automatisch runter?

    6.10 (edgy eft oder we das heisst) hat bei mir ein darstellungsproblem vor dem starten und nach dem beenden des xservers. also beim hoch- und runterfahren der maschine. das sehe ich naemlich exakt null meldungen. der bildschirm bleibt schwarz. bei 6.06 (dapper drake) war das nicht der fall. mal sehen ob ich das noch hinbekome, bevor der trial key auslaeuft - wenn nicht, dann kaufe ich mir jedenfalls kein parallels. ich warte ja immer noch auf vmware ...

    noch eine frage: kann man von linux aus (also aus der vm heraus) eine vpn-verbindung aufbauen?
     
  6. blutaermer

    blutaermer Ingrid Marie

    Dabei seit:
    31.12.03
    Beiträge:
    273
    ich habs jetzt nochmal mit dem cinema display probiert und im vollbildmodus, bin aber immer noch keinen schritt weiter.
    mehr als 1024x768 bietet er mir weiterhin nicht an ...
     
  7. kannst du das bestätigen, dass man die installation im vollbildmodus durchführen muss, um ubuntu mit der maximalen auflösung zu betreiben? also ich hab das auch probiert und mehr als 1024x768 geht auch so nicht.

    mir ist ansich auch nur bekannt, dass man die "xorg.conf" bearbeiten muss, um die auflösung zu maximieren.
     
  8. Wie macht man die Installation im Vollbildmodus eigentlich? Wenn ich von der Desktop CD boote kann ich zwar die Aufloesung aendern, soll mich dann aber ausloggen und den X Server (oder so) neustarten, kann mich dann aber irgendwie nicht mehr einloggen weil ich keine Zugangsdaten fuer die Desktop CD habe?

    Geht das irgendwie anders oder gibt es Zugangsdaten fuer die Desktop CD?
     
  9. DerKlops

    DerKlops Jonagold

    Dabei seit:
    30.10.06
    Beiträge:
    18
    Hallo,

    ich habs endlich hingekriegt. Musste dem Gastsystem erlauben unter Parallels die Auflösung zu ändern und anschließend habe ich die horiz. und verti. Refreshrates in der xorg.conf entsprechend angepasst. Seitdem kann ich wunderbar auf meinem externen Monitor mit Ubuntu im Vollbildmodus arbeiten.

    Gruß
    DerKlops
     
  10. blutaermer

    blutaermer Ingrid Marie

    Dabei seit:
    31.12.03
    Beiträge:
    273
    also ich habs mit dem vollbildmodus auch nicht hinbekommen!
    wo erlaube ich dem gastsystem die aufloeung zu veraendern?
    in den preferences?
    und wie mache ich das mit den refreshrates?
    woher weiss ich wie die sind? muss man die originalen des externen monitors nehmen? (woher bekomme ich diese?)
    funktioniert dann die installation auch noch, wenn man den externen monitor nicht am geraet hat?
     
  11. DerKlops

    DerKlops Jonagold

    Dabei seit:
    30.10.06
    Beiträge:
    18
    Hallo,

    @blutaermer: Einstellungen -- Benutzeroberfläche -- Vollbildoptionen. Dort sollte das Häckhen setzten können. Die Refreshrates enimmste Deinem Monitorhandbuch, oder Google oder Amazon. Du brauchst die von dem externen Monitor. Das ganze läuft dann auch mit 1280x800 auf deinem MacBook-Monitor. Musst halt die entsprechende Auflösung dann setzten. Obs mit anderen Werten gehte weis ich nicht. Kann ich aber mal ausprobieren...

    DerKlops
     
  12. blutaermer

    blutaermer Ingrid Marie

    Dabei seit:
    31.12.03
    Beiträge:
    273
    irgendwas scheine ich grundlegend falsch zu machen :(
    in der xorg.conf habe ich die werte eingetragen, die ich im netz gefunden habe.
    in den parallels-einstellungen sind beide haekchen gesetzt.
    in den einstellungen der vm habe ich die aufloesung 1280x1024 explizit angegeben.
    in der xorg.conf habe ich sogar alle bis auf 1280x1024 und 1024x768 rausgenommen. und trotzdem kann ich in den einstellungen die mir die ubuntu preferences anbieten keine aufloesung groesser 1024 finden ...

    irgendwie habe ich die seuche :)
     
  13. DerKlops

    DerKlops Jonagold

    Dabei seit:
    30.10.06
    Beiträge:
    18
    Moin,
    Komisch, ich musste nichtmal an den ubuntueinstellungen, hoffe du meinst z.B. das Monitor-Tool in KDE, etwas ändern. ich habe nur die werte geändert und den xorg neugestartet... dann stand auch im KDE-Monitor-Tool, oder wie das heist, die korrekte Auflösung drin. Wie betreibste denn Deinen externen Monitor, Mini-DVI-DVI oder Mini-DVI-VGA? Ich habe hier die erste Variante.

    Gruß
    DerKlops
     
  14. blutaermer

    blutaermer Ingrid Marie

    Dabei seit:
    31.12.03
    Beiträge:
    273
    also bei mir laeuft gnome.
    der monitor ist direkt an meier dvi buchse vom macbook pro.
    mehr kann ich jetzt auch nicht sagen, hab schon lange nicht mehr mit parallels rumgespielt und vielleicht hat sich das jetzt eh erledigt, da das neue parallels feature mich dazu ueberreden koennte statt linux windows zu virtualisieren.
    wobei dieses feature (coherency oder wie das heisst) auch mit linux moeglich war:
    aus der x11 applikation sich remote auf die virtualisierte linuxumgebung einloggen mit umleitung der x ausgabe ... habs selber noch nicht getestet, da ich selber nicht drauf gekommen bin ...
     

Diese Seite empfehlen