1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

OSX 10.4 PureFTP

Dieses Thema im Forum "Filetransfer" wurde erstellt von Simonsway, 07.01.07.

  1. Simonsway

    Simonsway Gast

    Hallo
    Wir haben ein Problem mit unserem OSX FTP Server.
    Wir haben soweit alles installliert geht auch alles soweit.
    Nur beim file listing braucht das Programm Transmit sehr lange.
    Vielleicht kennt jemand das Problem.

    Liebe Grüße

    Simon Eiler
     
  2. pepi

    pepi Cellini

    Dabei seit:
    03.09.05
    Beiträge:
    8.741
    Na dann gib uns doch noch ein paar mehr Details über den Setup.
    Gruß Pepi
     
  3. Simonsway

    Simonsway Gast


    Hallo
    Ok ich versuche mal alles zusammen zu schreiben.
    Es ist ein alter G4 Rechner mit OSX 10.4 ganz frische installation lauft soweit nur das Betriebssystem, Apache, Ftp mit PureFTP Server.
    Das ganze wird über Dyndns.org mit einem D-Link router geroutet sollte soweit passen port 80 und 21 werden geforwarded and die Ip.
    Wenn wir uns also von aussen verbinden wollen zum PureFTP Server dann geht das Listening fast immer sehr lange jetzt kann es sein das die Internet verbindung das Problem ist kann aber nicht sei n da ich im gleichen zuge noch ein Linux Server haben bei dem FTP zugriffe wunderbar funktionieren.
    Ich denke es ist nur eine kleien einstellung die das Problem behebt.


    Liebe Grüße


    Simon
     
  4. deepinpowder

    deepinpowder Reinette de Champagne

    Dabei seit:
    11.09.06
    Beiträge:
    415
    Hy,

    ja, das liegt am akiven und passiven FTP. Der Port 21 ist nur der Steuerport, dann wird eigentlich ein anderer Port geöffnet. Stelle mal im FTP Programm Passiv off.

    Gruß
     
  5. QuickMik

    QuickMik Stahls Winterprinz

    Dabei seit:
    30.12.05
    Beiträge:
    5.189
    der tipp von deepinpowder ist schon ganz gut.

    was mich aber noch interessieren würde.....
    der linux ist auch von aussen über port 21 erreichbar?

    wie sieht es aus, wenn du von innen die verbindung zum pureftp aufbaust?
     
  6. Simonsway

    Simonsway Gast

    Hallo
    Genau ja die Linux Kiste ist von aussen auch über port 21 erreichbar.
    Haus intern geht es auch gut mit dem OSX Server und PureFTP.
    Wir haben Passiven Mode schon probiert kein erfolg.
    Haus intern haben wir nartürlich Gigabit Ehternet somit schwer zu sagen da geht es schon sehr flot.

    Liebe Grüße

    Simon
     
  7. QuickMik

    QuickMik Stahls Winterprinz

    Dabei seit:
    30.12.05
    Beiträge:
    5.189
    wird schwierig.....glaube nicht, das es am mac liegt.
    eher am netzwerk
    dazu müsste man wissen, wer oder was hier firewall oder router spielt.

    und was heißt pasiv modus probiert?
    da kann man nicht einfach rumknipsen.
    dazu muss es ja portzuweisungen geben, die man auf der firewall freischaltet.

    womit verwaltet ihr den pureFTP?
    mit pureFTP manager?
     
  8. Simonsway

    Simonsway Gast

    Ich habe eh schon ein schlechtes Gewissen das sich hier einer so Mühe gibt.
    Wegen dem Pasiv modus haben wir nur im FTP Transmit umgestellt also nichts am router von wegen Port und Firewall.
    PureFTP wird mit dem Gui PureFTP Manager gesteuert ja.
    In der firewall haben ich einfach das DynDns modul eingeschalltet und in dem firewall das port forwarding also von der Ip 192.168.0.101 port 21 die Adresse wird dem OSX Server immer zugeteilt damit Dyndns funktioniert.

    Liebe Grüße

    Simon
     
  9. QuickMik

    QuickMik Stahls Winterprinz

    Dabei seit:
    30.12.05
    Beiträge:
    5.189
    warum denn...dafür sind foren ja da.
    man tut sich nur ein bissl leichter beim helfen, wenn der fragende auch infos preisgibt.

    das ist für nix. da geht es ja nur um den client und nicht um den server.

    na pipifein simon....dann hast du die hälfte ja schon hinter dir :)

    jetzt noch mit pureftp manager unter preferences -> server settings -> einen port range für den passiv modus zuweisen.
    das sollte natürlich mit der firewall gegengechecked werden.
    ich würde 3050-3100 nehmen ....oder so.

    in der firewall diese ports ebenfalls wie das 21er port auf den osx server umleiten.

    dann sollte das funktionieren.

    allerdings....kommen dann die nächsten probleme..... :(

    wenn jemand hinter einer firewall sich mit eurem server verbinden will, muss an dessen firewall diese ports nach aussen freigeschalten sein.
    und darauf hast du keinen einfluß :oops:

    wofür brauchst du denn einen ftp server?
    zum website laden oder als ersatz für einen ISDN server?

    ich meine....ist ja ohnehin das grindigste protokoll für einen datentransfer.

    ciao
    mike
     
  10. Simonsway

    Simonsway Gast

    Hallo Mike
    Wir verwenden das Protokol zum Fotos von überall aus in ein bestimmten Ordne zu laden das es ein Foto server sein sollte.
    Was für ein protokoll würdest du denn verwenden das auch für alle einfach ist und zugänglich.
    Wegen dem Port im PureFTP habe ich die ganze sache eingestellt jetzt kannn ich bei meinem router private port und public port eintragen ich sollte aber irgendwo die function von Port range haben oder das die ports von 3050 bis 3100 zu der Ip geroutet werden.
    Habe das mit Trigger aber dort kann ich keine Ip angeben jetzt bin ich mir nicht ganz sicher ober er die port einfach auf alle rechner im netzwerk verteilt oder nicht.
    Auf jeden fall habe ich es noch mal versucht mit dem Transmit geht immer noch nicht richtig.
    Ich habe dich eh mal angeskyped vielleicht können wir ja da mal tratschen.


    Liebe Grüße

    Simon
     
  11. QuickMik

    QuickMik Stahls Winterprinz

    Dabei seit:
    30.12.05
    Beiträge:
    5.189
    ist nicht so einfach. kommt immer drauf an.
    in diesem fall würde ich mir vielleicht einen webdav server basten.
    ist das gleiche protokoll wie die idisk von apple.

    kommt aber darauf an, weche systeme und welche dau´s darauf zugreifen müssen.
    viele sind ja schon mit einem ftp client überfordert.

    ich auch nicht .-)

    du würdest mich nicht hören......lieg zuhause mit einer heftigen erkältung rum und hab 0,1% stimme :(

    denke aber, wenn du das mit den pasiv ports hinbekommst, wird das pfeifen.
    mach beim proFTPd mal den portrange kleiner. 5 stück z.b.
    und richte die gleich wie beim 21er port am router ein

    ciao
    mike
     
  12. QuickMik

    QuickMik Stahls Winterprinz

    Dabei seit:
    30.12.05
    Beiträge:
    5.189
    was mir noch einfällt.
    hast du beim proFTP manager unter preferences-> server->optionen wohl

    force active mode...
    und die externe IP adresse drin?

    schick doch mal einen zugang zu dem server per PM.
    möcht mir mal das session log ansehen.
     
  13. Simonsway

    Simonsway Gast


    Hallo
    Na habe ich noch nicht gemacht.
    Welche Adresse sollte ich den da eintragen bei der externen Adresse da sich die ja immer verändert.

    Liebe Grüsse

    Simon
     
  14. QuickMik

    QuickMik Stahls Winterprinz

    Dabei seit:
    30.12.05
    Beiträge:
    5.189
    ist auch wieder wahr.
    gute voraussetztungen hast du ja nicht für einen ftp server :)
    keine statische IP und hinter einer FW auch noch...

    kannst du dort den dyndnsnamen eintragen?
     
  15. Simonsway

    Simonsway Gast


    Sonst kann ich auch ein Webdav einrichten wenn das besser geht.

    Liebe Grüße

    Simon Eiler
     
  16. pepi

    pepi Cellini

    Dabei seit:
    03.09.05
    Beiträge:
    8.741
    Du mußt auch die Ports der Passive Range auf die selbe interne IP wie den Port 21 forwarden. Sonst kann das nicht funktionieren. Mit active Mode wird übrigends niemand connecten können. Jedenfalls niemand der irgendeine Art von Firewall vor sich hat. (was heutzutage wohl wirklich jeder ist.)
    Gruß Pepi
     
  17. QuickMik

    QuickMik Stahls Winterprinz

    Dabei seit:
    30.12.05
    Beiträge:
    5.189
    ACK
    pepi hat wieder mal recht.
    active kann man vergessen.

    würde mich auf den webdav konzentrieren....
     

Diese Seite empfehlen