1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

OS X Server - langsamer Verbindungsaufbau

Dieses Thema im Forum "macOS & OS X Server" wurde erstellt von Ruprecht, 23.11.09.

  1. Ruprecht

    Ruprecht Braeburn

    Dabei seit:
    01.12.08
    Beiträge:
    47
    Hallo zusammen,

    wir haben seit geraumer Zeit ein kleines Problem mit unserem XServe. Der Verbingungsaufbau zum Server via AFP / SMB / VNC dauert eine halbe Ewigkeit. So ca. 30-60 Sec. muss man auf das Authentifizierungsfenster warten. Danach läuft alles wieselflink. Die Probleme fingen nach der Umstellung von 10.5 auf 10.6 an.

    Kann mir jemand einen Tip geben, wo der Fehler zu suchen ist?

    Grüße

    Ruprecht
     
  2. pepi

    pepi Cellini

    Dabei seit:
    03.09.05
    Beiträge:
    8.741
    Ohne Details nicht.
    Gruß Pepi
     
  3. Ruprecht

    Ruprecht Braeburn

    Dabei seit:
    01.12.08
    Beiträge:
    47
    Welche Details hättest du denn gerne?

    Gruß Ruprecht
     
  4. pepi

    pepi Cellini

    Dabei seit:
    03.09.05
    Beiträge:
    8.741
    Die üblichen Troubleshootingdaten, wir können nicht hellsehen…

    Betriebssytemversion wäre zum Beispiel ein guter Anfang, steht irgendwas in den Logs, Konfigurationen? Ich werds Dir aber nicht aus der Nase ziehen.
    Gruß Pepi
     
  5. Ruprecht

    Ruprecht Braeburn

    Dabei seit:
    01.12.08
    Beiträge:
    47
    OSX Version ist 10.6.2. Die Probleme fingen aber schon direkt nach dem Umstieg auf 10.6.1 an.
    Ich habe gerade die Logs durchgearbeitet, und bin beim DNS Log hängen geblieben:

    Code:
    24-Nov-2009 11:46:57.999 host unreachable resolving 'ns1.nameisp.info/A/IN': 2001:500:1c::1#53
    24-Nov-2009 11:46:57.999 host unreachable resolving 'ns1.nameisp.info/AAAA/IN': 2001:500:1b::1#53
    24-Nov-2009 11:46:57.999 host unreachable resolving 'ns1.nameisp.info/A/IN': 2001:500:1b::1#53
    24-Nov-2009 11:46:58.022 host unreachable resolving 'ns1.kolme.co.uk/AAAA/IN': 2001:630:181:35::83#53
    24-Nov-2009 11:46:58.023 host unreachable resolving 'ns3.kolme.co.uk/A/IN': 2001:502:ad09::3#53
    24-Nov-2009 11:46:59.635 unexpected RCODE (REFUSED) resolving 'www.getfirefox.com/AAAA/IN': 64.13.141.6#53
    24-Nov-2009 11:46:59.636 unexpected RCODE (REFUSED) resolving 'www.getfirefox.com/A/IN': 64.13.141.6#53
    24-Nov-2009 11:47:04.680 host unreachable resolving 'clicktorrent.info/A/IN': 2001:500:41::1#53
    24-Nov-2009 11:47:27.463 host unreachable resolving 'local/SOA/IN': 2001:500:2f::f#53
    24-Nov-2009 11:48:05.408 host unreachable resolving 'ns.web-solutions.dk/AAAA/IN': 2001:500:14:6036:ad::1#53
    24-Nov-2009 11:48:05.411 host unreachable resolving 'ns2.web-solutions.dk/AAAA/IN': 2a01:630:0:80::53#53
    24-Nov-2009 11:48:05.501 host unreachable resolving 'ns02.tdcwebmore.dk/A/IN': 2a01:3f0:0:303::53#53
    24-Nov-2009 11:48:54.844 host unreachable resolving 'www.id.uzh.ch/AAAA/IN': 2001:500:14:6047:ad::1#53
    24-Nov-2009 11:48:54.844 host unreachable resolving 'www.id.uzh.ch/AAAA/IN': 2001:620::5#53
    24-Nov-2009 11:49:08.997 host unreachable resolving 'prisoner.iana.org/A/IN': 2001:648:2c30::1:10#53
    24-Nov-2009 11:49:17.465 host unreachable resolving 'local/SOA/IN': 2001:500:3::42#53
    24-Nov-2009 11:49:24.197 host unreachable resolving 'ns.main-echo.de/A/IN': 2001:628:453:4905::53#53
    24-Nov-2009 11:49:47.579 host unreachable resolving 'ns6.bashtel.ru/A/IN': 2001:660:3005:1::1:2#53
    24-Nov-2009 11:50:05.720 host unreachable resolving 'ns2.starnetmedia.ro/A/IN': 2001:628:453:4001::53#53
    24-Nov-2009 11:50:17.467 host unreachable resolving 'local/SOA/IN': 2001:503:c27::2:30#53
    24-Nov-2009 11:50:17.467 host unreachable resolving 'local/SOA/IN': 2001:503:ba3e::2:30#53
    24-Nov-2009 11:50:17.467 host unreachable resolving 'local/SOA/IN': 2001:500:1::803f:235#53
    24-Nov-2009 11:51:27.468 host unreachable resolving 'local/SOA/IN': 2001:dc3::35#53
    24-Nov-2009 11:51:38.039 host unreachable resolving '219.131.37.95.zen.spamhaus.org/A/IN': 2001:7b8:3:1f::2:53:2#53
    24-Nov-2009 11:51:47.469 host unreachable resolving 'local/SOA/IN': 2001:7fd::1#53
    24-Nov-2009 11:53:22.482 host unreachable resolving 'local/SOA/IN': 2001:500:2f::f#53
    24-Nov-2009 11:53:25.966 unexpected RCODE (SERVFAIL) resolving '33.249.150.194.in-addr.arpa/PTR/IN': 194.150.248.107#53
    24-Nov-2009 11:54:52.207 host unreachable resolving 'ns2.telekabel.at/A/IN': 2001:678:d::cafe#53
    24-Nov-2009 11:54:52.207 host unreachable resolving 'ns2.telekabel.at/A/IN': 2001:4f8:4:b::202#53
    24-Nov-2009 11:55:42.132 host unreachable resolving 'local/SOA/IN': 2001:500:3::42#53
    24-Nov-2009 11:55:42.132 host unreachable resolving 'local/SOA/IN': 2001:500:1::803f:235#53
    24-Nov-2009 11:56:12.133 host unreachable resolving 'local/SOA/IN': 2001:503:c27::2:30#53
    24-Nov-2009 11:56:37.133 host unreachable resolving 'local/SOA/IN': 2001:503:ba3e::2:30#53
    24-Nov-2009 11:56:37.133 host unreachable resolving 'local/SOA/IN': 2001:dc3::35#53
    24-Nov-2009 11:56:50.939 unexpected RCODE (SERVFAIL) resolving 'ns2.ttnet.net.tr/A/IN': 212.156.4.20#53
    24-Nov-2009 11:56:50.964 unexpected RCODE (SERVFAIL) resolving 'dsl78.160-42429.ttnet.net.tr/A/IN': 212.156.4.20#53
    24-Nov-2009 11:57:56.711 host unreachable resolving '66.148.120.89.zen.spamhaus.org/A/IN': 2001:7b8:3:1f::2:53:1#53
    24-Nov-2009 11:59:13.618 lame server resolving 'ns1.volia.net' (in 'volia.net'?): 82.144.192.60#53
    24-Nov-2009 11:59:42.137 host unreachable resolving 'local/SOA/IN': 2001:7fd::1#53
    24-Nov-2009 11:59:52.116 unexpected RCODE (SERVFAIL) resolving '220.37.19.123.in-addr.arpa/PTR/IN': 203.162.4.1#53
    24-Nov-2009 12:00:35.740 host unreachable resolving 'cocoaheads.at/AAAA/IN': 2001:628:453:4302::53#53
    
    Ohne das gerade irgendjemand im Firmennetzwerk ist.
     
  6. pepi

    pepi Cellini

    Dabei seit:
    03.09.05
    Beiträge:
    8.741
    Na dann ist Dein Problem ja schon klar, oder? DNS und IPv6.
    Gruß Pepi
     
  7. Ruprecht

    Ruprecht Braeburn

    Dabei seit:
    01.12.08
    Beiträge:
    47
    Mmh, das Problem scheint klar, die Lösung nicht!

    Da wir "Daylite-Server" auf dem XServe laufen haben, müssen wir IPv6 client- und serverseitig deaktivieren. Dies habe ich unter "System Preferences / Network / Advanced" mit jedem Interface gemacht.
    Muss ich beim DNS-Server IPv6 separat deaktivieren? Wenn ja, wo?

    Grüße
     
  8. pepi

    pepi Cellini

    Dabei seit:
    03.09.05
    Beiträge:
    8.741
    Offenbar hast Du es nicht bei allen gemacht, da zumindest der Rechner dessen Log Du gepostet hast massenhaft IPv6 DNS requests macht und diese dann nicht erreichen kann.
    Warum mußt Du IPv6 deaktivieren für den Daylite Server?
    Gruß Pepi
     
  9. Ruprecht

    Ruprecht Braeburn

    Dabei seit:
    01.12.08
    Beiträge:
    47
    Deswegen:
    You're trying to login to a shared database on a local or remote connection, but it takes much longer than anticipated. One possibility is that IPv6 being incompatible with Bonjour is causing the problem.

    Wenn wir IPv6 aktiviert haben, dauert der Login (in die Daylite DB) über eine Minute.


    Mittlerweile funktioniert fast alles. Es lag wohl daran, dass nach dem Update auf 10.6 die /etc/dns/publicView.conf.apple vom ServerAdmin nicht mehr administriert werden konnte. Nachdem ich manuell ein paar "Reverse Zones" herausgeschmissen habe, geht nun alles wieder.

    Allerdings haben wir noch ein Problem:
    Wenn ich innerhalb der Firma per AFP auf eine Freigabe des Servers zugreife, dauert der Login-Prozess nur ein paar Millisekunden. Versucht ein Mitarbeiter dies extern über VPN, so muss er 120Sekunden auf das Loginfenster warten. Der VPN Nutzer kommt im gleichen IP-Range wie der interne Nutzer an. Beide haben denselben DNS-Server und Search-Domain Eintrag.
     
  10. pepi

    pepi Cellini

    Dabei seit:
    03.09.05
    Beiträge:
    8.741
    Reverse DNS Problem? Bandbreite?
    Gruß Pepi
     
  11. Ruprecht

    Ruprecht Braeburn

    Dabei seit:
    01.12.08
    Beiträge:
    47
    So, es lag teilweise am "Reverse DNS".

    Die Wartezeit auf das Loginfenster (beim Aufruf einer AFP-Freigabe) beträgt jetzt nur noch 15 Sekunden. Diese 15 Sekunden verschwinden, wenn ich die "Authentication Method" im ServerAdmin/AFP/Settings/Access von "Any Method" auf "Standard" setze.

    Aber:
    Der Zugriff auf dieselbe AFP-Freigabe dauert über VPN immer noch 15-20 Sekunden. Verbinde ich mich via VPN mit dem AFP-Dienst eines Linux-Rechners im selben Netzwerk beträgt die Wartezeit 0 Sekunden.

    Jemand die gleichen Probleme oder gar eine Lösung?

    Grüße
     

Diese Seite empfehlen