1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

OS X Apache problem

Dieses Thema im Forum "macOS & OS X" wurde erstellt von gnupi, 16.08.06.

  1. gnupi

    gnupi Gast

    hallo!
    ich bin noch etwas new2mac und habe folgendes problem:
    ich habe internet sharing und ftp aktiviert und komme unter
    http://meineip/
    auch auf die apachee seite.
    wenn ich allerdings auf
    http://meineip/~meinbenutzername
    gehe lande ich nicht, wie ich müsste in meinem sites-ordner, sondern werde weitergeleitet nach
    www.g4.local (g4 ist der rechnername)
    woran kann das liegen?
    somit komme ich ja von außerhalb nicht auf den webserver... :(
    kann man das dem apache irgendwo austreiben?

    wäre über hilfreiche tipps sehr dankbar!
    thx i.a.
    gnupi
     
  2. quarx

    quarx Hadelner Sommerprinz

    Dabei seit:
    17.04.05
    Beiträge:
    8.541
    Häng mal einen Slash an den URL, dann klappt's auch mit den Nachbarn. ;)
     
  3. gnupi

    gnupi Gast

    d'oh!
    manchmal ist das gute so nah, was? ;)

    besten dank...


    allerdings:
    warum ist er denn da so streng?
     
  4. quarx

    quarx Hadelner Sommerprinz

    Dabei seit:
    17.04.05
    Beiträge:
    8.541
    Schau mal in diesen Beitrag, das liegt an der Art und Weise, wie Apache mit dem (existierenden oder fehlenden) Slash am Ende des URL umgeht.
    Hatte ich bis dato auch nicht gewusst, bringe das aber seitdem bei jeder (un)passenden Gelegenheit an. :cool:
     
  5. stk

    stk Grünapfel

    Dabei seit:
    05.01.04
    Beiträge:
    7.141
    Moin,

    weil die Standardconfiguration in httpd.conf so eingestellt ist. Kannst ja ändern.

    Gruß Stefan
     

Diese Seite empfehlen