1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Ordner lässt sich nicht löschen

Dieses Thema im Forum "macOS & OS X" wurde erstellt von gammler1403, 25.12.08.

  1. gammler1403

    gammler1403 Damasonrenette

    Dabei seit:
    10.01.08
    Beiträge:
    484
    Hallo,

    ich habe einen Ordner mit Unterordnern. In den Unterordnern befindet sich Musik aus Radiomitschnitten. Nun möchte ich einen dieser Ordner löschen. Nur lässt er sich nicht löschen. Wenn ich ihn in den Papierkorb ziehe, werde ich nach meinem PW gefragt, eingegeben, dann OK und es tut sich nichts, nur ein kurzes Geräusch (Löschengeräusch). Der Inhalt selber lässt sich löschen, der Ordner jedoch nicht :(

    Wer kann mir helfen??

    LG, Tobias
     
  2. uwe9

    uwe9 ̈Öhringer Blutstreifling

    Dabei seit:
    27.06.05
    Beiträge:
    5.566
    .. mal Papierkorb sicher entleeren versucht? o_O
     
  3. gammler1403

    gammler1403 Damasonrenette

    Dabei seit:
    10.01.08
    Beiträge:
    484
    Mhhh, wie gehtn das? Also der Papierkorb ist ja leer. Und dann zieh ich den Ordner da rein und dann kommt das Löschengeräusch und es passiert nichts...
     
  4. s23

    s23 Seidenapfel

    Dabei seit:
    23.11.08
    Beiträge:
    1.333
    Geh mal in den Terminal, gib ein "rm -r" und dann ein Leerzeichen und dann zieh den Ordner auf das Terminalfenster. Nun sollte da der Pfad zu dem Ordner stehen. Dann noch "Enter" auf der Tastatur und der Ordner sollte ohne Widerworte gelöscht werden. Evtl. musst du noch dein Kennwort eingeben.
     
  5. gammler1403

    gammler1403 Damasonrenette

    Dabei seit:
    10.01.08
    Beiträge:
    484
    Nun ja, irgendwie gehts immer noch nicht :(

    Code:
    iMac:~ tobiaskaufmann$ rm -r /Users/tobiaskaufmann/Music/Musik\ \(ClipInc\)/1Live\ Diggi 
    rm: /Users/tobiaskaufmann/Music/Musik (ClipInc)/1Live Diggi: Operation not permitted
    
     
  6. DBertelsbeck

    DBertelsbeck Tiefenblüte

    Dabei seit:
    20.04.04
    Beiträge:
    6.425
    Du hast keine Rechte an dem Ordner.
    CMD-I zeigt Dir die Rechte an, Du musst sie ändern.
     
  7. s23

    s23 Seidenapfel

    Dabei seit:
    23.11.08
    Beiträge:
    1.333
    Probiers mal mit einem "sudo" vor dem ganzen Befehl. Wenn das nicht geht, fehlen deinem Benutzer Verwaltungsrechte. Du solltest dann das ganze nochmals als Computerverwalter (neusprech: root) probieren.

    Oder du setzt eben die Rechte neu:

    chown tobiaskaufmann "datei/ordner"
    chmod 777 "datei/ordner"
     
  8. gammler1403

    gammler1403 Damasonrenette

    Dabei seit:
    10.01.08
    Beiträge:
    484
    Muss ich den Pfad für den Ordner dann in Anführungszeichen setzen?

    Wie kann man sich als "root" anmelden? (Bin erst vor 3 Monaten umgestiegen^^)
     
  9. s23

    s23 Seidenapfel

    Dabei seit:
    23.11.08
    Beiträge:
    1.333
    Nein, du machst das wie zuvor auch. Befehl und dann Leerzeichen und dann den Ordner/Datei in das Fenster ziehen.

    Im Terminal meldest du dich als root wie folgt an: su oder login root. Dann wirst du nach dem Kennwort gefragt. Dies muss natürlich gesetzt sein. Normalerweise hast du als Standardbenutzer aber Verwaltungsrechte. Bei Problemen wg. fehlender Rechte liegt das zumeist daran, dass die Datei nur falsch gesetzte Rechte hat. Dies kannst du mit obigen Befehlen recht einfach lösen.
     
  10. gammler1403

    gammler1403 Damasonrenette

    Dabei seit:
    10.01.08
    Beiträge:
    484
    Hm, habs in der HIlfe gefunden. Nur ist bei mir im Verzeichnisdienst nirgendwo ein "Bearbeiten"-Button (so wie es in Schritt 3 der Hilfe beschrieben ist)....
     
  11. s23

    s23 Seidenapfel

    Dabei seit:
    23.11.08
    Beiträge:
    1.333
    Dazu kann ich nichts sagen. Ich arbeite lieber im Terminal direkt.

    Hast du denn die Rechte neu gesetzt und den Löschvorgang nochmal probiert?
     
  12. gammler1403

    gammler1403 Damasonrenette

    Dabei seit:
    10.01.08
    Beiträge:
    484
    Also die Rechte hab ich repariert (chown tobiaskaufmann "datei/ordner"
    chmod 777 "datei/ordner"), löschen kann ich den Ordner immer noch nicht. Wenn ich im Terminal "login root" eingebe werde ich nach dem PW gefragt, welches ich glaube ich noch nicht gesetzt habe (wie gesagt, bin mit dem Mac noch nicht soo vertraut^^)...und aktivieren kann ich den root-Account via Verzeichnisdienst auch nicht :(
     
  13. gammler1403

    gammler1403 Damasonrenette

    Dabei seit:
    10.01.08
    Beiträge:
    484
    Weiteres Problem: Wenn ich im Terminal mein PW eingeben will reagiert die Tastatur nicht auf die Buchstaben :(

    Was ist hier nur los :(
     
  14. s23

    s23 Seidenapfel

    Dabei seit:
    23.11.08
    Beiträge:
    1.333
    Hast du mal ein "sudo rm -r ordner" ausprobiert? Du wirst dann nach deinem normalen Kennwort gefragt.

    Das ist auch richtig so. Es wird nicht angezeigt, wieviel Zeichen du eingegeben hast. Mit Absicht.
     
  15. gammler1403

    gammler1403 Damasonrenette

    Dabei seit:
    10.01.08
    Beiträge:
    484
    Code:
    iMac:~ tobiaskaufmann$ sudo rm -r /Users/tobiaskaufmann/Music/Musik\ \(ClipInc\)/1Live\ Diggi 
    
    WARNING: Improper use of the sudo command could lead to data loss
    or the deletion of important system files. Please double-check your
    typing when using sudo. Type "man sudo" for more information.
    
    To proceed, enter your password, or type Ctrl-C to abort.
    
    Password:
    rm: /Users/tobiaskaufmann/Music/Musik (ClipInc)/1Live Diggi: Operation not permitted
    iMac:~ tobiaskaufmann$ sudo rm -r/Users/tobiaskaufmann/Music/Musik\ \(ClipInc\)/1Live\ Diggi 
    rm: illegal option -- /
    usage: rm [-f | -i] [-dPRrvW] file ...
           unlink file
     
  16. gammler1403

    gammler1403 Damasonrenette

    Dabei seit:
    10.01.08
    Beiträge:
    484
    Ich hab die Lösung!

    Der Oberordner Musik (Clipink) war geschützt. Deswegen konnte ich den Unterordner "1Live Diggi" nicht löschen. Mich wundert nur, dass ich den Inhalt des Unterordners löschen konnte...*hmmm*
     
  17. s23

    s23 Seidenapfel

    Dabei seit:
    23.11.08
    Beiträge:
    1.333
    Naja, du musst auch schon zwischen dem Befehl und dem zu löschenden Ordner ein Leerzeichen lassen ;)
     
  18. MacMark

    MacMark Biesterfelder Renette

    Dabei seit:
    01.01.05
    Beiträge:
    4.709
    Achte mal auf Deine Syntax:
    Leerzeichen nach -r machen. Am besten ist Du tippst "sudo rm -r " und ziehst dann die Datei/Verzeichnis ins Terminal.
     
  19. gammler1403

    gammler1403 Damasonrenette

    Dabei seit:
    10.01.08
    Beiträge:
    484
    Okay, vielen Dank schon mal :)
     
  20. MacMark

    MacMark Biesterfelder Renette

    Dabei seit:
    01.01.05
    Beiträge:
    4.709
    Das Unterverzeichnis hatte das Flag nicht gesetzt.
     

Diese Seite empfehlen