1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

OD Admin Permissions verloren...

Dieses Thema im Forum "macOS & OS X Server" wurde erstellt von MacMapple, 05.01.10.

  1. MacMapple

    MacMapple Boskop

    Dabei seit:
    22.12.09
    Beiträge:
    205
    Hallo zusammen,
    die OpenDirectory (OD) Administration auf dem MacMini “Snow Leopard” Server bereitet mir Schwierigkeiten. Aus unerfindlichen Gründen habe ich offensichtlich die administrativen Rechte im OpenDirectory verloren. Die folgende Bilderserie zeigt die Fehlermeldungen:

    http://www.grobator.de/artikel/opendirectory-das-unbekannte-wesen

    Über sachdienliche Hinweise in dieser Angelegenheit wäre ich sehr dankbar.
     
  2. harrym

    harrym Fuji

    Dabei seit:
    26.04.06
    Beiträge:
    37
    Hi MacMapple,

    ich habe auch wochenlang mit einer vergurkten OD Konfiguration herumgekämpft, weiß aber bis heute nicht genau, woran es gelegen haben mag. Google habe ich rauf unf runter abgegrast, den Apple-Support genervt und trotzdem keine Lösung bekommen. Was auf jedenfall für gehörigen Ärger sorgt, ist das Installieren von SLS ohne funktionierende Namensauflösung via DNS.

    Zwischenzeitlich hat "Zugriffsrechte reparieren" mal geholfen und Neustart hat auch schon mal vorübergehend Linderung gebracht, aber irgendwie kam mein Server immer mehr in die Abwärtsspirale und die Fehlermeldungen häuften sich...

    Irgendwann habe ich aufgegeben und in einer Wochenendschicht den Server neu installiert und vorher dafür gesorgt, dass mit absoluter Sicherheit die Namensauflösung im Netz in beide Richtungen funktioniert.

    Außerdem habe ich in der Standardinstallation weniger Dienste automatisch einrichten lassen, nur den OD Master. Ich könnte mir vorstellen, dass hier der Hund begraben liegt. Vielleicht erstmal nur ein nacktes Basissystem aufsetzen und dann später nach und nach die benötigten Dienste von Hand einrichten und mit dem OD anfangen.

    Bei mir läuft der Server jetzt stablier, die komischen Fehlermeldungen vom OD sind weg, aber ich habe immer noch merkwürdige Phänomene zu beklagen, die will ich aber jetzt hier nicht auch noch breittreten.

    Good Luck!
     
  3. stk

    stk Grünapfel

    Dabei seit:
    05.01.04
    Beiträge:
    7.141
    Moin,

    mit OD anfangen ist eine schlechte Idee. Der läuft nur vernünftig (und kerberisiert) wenn zuvor der DNS korrekt auflöst!

    Wäre noch spannend zu wissen ob der am WGM angemeldete User »aur« auch administrative Rechte auf den OD hat.

    Gruß Stefan
     

Diese Seite empfehlen