1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Numbers und Referenzen?

Dieses Thema im Forum "iWork" wurde erstellt von KoljaLauterbach, 26.01.09.

  1. KoljaLauterbach

    KoljaLauterbach Golden Delicious

    Dabei seit:
    26.01.09
    Beiträge:
    11
    Moin Moin!

    Erster Post und gleich eine Frage ;)

    Ich habe eine Numbers Tabelle in der sich zwei Spalten befinden (Datum und eine Zahl)
    Jetzt möchte ich zweierlei:

    1. Aus Spalte 2 den höchsten Wert finden. Das ist kein Problem: NGRÖSSTE(Spalte B)
    2. Das entsprechende Datum zu Berechnung 1 finden.

    Und das ist jetzt mein Problem. Ich habe keine Möglichkeit finden können über die durch 1. errechnete Zahl die Spalte zu bestimmen, geschweige denn eine Referenz auf den Datumseintrag in der 1. Spalte zu finden.

    Hat hier jemand eine Idee?

    LG Kolja
     
  2. KoljaLauterbach

    KoljaLauterbach Golden Delicious

    Dabei seit:
    26.01.09
    Beiträge:
    11
    Also...

    Nach langer Suche und kaufen eines Buches habe ich tatsächlich eine Funktion gefunden...

    =SVERWEIS(MAX(G2:G33);A2:G33;1;FALSCH)

    Leider scheint die Funktion nicht zu funktionieren. Ich habe ein ganz einfaches Beispiel versucht, aber der Wert wird nie(!) gefunden, egal was ich mache...

    Könnte das einer von euch mal verifizieren?

    Vielen Dank!

    MfG Kolja
     
  3. KoljaLauterbach

    KoljaLauterbach Golden Delicious

    Dabei seit:
    26.01.09
    Beiträge:
    11
    Hier die Lösung!

    Also, auch auf die Gefahr hin, dass das hier ein kompletter Monolog wird ;)

    Die Formel war schon ganz richtig:

    =SVERWEIS(MAX(G2:G33);C2:G33;1;FALSCH)

    Der Knackpunkt liegt in folgenden kleinen Detail, welches ich beim ersten Lesen der Funktionsbeschreibung einfach übersehen habe.

    Der Wertebereich (an Pos. 2) scannt NICHT alle Spalten wie ich zu erst vermutet hatte, sondern nur die erste, in diesem Falle Spalte C!

    Das bedeutet, dass die Sache wie ich sie haben wollte so nicht ganz funktioniert, denn wer will das Datum schon nach dem Wert haben ;)

    Als kleinen Workaround habe ich jetzt einfach in einer Spalte NACH dem Wert noch einmal eine Referenz auf die Datumsspalte gesetzt. Das sieht zwar beknackt aus, funktioniert aber...

    Hoffe, dass meine Lösung für irgendwen nützlich ist ;)

    LG Kolja
     

Diese Seite empfehlen