1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

[Numbers] Formeln die auf (noch) leere Zellen Bezug nehmen

Dieses Thema im Forum "iWork" wurde erstellt von Soul Monkey, 25.11.07.

  1. Gibt es bei Numbers die Moeglichkeit Formeln dahingehend zu modifizieren das wenn diese auf noch leere Zellen Bezug nehmen keine Berechnung erfolgt?

    Ich habe naemlich das Problem das in einer Zelle immer ein absolut utopischer Wert steht und in den anderen Zellen eine 0.

    Es sieht weder schoen aus noch ist es sinnvoll von Numbers eine Berechnung durchzufuehren obwohl eine Komponente fehlt.

    Bei meiner Tabelle wird jeden Sonntag ein Wert per Hand eingegeben und von diesem der Wert von letzter Woche abgezogen. Die Differenz wird in eine neue Spalte eingetragen und danach mit einem fixen Wert multipliziert. Das Produkt wird in eine neue Spalte/Zelle geschrieben.

    Ich habe die Formeln fuer eine Zeile eingegeben und dann in jeder Spalte die betreffende Zelle per Maus nach unten gezogen und so die Formeln fuer mehrere Zeilen/Zellen "kopiert".

    Also was ich will ist das Numbers mir keine falschen Werte oder Nullen hinschreibt weil ein fuer die Berechnung erforderlicher Wert eben noch fehlt.
     
  2. Hobbes_

    Hobbes_ Gast

    Ich weiss leider nicht, ob Numbers dafür sogar eine spezielle Funktion zur Verfügung stellt. Ein Workaround, der auch in Excel immer gut funktioniert, ist eine WENN-Abfrage um die eigentliche Berechnung zu bilden. In Excel funktioniert das so:
    Code:
    =WENN(UND(A1<>"";B1<>"");A1+B1;"")
    Ich nehme mal an, dass Numbers auch solche logischen Funktionen anbietet. Vielleicht kannst Du mit diesen Überlegungen etwas anfangen.
     
  3. Numbers bietet eine Vielzahl solcher Funktionen, vielleicht liegt es an den - meiner Meinung nach - teilweise recht aussagelosen (zumindest fuer mich als Laien - sollte aber beim Mac keine Rolle spielen) deutschen Beschreibungen das ich damit nichts anfangen konnte.

    Dein Beispiel funktioniert uebrigens bestens, genau so habe ich mir das vorgestellt. Danke!
     
  4. Hobbes_

    Hobbes_ Gast

    Das freut mich. Danke auch Dir :)
     

Diese Seite empfehlen