• Es gibt nach dem Softwareupdate eine Reihe von Änderungen und Neuerungen in unserem Forum. Genaueres dazu findet Ihr in dieser Ankündigung. Hinweise, Kritik, Anregungen, Lob und Tadel bitte hier diskutieren.

[Numbers] Numbers - Blatt mit Formeln in andere Numbers Datei kopieren

DeSaint2204

Erdapfel
Mitglied seit
18.03.19
Beiträge
2
Hallo,

ich habe 2 Dateien. In Datei1 habe ich 2 Arbeitsblätter, Blatt1 und Blatt2. In Blatt1 nutze ich eine Formel, die sich auf Blatt2 bezieht, z.B. steht in Zelle A1 von Blatt1 die Formel: "=SUMME(Blatt1::Tabelle 1::A1:A5)"


Jetzt kopiere ich Blatt1 und füge es in Datei2 ein. In der Zelle des eingefügten Blatt1, in der vorher die Formel stand, steht jetzt nur noch das Ergebnis der Formel, die Formel selbst ist verschwunden.


Ich vermute, dass Numbers die Formel durch den Wert ersetzt, weil es in der neuen Datei kein Blatt2 gibt.


Gibt es einen Weg, das Blatt1 in Datei2 zu kopieren, so dass die Formeln, die sich auf andere Tabellenblätter der 1. Datei beziehen, erhalten bleiben?


PS: In Excel kann ich mehrere Tabellenblätter markieren und "gemeinsam" in einen neue Datei verschieben. Die Formeln bleiben erhalten. Gibt es ein Äquivalent in Numbers?


Danke und Gruß

Christian
 

DeSaint2204

Erdapfel
Mitglied seit
18.03.19
Beiträge
2
Hallo,

ich habe mich an den Support gewandt, der nach "Eskalation" an die "Ingenieure" die Antwort gab: "works as designed". Also ist so nicht im Programm vorgesehen. Weder das gleichzeitige kopieren mehrerer Blätter funktioniert, noch funktioniert es, erst Blatt 2 und im Anschluss Blatt 1 zu kopieren. Damit sollte man sich gut überlegen eine vorhandene Datei zu trennen und nur einen Teil separat weiter zu bearbeiten, da man die beiden Dateien dann nicht mehr zusammenführen kann (wenn die Formeln über die Arbeitsblätter hinweg verweisen).

Danke und Gruß

Christian


PS: ich habe ein Skript in "AppleScript" geschrieben, welches zellenweise den Inhalt der Datei 1 in den Inhalt der Datei 2 kopiert. Das geht dann...