1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Ntfs-3g

Dieses Thema im Forum "Unix & Terminal" wurde erstellt von Atelis, 26.04.07.

  1. Atelis

    Atelis Akerö

    Dabei seit:
    01.03.07
    Beiträge:
    1.831
    ich habe jetzt versucht "NTFS-3G" zu installieren. ich habe

    1. MacFUSE Core 0.2.5 installiert
    2. Neu gestartet...
    3. MacFUSE Tools installiert
    4. NTFS-3G installiert
    5. Nochmal neu gestartet...

    müsste jetzt als nächstes die windows-partition aktivieren - und zwar mit dem terminal. habe folgenden befehl versucht:

    Code:
    mount -t ntfs-3g /dev/disk0s3 /Volumes/Windows\ HD
    aber da scheint noch irgendwas falsch zu sein. kann mir jemand helfen?? finde im internet nur linux-anleitungen...
     
  2. delycs

    delycs Weigelts Zinszahler (Rotfranch)

    Dabei seit:
    13.09.06
    Beiträge:
    245
    mal als root (sudo) probiert?
     
  3. action

    action Tydemans Early Worcester

    Dabei seit:
    15.11.05
    Beiträge:
    389
    Auch wenn ich dir jetzt nicht direkt helfe damit.
    Für was ist diese ntfs-3g genau? man kann ja mittlerweile NTFS schreiben und lesen unter OSX, oder gibts da irgendwelche einschränkungen von denen ich nichts weis.
    Erscheint eine fehlermeldung??
     
  4. Atelis

    Atelis Akerö

    Dabei seit:
    01.03.07
    Beiträge:
    1.831
    nee, man kann nur lesen. mit NTFS-3G soll man dann auch schreiben können...


    mit sudo hatte ich auch schon probiert - passiert auch nichts... poste gleich mal die fehlermeldung, die da kommt...
     
  5. action

    action Tydemans Early Worcester

    Dabei seit:
    15.11.05
    Beiträge:
    389
    ich hab erst gestern auf die externe USB platte eines freundes bei der ein partition mit 80gb mit ntfs formatiert ist eine datei hinverschoben und es hat funktioniert. ich habs ihm ja auch nicht geglaubt das das geht vom mac aus, aber es hat funktioniert. hab OSX 10.4.9, werd morgen mal screenshots machen von.
     
  6. Atelis

    Atelis Akerö

    Dabei seit:
    01.03.07
    Beiträge:
    1.831
    ich weiß nicht warum, aber ich habe die MacFUSE Tools und NTFS-3G mit den beigefügten scripts einmal entfernt und wieder installiert - nach einem neustart geht es jetzt, ohne dass ich was ins terminal eingeben muss... o_O
    er bindet die partition bei der anmeldung als netzlaufwerk ein (hat zumindest das icon) und man kann das laufwerk problemlos auswerfen und mit dem festplattendienstprogramm auch wieder aktivieren...

    jetzt habe ich mich einmal abgemeldet und wieder angemeldet und alles ist wieder wie vorher: kein netzwerkvolume, nur normale ntfs-partition, auf die ich nicht schreiben kann... :(


    meine interne partition war bis jetzt aber immer schreibgeschützt - auch mit 10.4.9 ...
     
  7. action

    action Tydemans Early Worcester

    Dabei seit:
    15.11.05
    Beiträge:
    389
    ist interessant. ich werd morgen der sache nachgehen warum das geht mit der externen.
    bis morgen dann.
    mfg
    action
     
  8. Atelis

    Atelis Akerö

    Dabei seit:
    01.03.07
    Beiträge:
    1.831
    so, hier die fehlermeldung nach dem sudo befehl:

    Code:
    sudo mount -t ntfs-3g /dev/disk0s3 /Volumes/Windows\ HD
    Password:
    Volume is dirty.
    Run chkdsk and try again, or use the force option.
    ERROR: couldn't mount volume : No such file or directory
    Volume is scheduled for check. Please boot into Windows TWICE, or
    use the 'force' mount option. For example type on the command line:
    
                mount -t ntfs-3g /dev/disk0s3 /Volumes/Windows HD -o force
    
        Or add the option to the relevant row in the /etc/fstab file:
    
                /dev/disk0s3 /Volumes/Windows HD ntfs-3g defaults,force 0 0
     
  9. pepi

    pepi Cellini

    Dabei seit:
    03.09.05
    Beiträge:
    8.741
    Das Filesystem ist nicht clean runtergefahren worden und daher noch als "dirty" markiert. Wird ja auch vorgeschlagen es zu überprüfen. Also an den Windows PC dran und dort mich chkdsk korrigiert, dann ordentlich abmelden und nochmal versuchen.
    Oder eben -f (force) beim mounten angeben.
    Gruß Pepi
     
  10. Rastafari

    Rastafari Golden Noble

    Dabei seit:
    10.03.05
    Beiträge:
    17.896
    DAS bei einem NTFS-Volume zu tun, das als "dirty" getagged ist, ist eine SEHR schlechte Idee.
    Wenn an diesem Flag auch nur das kleinste Fitzelchen "Wahrheit" ist und das nicht nur "einfach so übriggeblieben ist", also nur "nicht mehr weggeräumt" wurde, als man es hätte angstfrei entfernen können (sobald das Journal leergespult und die ACL-Sets richtiggestellt sind...)
    ...dann gibt es Datenverlust in unvorhersehbarem Umfang unter GARANTIE! Mit Brief und Siegel. Und die Wahrscheinlichkeit ist HOCH.
     
  11. Atelis

    Atelis Akerö

    Dabei seit:
    01.03.07
    Beiträge:
    1.831
    wie genau stelle ich das an? geht das auch, wenn ich unter windows angemeldet bin?? kenne wohl die eingabeaufforderung, aber nicht den befehl chkdsk - weiß nur, dass er das dateisystem repariert und ausgeführt wird, wenn das system nicht sauber runtergefahren ist...
     
    #11 Atelis, 26.04.07
    Zuletzt bearbeitet: 26.04.07
  12. iPoe

    iPoe Pomme Etrangle

    Dabei seit:
    07.03.05
    Beiträge:
    910
    hallo,
    normal reicht es windows zu starten, die platte anzuschließen und dann sauber herunterzufahren.
    sonst über den explorer, rechte maustaste und unter eigenschaften kannst du einen checkdisk veranlassen...


    iPoe
     
  13. Atelis

    Atelis Akerö

    Dabei seit:
    01.03.07
    Beiträge:
    1.831
    danke, seltsamerweise hatte ich das so auch das letzte mal gemacht, aber bei diesem hochfahren, hat er das ganze nochmal gemacht. naja...

    es scheint jetzt alles zu funktionieren: windows hd wird als netzlaufwerk eingebunden.
    wenn man sie auswirft kann man sie nur mit dem festplattendienstprogramm wieder mounten...
     
  14. Atelis

    Atelis Akerö

    Dabei seit:
    01.03.07
    Beiträge:
    1.831
    ok, habe herausgefunden, warum ich zwischendurch chkdsk ausführen sollte: ich hatte die windows-partition mit dem festplattendienstprogramm repariert... o_O ok, jetzt weiß ich woran es lag...


    noch eine kleine hilfe: wenn man das volume ausgeworfen hat, kann man es mit diesem applescript wieder aktivieren:

    Code:
    on run {}
    	
    	set theDisk to "disk0s3"
    	
    	-- Überprüfen, ob Volume gemountet ist
    	set mountpoint to do shell script "diskutil information " & theDisk & " | grep \"Mount Point\" | awk '{print $3}'"
    	if mountpoint is "" then
    		-- Volume soll gemountet werden
    		try
    			do shell script "diskutil mount " & theDisk
    		end try
    		(*else
    	-- Volume soll ausgeworfen werden
    	try
    		do shell script "diskutil unmount " & theDisk
    	end try*)
    	end if
    	
    end run
    wer die klammern (* und *) entfernt, kann die partition mit dem script auch auswerfen, allerdings dauerte das bei mir seltsam lange - wenn ich den befehl direkt im terminal ausführe, dauert das deaktivieren nicht so lange - keine ahnung, woran das liegt...

    alternativ kann man natürlich auch das festplattendienstprogramm starten und das volume aktivieren...
     
  15. Hnk

    Hnk Schöner von Nordhausen

    Dabei seit:
    14.05.06
    Beiträge:
    320
    externe Festplatte taucht nicht mehr auf Desktop auf

    Hi,

    seitdem ich NTFS-3g installiert hab, wird meine externe Festplatte zwar erkannt (im Festplattendienstprogramm), aber ich kann nicht mehr auf sie zugreifen. Ich habe die Festplatte noch aus Windows Zeiten und deswegen NTFS formatiert, weswegen ich eigentlich MacFUSE und NTFS-3g installiert habe. Das Windows-Laufwerk taucht, wie es sein sollte, als Netzwerklaufwerk auf. Aber die externe Platte nicht. Was kann ich machen?
     
  16. Atelis

    Atelis Akerö

    Dabei seit:
    01.03.07
    Beiträge:
    1.831
    hast du auch die macfuse-tools installiert?

    du brauchst 3 installer:

    1. MacFUSE-Core
    2. MacFUSE Tools
    und 3. NTFS-3G

    und auch in der reihenfolge, ne??
     
  17. Hnk

    Hnk Schöner von Nordhausen

    Dabei seit:
    14.05.06
    Beiträge:
    320
    Ich hab die drei Sachen installiert, aber die Reihenfolge wahrscheinlich nicht beachtet. Wie kann ich denn die Sachen deinstallieren?
     
  18. Atelis

    Atelis Akerö

    Dabei seit:
    01.03.07
    Beiträge:
    1.831
    es liegen uninstall-scripte in der dmg.
     
  19. Hnk

    Hnk Schöner von Nordhausen

    Dabei seit:
    14.05.06
    Beiträge:
    320
    Also irgendwie komm ich mit der Deinstallation nicht weiter. Kann mir mal jemand ne Quelle angeben, von der ich MacFuse runterladen kann und in der auch ein Uninstall-Skript im dmg liegt? In meiner ist nämlich anscheinend keins drin...
     
  20. Atelis

    Atelis Akerö

    Dabei seit:
    01.03.07
    Beiträge:
    1.831
    unten rechts die beiden doppelklicken - fertig!
     

    Anhänge:

Diese Seite empfehlen