1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Novell-Server Anmeldung

Dieses Thema im Forum "macOS & OS X" wurde erstellt von king lui, 14.03.07.

  1. king lui

    king lui Morgenduft

    Dabei seit:
    24.02.07
    Beiträge:
    168
    Hallo Leute!

    Wir haben in der Schule einen Novell-Server. Ich habe einen Benutzernamen zum Einoggen bekommen, Passwort bleibt frei (braucht man nicht, geht ohne). Mit Windows ist es kein Problem auf die Netzlaufwerke zuzugreifen, aber beim Mac: Verbindung fehlgeschlagen!

    Zum Verbinden gehe ich so vor:
    1. Gehe zu --> Mit Server verbinden
    2. IP vom Server eingeben
    3. Dann kommt Benutzerabfrage --> dort gebe ich für User: wlan01 ein und Passwort bleibt frei
    4. FEHLERMELDUNG, VERBINDUNG FEHLGESCHLAGEN :-[

    Bitte helft mit weiter, in der Suche und im Internet finde ich leider nichts!
    Danke!
     
  2. TheMentor

    TheMentor Gast

    Frag mal nach, ob euer NovellServer "WebDAV" kann, denn dann kannst die Laufwerke so mounten. Leider hat Novell den AppleSupport eingestellt und es gibt nur mehr einen kommerziellen Novell Client (GroupWise wird weiterhin unterstützt).

    Was noch eine Möglichkeit wäre. Novell bietet auch eine Webbasierte Oberfläche der Laufwerke an und du kann via Firefox auch alle Laufwerke so benutzen wie gewohnt!

    Gruß
    TM.

    P.S.: Leider hat der Finder noch immer ein Problem mit WebDAV und https. Wenn nur sowas geht, kann ich dir goliath empfehlen!
     
    king lui gefällt das.
  3. king lui

    king lui Morgenduft

    Dabei seit:
    24.02.07
    Beiträge:
    168
    Hallo!

    Erstmals Danke für deine Antwort. Ich verbinde mich aber nicht von Zuhause aus auf den Server, sondern in der Schule, direkt im LAN. Apple's Finder müsste doch eine Novell Unterstützung haben, oder?

    Kann doch nicht so schwer sein, sich auf einen Server einzuklinken, wenn man registrierter Benutzer ist?!

    mfg alex
     
  4. LadeSchale

    LadeSchale Gast

    hallo.

    Können die Windowsrechner einfach so darauf zugreifen oder brauchen die vorher eine Softwareinstallation ?
    Wenn die Windowsrechner ohne Zusatzsoftware darauf zugreifen können, sollte es im Finder mit dem vorangestellen smb:// vor der IP des Servers auch gehen.

    Kannst du evtl. mehr Infos über den Novellserver bekommen, gut wäre zu wissen welche Version eingesetzt wird ... oder ob es sich um einen Dinosaurier aus dem letzten Jahrtausend handelt.
     
  5. TheMentor

    TheMentor Gast

    Für gewöhnlich geht das nicht, dass man so einfach auf die Shares von einer Novellkiste via smb zugreift. Wenn der Novellserver (aktuelle Softwareversion) afaik auf SuSE läuft (die liefern das SuSE Enterprise mit), dann kann man in der OneConsole den Server überrede, dass er seine NovellShares via SambaShare freigibt. Wenn das nicht geht und WebDAV auch nicht aufgedreht bzw installiert ist, dann schaut es düster aus (es sei den die Webvariante funktioniert).
    Wir haben hier in der Firma das selbe Problem, dass einige Mac OS X im Einsatz haben.

    Lg
    TM
     
  6. king lui

    king lui Morgenduft

    Dabei seit:
    24.02.07
    Beiträge:
    168
    Moin!

    So, nun habe ich den Admin gefragt und der Server hat NetWare 6.5 und kein WebDAV! Ich habe smb://IP-Adresse eingegeben und es erscheinen auch folgende Laufwerke: APPS, SYS, USR, _ADMIN. Dann wähle ich USR und es erscheint ein Anmeldefenster. Da sollte ich dann die Arbeitsgruppe (die es laut dem Serveradmin nicht gibt) eingeben, Benutzername und Kennwort. Habe alles eingegeben, aber nichts passiert, er meldet, dass ich Benutzername oder Passwort falsch eingegeben habe.

    lg alex
     
  7. LadeSchale

    LadeSchale Gast

    mhm, ich kannte bisher nur die Anbindung per Clientsoftware an Novell, war aber auch ein alter 4er Server -> Link

    Das es mit Samba zumindest bis zur Auswahl der Freigaben geht klingt schon mal gut, wenn er jetzt Benutzername und Passwort nicht erkennt könnte evtl. der Admin in den Logfiles des Servers sehen woran es liegt, ich vermute das es an einer Art Verschlüsselung liegt. OSX überträgt das Passwort so weit ich weiß jedoch unverschlüsselt.

    Die Suche bei Google hat ergeben das es wohl aber auch einen AFP Dienst unter Novell gibt, weswegen du ja auch erstmal via Server verbinden ohne Probleme zu einer Benutzername/Passwort Abfrage gelangt bist, würde so ein Dienst nicht auf dem Novellserver laufen würde OSX nach einiger Zeit sagen das es den Server nicht gefunden hat. In der durch Google gefundenen Anleitung von der Uni Innsbruck ist 10.2 abgebildet und der Zugriff auf den Novellserver erfolgt via AFP, wobei auch hier die Nutzerdaten unverschlüsselt übertragen werden sollten ... leider.
     
  8. king lui

    king lui Morgenduft

    Dabei seit:
    24.02.07
    Beiträge:
    168
    Bei dieser Anleitung von der Uni Innsbruck steht, dass unbedingt "Unverschlüsselte Verbindung" im Anmeldefenster stehen muss. Bei mir ist das aber nicht der Fall.

    Danke für den Link von dem Novell-Client von Prosoft. Gibt es eine "kostenfreie" Alternative?

    lg
    alex
     
  9. LadeSchale

    LadeSchale Gast

    OK, ich hab hier was bei Novell zu Novell 6.5 gefunden, ist vielleicht auch für den Admin interessant. Der Link geht direkt auf "Vorbereitung für CIFS und AFP" und in der linken Spalte in der Übersicht ist weiter unten nochmal die Sektion "Arbeiten mit Macintosh Computern" aufgeteilt in Admin, User und Troubleshouting -> Link

    Sollte also grundlegend schonmal funktionieren, auch ohne Zusatzclientsoftware ... wenn die Rahmenbedingungen stimmen :) . Du kannst also auf deiner Seite (User) nur schauen ob du ganz normal mit afp://IPvomServer das Anmeldefenster bekommst und dann auf Optionen bzw. bei 10.4 unten links auf den Button mit dem Zahnrad klickst und schaust das die Kennwortübermittlung unverschlüsselt ist.
    Mehr kann man auf der Benutzerseite wohl nicht machen, ich hoff der Admin hat ein offenes Ohr für das Problem, was bei einigen Unis ja wohl gelöst werden konnte (Google: Novell OSX).
     
  10. LadeSchale

    LadeSchale Gast

    Naja die kostenfreie Alternative ist die native AFP-Unterstützung die Novell mitliefert, die ja grundlegend auch funktionieren muss ... sonst würde sie ja nicht einmal von Novell und andernmal von Apple beworben werden.

    Wie gesagt, vermtl. scheitert es an der Verschlüsselung.
     
  11. king lui

    king lui Morgenduft

    Dabei seit:
    24.02.07
    Beiträge:
    168
    Hallo!

    So, nun hat der Admin das soweit geschafft, dass ich bis zur Übertragung komme, also "unverschlüsseltes" Passwort bei den Optionen steht und mein Mac versucht auf die Laufwerke zuzugreifen.
    Doch der Server akzeptiert mich wohl nicht als gültigen User. Ich habe kein Passwort, braucht man ein Passwort? Ich habe auch etwas über ein "einfaches Passwort" gelesen, was ist das und brauche ich sowas?

    Danke @ LadeSchale für den super Link!

    mfg alex
     
  12. TheMentor

    TheMentor Gast

    Vergiss aber nicht auch den Tree anzugeben.. Novell kann gleich wie Windows auch mehrere "Domains" verwalten.. vielleicht liegt es ja daran!
     
  13. king lui

    king lui Morgenduft

    Dabei seit:
    24.02.07
    Beiträge:
    168
    Und wie stelle ich das an bitte? Ich kann nirgends den Tree eintragen...
     
  14. LadeSchale

    LadeSchale Gast

    Mit dem Tree bin ich mir nicht so sicher, das gehört doch zum Bereich IPX.
    Wenn per AFP zugegriffen wird ist das egal, da zählt der Servername oder Server IP.
    Per SMB ist es lediglich die Domain die man bräuchte, wenn das wichtig ist.
    Es kann wirklich daran liegen das es an dem fehlendem Kennwort hängt, hatte ich bis jetzt auch völlig ausgeblendet bzw. nicht wirklich gewertet.
    Gebt dem User doch einfach mal ein Kennwort, dabei kann es ein Simples sein wie 1234 .
    Das hängt von der Implementierung des Protokolls oder auch der Sicherheitseinstellungen am Server ab, ob er User ohne Passwort erlaubt.
     
  15. king lui

    king lui Morgenduft

    Dabei seit:
    24.02.07
    Beiträge:
    168
    ICH HABE ES ERFOLGREICH HINBEKOMMEN! :-D

    Danke für eure hilfreichen Tipps! Nun habe ich es mit dem Admin zusammen hinbekommen. Jetzt möchte ich nochmal eine Zusammenfassung machen, wie wir es hinbekommen haben.

    1.) Am Server direkt die Datei "afptcp" erneut einlesen, also "reload afptcp" in die Serverkonsole eingeben.
    2.) Als Admin neuen User im Root anlegen oder die ctxs.cfg bearbeiten. Ich betone nochmal auf ROOT, weil man im Finder nicht den Kontext angeben kann, darum unbedingt im Root-Verzeichnis anlegen!!!
    3.) Es funktioniert! :cool:

    Hier nochmal die genaue Erklärung: http://www.novell.com/documentation...=/documentation/nw65/native/data/amax3xh.html

    mfg
    alex
     
    DasSCHWITZENDEÖltier gefällt das.

Diese Seite empfehlen