1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Nach jedem Update dieselben Zicken: Spotlight und TimeMachine in Zeitlupe

Dieses Thema im Forum "macOS & OS X" wurde erstellt von AgentSmith, 17.01.08.

  1. AgentSmith

    AgentSmith Hochzeitsapfel

    Dabei seit:
    15.07.07
    Beiträge:
    9.361
    Da es jetzt nach dem Update auf iTunes 7.6, FrontRow etc. schon wieder passiert ist, muss ich da doch mal einen eigenen Thread dazu machen.

    Ich hatte das nachfolgend beschriebene Verhalten bis jetzt nach jedem Update - 10.5.1, dem 2007-009 Update und jetzt eben wieder.

    Nach jedem dieser Updates ist Spotlight anscheinend auf Null zurückgesetzt - ein Klick offenbar nur für jede der Partition "Zeit zum Indizieren wird berechnet".
    Zeitgleich scheint sich diese Berechnung der benötigten Zeit mit Time Machine zu beissen, denn dieses hängt im "Vorbereiten"-Zustand fest.
    Spotlight braucht EWIGKEITEN, um irgendwas gebacken zu bekommen - ich habe keine Ahnung, ob es vielleicht tatsächlich irgendwann von alleine auch fertig würde, so viel Geduld hatte ich bisher nicht.
    Es dauert mehrere Stunden (!) bis bei der ersten Partition mal das Berechnen der benötigten Zeit zu Ende ist. Die Indizierung geht dann so langsam voran, als würde meine Platte per USB1 dranhängen, nicht per FW800.

    Ich habe dann Time Machine deaktiviert, um Spotlight nicht durch unnötige Aktivität zu behindern. Nachdem ich 3 Tage (!!) gewartet habe, war die Neuindizierung immer noch nicht fertig. Danach bin ich in die Weihnachtsferien gefahren und hab den Mac angelassen, als ich nach ner Woche wiederkam, war er fertig.
    Time Machine wieder angestellt, zack, Backup ging ratzfatz über die Bühne - das scheint sich also wirklich gegenseitig zu behindern.

    Beim zweiten Mal als wieder Spotlight wie neu und Time Machine in der Zeitschleife :p gefangen war hatte ich keine Lust, den Rechner wieder eine Woche lang indizieren zu lassen: Ich hab alle Partitionen bis auf eine in die Privatsphäre gesetzt - dadurch ging es ein bisschen schneller. Die 300GB-iTunes-Partition war nach nur gut 30 Stunden indiziert, der Rest folgte dann einzeln durch Entfernen aus der Privatsphäre mit vergleichbaren Werten.

    Während des Indizierens springt die Restzeit übrigens dutzend- wenn nicht hundertfach sinnlos hin und her.. noch x Stunden, dann noch x Minuten, Stunden später steht wieder was von y Stunden da.. in feinster Windows-Manier wird da im Statusbalken herumgesprungen.. und in schöner Regelmäßigkeit mittendrin wieder zu "Zeit zum Indizieren wird berechnet" gewechselt.


    Und nun schon wieder derselbe Sch**ß.. das kann es doch nicht sein. Es darf doch nicht sein, dass ich nach jedem Update erstmal ne Woche lang Stress habe, bis Spotlight wieder ordentlich indiziert hat und dann Time Machine wieder benutzbar ist. Das macht mich wahnsinnig. Ich könnte Sachen eintreten, so nervig ist das.

    NICHTS hilft.. ich habe einfach alles, was man da nur ausprobieren kann ausprobiert. Spotlight per Terminal aktiviert, deaktiviert, resettet.. die Ordner mit den Spotlight-Indizes von Hand gelöscht und dann das Indizieren starten lassen.. alles zwecklos.


    Das ist einfach nicht normal und ich kriege jetzt schon wieder graue Haare davon, dass mein Spotlight bis Anfang nächster Woche unbenutzbar bleibt und ich dann erst wieder darüber nachdenken darf, Time Machine zu nutzen.

    Ich habe zu dem Problem (leider?!) auch nirgends im Netz irgendwas finden können, ich scheine ziemlich alleine damit dazustehen.
    Wenn irgendjemand das Problem auch hat, kennt oder sogar Ursachen weiß, bitte ich um Meldung.

    Problemlösung wird mit Karmabombe und spontan vielleicht auch Sachpreis belohnt, denn das regt mich so unfassbar auf.. ich muss mich sehr zügeln, die Worte fehlen mir jedenfalls definitiv nicht.

    Für jeglichen konstruktiven Hinweis bin ich dankbar - unkonstruktive Hinweise besser nur denken und nicht posten, mir ist in der Sache nach Scherzen nicht zu Mute. Ich hab mir keinen Mac gekauft, um nach jedem Update ne Woche nicht mehr Suchen zu können und meine freien Abende dann mit Spotlight hätscheln, damit es bittebitte wieder brav geht, zu verbringen..
     
    Zettt gefällt das.
  2. Homer J.

    Homer J. Osnabrücker Reinette

    Dabei seit:
    17.11.07
    Beiträge:
    987
    Hi Agent ... werde es heute Abend mal testen. Hast Du Dein System schon mal neu drüber gebügelt? Ist Spotlight nur bei den externen Platten so Langsam? Wieviele hast Du den dran hängen an Deinem System?
     
  3. AgentSmith

    AgentSmith Hochzeitsapfel

    Dabei seit:
    15.07.07
    Beiträge:
    9.361
    Nein, sonst geht ja alles - und wenn ich lang genug warte, geht das auch wieder..

    Nein, ob intern oder extern macht keinen Unterschied. Ich hab eine externe Platte permanent dran hängen, auf der sind knapp 400GB genutzt - angebunden über FW800.
     
  4. Macbeatnik

    Macbeatnik Golden Noble

    Dabei seit:
    05.01.04
    Beiträge:
    24.952
    Hast du schon mal versucht, ist lästig, ich weiß, aber vielleicht eine Lösung, den Spotlight Index neu anzulegen. Vielleicht ist da was zerhackt.
     
  5. newman

    newman Roter Eiserapfel

    Dabei seit:
    02.06.05
    Beiträge:
    1.436
    Bei mir wurde auf keinem Rechner nach den oder vorherigen Leo-Updates neu indiziert.

    Scheint ein spezifisches Problem deiner OS X Installation zu sein...
     
  6. AgentSmith

    AgentSmith Hochzeitsapfel

    Dabei seit:
    15.07.07
    Beiträge:
    9.361
    Schon mehrmals, Macbeatnik, ja. Alles in die Privatsphäre gezogen, dann über Terminal die ganzen versteckten Ordner mit den Index-Daten gelöscht, neu gebootet, eins nach dem anderen wieder aus der Privatsphäre raus.. so hab ich's dann zwar beim letzten Mal wieder hinbekommen, aber auch da hat es abnormal lange gedauert..

    Ich frage mich nur, wie das Problem entstanden ist, newman.. es ist eine absolut frische und saubere Installation, kein Upgrade von Tiger.. ich hab sehr wenig Software installiert und war immer sehr vorsichtig - ist schliesslich mein erster Mac, den will ich nicht gleich zumüllen - insofern wundert mich schon sehr, dass das solche Probleme macht.
     
  7. Macbeatnik

    Macbeatnik Golden Noble

    Dabei seit:
    05.01.04
    Beiträge:
    24.952
    Spotlight und Timemaschine sind wohl häufig recht zickig. So gab es hier gestern einen Thread wo SL bei jedem Neustart anfing zu indizieren, lag in dem Fall wohl an der winPartion? Timemaschine ist wohl auch zickig in Verbindung mit anderen Backup Apps, auch ein Fall in Verbindung mit SuperDuper, da rödelte TM ohne unterlass.
    ZU deinem speziellen Fall kann ich leider nicht mehr beitragen, nur soviel bei mir unter völlig anderen Voraussetzungen, was den Install angeht nur drübergebügelt(4 Rechner fahren unter Leo), bei einem Rechner seit 10.1 passiert das nicht, und ich bin nicht wählerisch was den Install von Programmen angeht, und bei mir sitzen zusätzlich noch die Kids auch an meinen Rechnern und machen was sie wollen.
    Vielleicht hilft Festplattenreparatur und psst ganz leise gesagt die Reparatur der Zugriffsrechte und eventl. das Comboupdate nochmal fahren.
     
  8. Moorcock

    Moorcock Becks Apfel (Emstaler Champagner)

    Dabei seit:
    27.02.07
    Beiträge:
    332
    Agent Smith,

    versuch doch mal den Index komplett neu zu erstellen.
    Quelle:http://www.macintouch.com/tigerreview/spotlight.html

    Hatte bei mir unter Tiger Erfolg
    Gruß
    Moorcock
     
  9. Ich habe heute meine "My Book Premium Editon" bekommen.

    Benutze gerade zum ersten mal Time Machine.

    Bei mir jodelt der jetzt schon ca. 1 Stunde rum und ich habe gerade mal 12 GB (FireWire 400)

    Das ist doch nicht schnell, oder?
     
  10. Homer J.

    Homer J. Osnabrücker Reinette

    Dabei seit:
    17.11.07
    Beiträge:
    987
    @Nuvolaris_03 ist zwar Offtopic bzw gehört es in ein anderes Forum

    1h=60min=3600sec - 12GB=12000MB, macht im Schnitt 3MB/s.

    Das ist wirklich zuwenig.

    @AgentSmith, habe gestern mein Update gemacht. Alles ok mit Timemaschine und Spotlight. Vielleicht solltest Du wirklich mal Deine OS Installation erneuern. Es kann ja nicht schaden.
     
  11. AgentSmith

    AgentSmith Hochzeitsapfel

    Dabei seit:
    15.07.07
    Beiträge:
    9.361
    Mhm, also auf Neuaufsetzen hab ich ja nun wirklich keinen Bock. :D
    Dann probier ich lieber die Tipps von Macbeatnik nochmal (Comboupdate habe ich bisher noch nicht gemacht) - und dann mal sehen, wann das nächste Update kommt.. o_O
     
  12. joho3001

    joho3001 Gast

    ich habe das selbe problem mit spotlight und timemachine

    hi, auf meiner suche nach einem bugfix habe ich den thread hier gefunden.
    ich habe nämlich dasselbe problem wie das hier beschriebene.
    der spotlight-index ist schon mehrfach gekillt worden und schaukelt sich beim anlegen hoch auf "noch 800000 stunden", timemachine braucht für 117 MB backups 8 stunden (nachts)
    dazu kommen noch diverse abstürze.

    weiß jemand von euch rat?
     
  13. Kernelpanik

    Kernelpanik Ingol

    Dabei seit:
    05.03.04
    Beiträge:
    2.098
    A Junx! Bei mir hat es jetzt auch begonnen... TimeMachine braucht Ewigkeiten für ein Backup von 5GB. 12 Stunden genügen da keinesfalls! Naja... hoffen wir mal auf das nächste Update.
     

Diese Seite empfehlen