1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

MYSQL Server über Client Connecten - Probleme

Dieses Thema im Forum "macOS & OS X Server" wurde erstellt von stehlampe, 08.10.08.

  1. stehlampe

    stehlampe Grahams Jubiläumsapfel

    Dabei seit:
    14.03.06
    Beiträge:
    103
    Hi, ich habe über den Server Admin den SQL-Server gestartet und Zugriff über Netzwerk Freigegeben. Webserver habe ich keinen laufen - benötige ich eigentlich auch nicht.
    Der Server hat die IP 192.168.1.110

    Nun will ich im internen Netz mit meinem Client (192.168.1.4) auf den Server zugreifen.

    Mit dem Dienstprogramm Netzwerke komme ich per ping auf die Maschine und der SQL Port ist auch offen (3306).

    Wenn ich mich per Client anmelden will bekomme ich aber den Fehler:

    Unable to connect to host 192.168.1.110.
    Be sure that the address is correct and that you have the necessary privileges.
    MySQL said: Host '192.168.1.4' is not allowed to connect to this MySQL server

    Was mach ich falsch?!
     
  2. nickch4nge

    nickch4nge Süsser Pfaffenapfel

    Dabei seit:
    16.01.08
    Beiträge:
    665
    du kannst nur local auf deinen mysqlserver zugreifen ist die standarteinstellung!

    Wie verwaltest du deinen mysqlserver? Mit phpmyadmin geht das ganz leicht.
     
  3. schwaiger

    schwaiger Weigelts Zinszahler (Rotfranch)

    Dabei seit:
    19.03.06
    Beiträge:
    249
    connecte dich per ssh auf deine maschiene und geh über localhost rein.

    oder trage * in der tabelle für die user ein ( weiss die row nicht ausm kopf )

    lg flo
     
  4. drlecter

    drlecter Wöbers Rambur

    Dabei seit:
    04.11.06
    Beiträge:
    6.442
    Hast du den Zugriff aus dem Netz erlaubt? Du kannst das mit dem MySQL Administrator einstellen (oder direkt an der Konsole :) )
     
  5. stehlampe

    stehlampe Grahams Jubiläumsapfel

    Dabei seit:
    14.03.06
    Beiträge:
    103
    Zugriff (also den Haken bei den SQL Servereinstellungen) habe ich eigentlich gesetzt. Ich versuch mal das mit dem Sternchen in der User Tabelle :)
     
  6. stehlampe

    stehlampe Grahams Jubiläumsapfel

    Dabei seit:
    14.03.06
    Beiträge:
    103
    Also Stern als User mag er irgendwie nicht :) Jetzt probier ich mal direkt die IP einzutragen
     
  7. drlecter

    drlecter Wöbers Rambur

    Dabei seit:
    04.11.06
    Beiträge:
    6.442
    Hast du dir mal den MySQL Administrator für MacOS installiert? Damit kriegst du das relativ einfach hin. Soweit ich weiss muss du kein * sondern ein % eingeben.
     
  8. stehlampe

    stehlampe Grahams Jubiläumsapfel

    Dabei seit:
    14.03.06
    Beiträge:
    103
    Cocoamysql hab ich mir installiert :) Mit dem ging es auch wobei ich jetzt die IP einfach eingtragen haben von meinem Client (ist dank dhcp aber ein wenig doof). Ich probier mal das % Zeichen :) Danke.
     
  9. schwaiger

    schwaiger Weigelts Zinszahler (Rotfranch)

    Dabei seit:
    19.03.06
    Beiträge:
    249
    nein nicht als user * sondern als host ( da wo localhost steht )
     
  10. drlecter

    drlecter Wöbers Rambur

    Dabei seit:
    04.11.06
    Beiträge:
    6.442
    Ich meine die GUI Tools von hier: http://dev.mysql.com/downloads/gui-tools/5.0.html
    Da kannst du dann sagen, von welchem Host aus das ganze geschehen soll. Wobei bei Cocoamysql sollte doch auch die Option sein oder irre ich mich da? Normalerweise sollten die Programme die Auswahl localhost, alle oder feste IP zur Verfügung stellen.
     
  11. stehlampe

    stehlampe Grahams Jubiläumsapfel

    Dabei seit:
    14.03.06
    Beiträge:
    103
    ach sorry - stimmt jetzt hab ich es kapiert .-) Danke funktioniert!
     

Diese Seite empfehlen