1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

MySql läuft nicht!

Dieses Thema im Forum "PHP & Co." wurde erstellt von schmani, 13.12.07.

  1. schmani

    schmani Tokyo Rose

    Dabei seit:
    25.06.06
    Beiträge:
    70
    Hallo allerseits,

    wollte für die Uni auf meinem MacBook MySQL installieren aber das läuft alles leider nicht so, wie es soll. Bei der ersten Installation ist der Server gestartet, ich konnte drauf zugreifen aber wenn ich eine Datenbank erstellen oder benutzen wollte, kam ein Fehler, dass die Syntax angeblich nicht stimmt (war aber richtig).
    Dann habe ich das MB neu gestartet, woraufhin der Server garnicht mehr starten wollte. Habe dann gegooglet, wie ich MySQL entfernen kann, hab das dann auch getan und seitdem startet der Server bei jeder Neuinstallation überhaupt nicht mehr. Klicke ich in den Systemeinstellungen auf "Start MySQL Server" passiert einfach garnichts..
    Habt ihr da vielleicht einen Tipp, wie ich das zum Laufen kriegen kann, brauche das dringend für die Uni..

    Vielen Dank schonmal,

    Daniel
     
  2. red

    red Querina

    Dabei seit:
    18.06.07
    Beiträge:
    184
  3. schmani

    schmani Tokyo Rose

    Dabei seit:
    25.06.06
    Beiträge:
    70
    Ich habe das jetzt eben alles nochmal nach dieser Anleitung probiert:
    http://hivelogic.com/narrative/articles/installing-mysql-on-mac-os-x

    Will ich per "mysql -uroot" testen, ob der Server läuft, erhalte ich:
    "Error 2002 (HY000): Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2)"

    Also gleiche Fehlermeldung wie vorher.. Komisch ist nur, dass ich bei der allerersten Installation problemlos den Server starten konnte?
     
  4. ma.buso

    ma.buso Châtaigne du Léman

    Dabei seit:
    16.04.05
    Beiträge:
    824
    warum nimmst du nicht einfach eine fertiglösung wie z.b. mamp? ist zwar noch bissl mehr mit drin, aber da musst du nicht erst selber rumfriemeln.
     
  5. KayHH

    KayHH Gast

    Der Pfad hat sich geändert, /tmp ist nicht mehr aktuell. Erstelle in /etc eine Datei „my.cnf“ mit folgendem Inhalt:

    Code:
    [client]
    socket = /var/mysql/mysql.sock
    
    [mysqld]
    socket = /var/mysql/mysql.sock
    


    KayHH


    Nachtrag:
    In /var musst Du auch noch eine Kleinigkeit fixen, spricht ein Verzeichnis erstellen welche _mysql gehört.

    Code:
    sudo mkdir /var/mysql
    sudo chown _mysql /var/mysql
    
     
  6. schmani

    schmani Tokyo Rose

    Dabei seit:
    25.06.06
    Beiträge:
    70
    Kann man auf den MySQL-Server ganz normal mit dem QueryBrowser zugreifen? Mehr brauch ich ja nicht...
     
  7. schmani

    schmani Tokyo Rose

    Dabei seit:
    25.06.06
    Beiträge:
    70
    Danke für den Tipp, aber dort befindet sich schon eine solche Datei mit anderem Inhalt.
     
  8. KayHH

    KayHH Gast

    Aha, welches MySQL hast Du denn installiert? Ich habe momentan 5.0.45 (offizielle dmg-Version) laufen. Da war diese Datei nicht vorhanden.


    KayHH
     
  9. schmani

    schmani Tokyo Rose

    Dabei seit:
    25.06.06
    Beiträge:
    70
    Ich habe auch 5.0.45 installiert, allerdings nach der oben von mir verlinkten Anleitung. Also habe ich es selbst kompiliert, da die dmg-Version bei mir nicht lief. Seltsamerweise ging es ja beim ersten Mal, den Server zum Laufen zu bringen, aber Queries waren unmöglich..
     
  10. KayHH

    KayHH Gast

    Hm, da fällt mir jetzt so auf die Schnelle auch nichts ein, sorry. Wieso lief die dmg-Version bei Dir nicht? Gab es eine Fehlermeldung?


    KayHH
     
  11. schmani

    schmani Tokyo Rose

    Dabei seit:
    25.06.06
    Beiträge:
    70
    So, Neuigkeiten:
    Server läuft jetzt wieder nach einem Starten und Stoppen inkl den von dir beschriebenen Änderungen (habe die alte my.cnf einfach überschrieben). Allerdings ist jetzt das alte Problem mit den Queries wieder da:
    Der akzeptiert aktuell keine Queries, ich probier das allerdings gerade mit meinem Mitbewohner aus, vielleicht klappt es ja danach..
    Erstmal vielen Dank für die Hilfe mit dem Server, soweit läuft der ja jetzt, ich meld mich nochmal, falls die Queries weiterhin nicht gehen.
    Fehlermeldungen sind: Code 106: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'Database test' at line 1.
     
  12. schmani

    schmani Tokyo Rose

    Dabei seit:
    25.06.06
    Beiträge:
    70
    So. kleines Update meinerseits..
    Die Datenbank steht jetzt, allerdings musste ich die 5000 Zeilen manuell per Copy & Paste einfügen, weil der /(warum auch immer) die *.sql - Datei nicht akzeptiert hat.
    Jedenfalls sieht es so aus, als würde nun endlich alles gehen. Also vielen Dank für die schnelle und kompetente Hilfe und bis zum nächsten Mal ;)
     

Diese Seite empfehlen