1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Musik ohne Bild?

Dieses Thema im Forum "WYSIWYG-Editoren" wurde erstellt von pcpanik, 08.11.09.

  1. pcpanik

    pcpanik Celler Dickstiel

    Dabei seit:
    27.01.08
    Beiträge:
    803
    Kann ich Musik aus iTunes auch ohne Bild in iWeb 09 unter bringen.
    Also, dass nur und ausschließlich die Steuerungsleiste sichtbar ist, aber kein Bild bzw. leere Fläche?

    Wenn ich nämlich kein Bild einfüge, wird der Raum dennoch frei gelassen, was natürlich unschön ausschaut.
     
  2. creative7even

    creative7even Jerseymac

    Dabei seit:
    23.02.05
    Beiträge:
    454
    Hat man mit iWeb auch die Möglichkeit den html-code einzusehen (oder ev.mit externem editor)?
    Oder gibts einen Link zu Site - dann könnten wir etwas Analyse betreiben :)
     
  3. pcpanik

    pcpanik Celler Dickstiel

    Dabei seit:
    27.01.08
    Beiträge:
    803
    Direkter Link

    Problem seit gestern Abend: Die Seite wird auch nicht mehr sofort geladen, sondern erst alle Musikdaten komplett geladen, bevor der Benutzer sie sieht. Total verrückt, denn eine Seite weiter funktioniert es normal, da wird die Seite geladen und anschließend die Musikinformation ganz normal im Player nachgeladen.
    Also muss man sich bitte etwas gedulden, bis der Inhalt sichtbar wird. Warum zu Kuckuck auch immer.
     
  4. creative7even

    creative7even Jerseymac

    Dabei seit:
    23.02.05
    Beiträge:
    454
    Also ich kann das Problem mit dem vollständigem Laden des Audiofiles auch auf der Folgeseite feststellen. Das liegt IMO daran, dass das Quickime-Player-Object mit Javascript direkt geschrieben wird - ohne es an einen Event-Listener zu binden...
    Code:
    <script type="text/javascript">
    // führt das Schreiben des Movies erst aus wenn die Seite geladen wurde (=onload)
    window.onload = function() {
      writeMovie1();
    }
    </script>
    
    Zum Abstandsproblem... oh mann... die Player werden absolut positioniert. Sieht im Detail dann so aus:
    Code:
    <object style="position: absolute; top: 5798px" >...</object>
    was nichts anders bedeuted als: Positioniere das Element 5798px in y-Richtung. Die x-Achse verläuft horizontal, y vertikal. Der Bezugspunkt (0/0) ist die linke obere Ecke des Elternelements in dem der Player steckt... (das war die vereinfachte Variante, Stylesheet-Gurus wissen dass es auch vom positioning-Typ abhängig ist)

    Wie gesagt kenne ich iWeb nicht - vielleicht kennt jemand ein paar Tweaks für deine Probleme. Ansonsten kann ich dir nur raten mal die Eigenschaften der Objekte (Player) innerhalb von iWeb nochmals zu kontrollieren. Vielleicht kann man hier noch an einigen Settings schrauben...
     
  5. pcpanik

    pcpanik Celler Dickstiel

    Dabei seit:
    27.01.08
    Beiträge:
    803
    Ich danke Dir auf jeden Fall für die Analyse. Das Problem mit dem Objekt ist hier nicht gegeben und die absolute Postionierung ergibt sich aus der tatsache, dass ich da Objekt ausgeschnitten und dann im Textfeld eingesetzt habe. War für mich der einzige Weg eine Verschiebung zu verhindern.

    Mit dem Player irritiert mich dermaßen, denn ich habe schon einige iWeb Seiten gesehen, in denen das immer richtig funktioniert. Und bei mir hat das anfangs auch geklappt.
    Total verrückt, ich befürchte mal fast, dass sich die Blog Vorlage für mein Vorhaben nicht eignet und ich separate Seiten erstellen muss, in denen ich Textfelder und Objekte arrangiere.

    ----

    So, genau das habe ich nun gemacht und alles funktioniert jetzt wie gewünscht. Sogar der Seitenaufbau ist für mobileMe Verhältnisse flott.

    Nur eine Mediendatei ohne Bild einzubeziehen, da finde ich weiterhin nichts.
     
    #5 pcpanik, 10.11.09
    Zuletzt bearbeitet: 10.11.09

Diese Seite empfehlen