1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Mittelwert, Nullwerte ignorieren

Dieses Thema im Forum "iWork" wurde erstellt von Ben78, 12.02.10.

  1. Ben78

    Ben78 Stechapfel

    Dabei seit:
    14.09.08
    Beiträge:
    160
    Wenn ich einen Mittelwert berechne und möchte das dabei eventuell auftauchende Nullwerte in den Bezugszellen ignoriert werden, wie geht das?
     
  2. Scotch

    Scotch Ananas Reinette

    Dabei seit:
    02.12.08
    Beiträge:
    6.237
    Wenn die Funktion korrekt implementiert ist gar nicht. Die Mittelwertbildung sollte leere Zellen ignorieren, aber keine Nullwerte.

    HTH,
    Dirk
     
  3. Der_Apfel

    Der_Apfel Transparent von Croncels

    Dabei seit:
    03.12.07
    Beiträge:
    305
    Klar geht das. Du musst dir nur eine eigene Funktion dafür implementieren. Also irgendwie SUM(A1:A100)/(ZÄHLENWENN(A1:A100;"<>0")).
    Das ist jetzt nur Pseudocode für Excel, von Numbers habe ich keine Ahnung und es sollten so natürlich in allen Feldern Zahlen stehen...
     
  4. risetothesky

    risetothesky Macoun

    Dabei seit:
    19.02.09
    Beiträge:
    119
    Hiermit geht es:
    =SUMME(A)/ZÄHLENWENN(A;">0")
    Das A einfach durch deine Spalte oder deine Zeile ersetzen.
     
  5. Scotch

    Scotch Ananas Reinette

    Dabei seit:
    02.12.08
    Beiträge:
    6.237
    Und keine negativen Zahlen verwenden... ;) Nochmal: Wenn in der Tabelle wirklich Nullen stehen, also z.B. eine Messreihe vorliegt, in der der Messwert "0" vokommt, dann sind die beschriebenen Verfahren schlicht und einfach falsch.

    Gruss,
    Dirk
     
  6. macaneon

    macaneon Kaiserapfel

    Dabei seit:
    19.06.07
    Beiträge:
    1.727
    Hier das geht:
    =WENN(ZÄHLENWENN(C5:H5;">0");SUMME(C5:H5)/(ZÄHLENWENN(C5:H5;">0")))

    Musst du nur noch an die Numbers-Syntax anpassen und eventuell den Einzugsbereich (C bis H) verändern...

    Achso: Negative Werte werden bei der Summenbildung allerdings berücksichtigt.
     
    #6 macaneon, 12.02.10
    Zuletzt bearbeitet: 12.02.10
  7. risetothesky

    risetothesky Macoun

    Dabei seit:
    19.02.09
    Beiträge:
    119
    Wie wäre es hiermit?
    =SUMME(B)/(ANZAHL(B)-ZÄHLENWENN(B;"0"))
    Diese Formel errechnet den Mittelwert aller Zahlen in Spalte B, die ungleich 0 sind. Also ich denke das ist genau das was du suchst.
    Geht auch mit negativen Zahlen!
     
  8. Ben78

    Ben78 Stechapfel

    Dabei seit:
    14.09.08
    Beiträge:
    160
    Erstmal danke für die Tipps und Gedanken. :)

    Bislang war allerdings noch keiner erfolgreich.

    Vielleicht zum Hintergrund:

    Es soll dazu dienen Noten aus Klassenarbeiten zu einer Gesamtübersicht zusammenführen.

    Also beispielsweise die Noten aus allen Klassenarbeiten welcher ein Schüler über das Jahr geschrieben hat aus den einzelnen Tabellen raussuchen und in eine Gesamtübersicht bringen.

    Hat der Schüler bei einer Arbeit gefehlt, so ist die Bezugszelle im entsprechenden Formular natürlich leer und Numbers fügt automatisch eine 0 in die Gesamtübersicht ein. Durch diese 0 wird dann die Durchschnittsberechnung in der Gesamtübersicht zerhaun.
     
  9. macaneon

    macaneon Kaiserapfel

    Dabei seit:
    19.06.07
    Beiträge:
    1.727
    Daher mein Vorschlag: Er entstammt nämlich demselben praktischen Problem (Notenberechnung). Bring das mal in Numbers-Syntax und versuch es nochmal.


    Der zweite Tipp von risetothesky funktioniert übrigens auch.

    Frage: Warum schreibt Numbers denn eine Null in ein leeres Feld? Bei mir steht da einfach nichts drin und die rechnende Zelle hat damit keinerlei Probleme...
    Auf diese Weise funktioniert nämlich auch die MITTELWERT-Funktion. Wenn die Zelle leer bleibt, läuft alles wie geschmiert...
    Liegt aber vielleicht auch daran, dass ich meine berechneten Werte von den verschiedenen Tabellenblättern abholen lasse und nicht jede Zelle einzeln nochmals abhole und anzeigen lasse, die zuvor in eine Berechnung eingegangen ist...
    Ich glaube daher, dass die Lösung für dein Problem die (Abhol-)Ordnung ist.
    Bei Bedarf kann ich dir heute Abend meine Tabelle zuschicken (bitte PN mit E-Mail-Adresse an mich). Wenn die ordentlich gepflegt ist, gibt es keine Schwierigkeiten.
     
    #9 macaneon, 12.02.10
    Zuletzt bearbeitet: 12.02.10
  10. Ben78

    Ben78 Stechapfel

    Dabei seit:
    14.09.08
    Beiträge:
    160
    Hat geklappt.
    Es gibt sogar eine vorgefertigte Funktion in Numbers um das ganze zu lösen.

    Ich bin Anfänger auf dem Gebiet, darum bin ich wohl nicht auf den passenden Suchbefehl gekommen. Tippt man in der Funktionsübersicht MITTELWERT ein, wählt anschließend MITTELWERTWENN, so wird einem die Formel von selbst eingefügt.

    =Mittelwert(Test-Werte;Bedingung;Mittelwerte)

    Muss man nur noch füllen mit den Wunschvorgaben.

    In der Tat entspricht sie euren Vorschlägen, ich war nur zu dumm eure Vorschläge korrekt anzupassen.

    Herzlichen Dank für eure Gedanken und Vorschläge.
     
  11. _linx_

    _linx_ Kleiner Weinapfel

    Dabei seit:
    04.01.09
    Beiträge:
    1.125
    Dann musst du die Gesamtübersicht anpassen, denn so wie du es jetzt hast, ist es mathematisch schlichtweg nicht korrekt.
    Dabei wäre die Lösung so einfach:

    =WENN(ANZAHL2(feld), feld, "")
     

Diese Seite empfehlen