1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Mein Dreamweaver ummlt nicht!

Dieses Thema im Forum "WYSIWYG-Editoren" wurde erstellt von Gunther, 20.07.09.

  1. Gunther

    Gunther Idared

    Dabei seit:
    02.01.05
    Beiträge:
    29
    Hallo,

    bin Golive-User und versuchs jetzt ernsthaft mit Dreamweaver.
    Der schreibt mir aber die deutschen Umlaute und alle anderen Sonderzeichen in den Quelltext.
    Im Dreamweaver-Fenster unten rechts steht "Unicode 5.0 UTF-8". Wo kann ich das Programm einstellen, daß es die Sonderzeichen umwandelt?

    Danke
    Gunther
     
  2. DBertelsbeck

    DBertelsbeck Tiefenblüte

    Dabei seit:
    20.04.04
    Beiträge:
    6.425
    Was ist "ummlt"?
     
  3. el caramba

    el caramba Doppelter Prinzenapfel

    Dabei seit:
    04.08.07
    Beiträge:
    441
  4. Gunther

    Gunther Idared

    Dabei seit:
    02.01.05
    Beiträge:
    29
    Er wandelt die Umlaute nicht in HTML um. Weiß niemand Bescheid?

    Gunther
     
  5. Salzi

    Salzi Prinzenapfel

    Dabei seit:
    29.08.06
    Beiträge:
    555
    wenn ich mich richtig erinnere machte das der Dreamweaver nur automatisch, wenn der richtige Zeichensatz eingestellt ist.
     
  6. el caramba

    el caramba Doppelter Prinzenapfel

    Dabei seit:
    04.08.07
    Beiträge:
    441
    notfalls kannst du umlaute als sonderzeichen und somit als gesicherter Code einfügen....
    Habe auch noch nicht rausgefunden, wann er umlaute richtig einsetzt und wann nicht. Bei UTF Codierung machte er es bei mir noch nie mit automatischer Einsetzung...
     
  7. Salzi

    Salzi Prinzenapfel

    Dabei seit:
    29.08.06
    Beiträge:
    555
    UTF8 beinhaltet aber Umlaute, so dass diese nicht automatisch umgewandelt werden... Ich verwende keinen Dreamweaver (mehr), glaube mich aber daran zu erinnern, dass wenn du einen ISO Zeichensatz wählst, dass die Umlaute dann umgewandelt werden.
     
  8. Tyrra

    Tyrra Holländischer Prinz

    Dabei seit:
    17.12.07
    Beiträge:
    1.869
  9. el caramba

    el caramba Doppelter Prinzenapfel

    Dabei seit:
    04.08.07
    Beiträge:
    441
    also auch nicht in der geteilten Ansicht?
     
  10. Tyrra

    Tyrra Holländischer Prinz

    Dabei seit:
    17.12.07
    Beiträge:
    1.869
    Nur Entwurfsansicht!
    Wäre ja voll der Hammer wenn beim coden plötzlich umgewandelt würde ;)


    EDIT: kann sein das in der Geteilten Ansicht (wenn Entwurfsmodus aktiv ist) auch umgewandelt wird - Probier das doch mal bitte aus und poste das Ergebnis - Habe keinen DW zur Hand zum Testen
     
  11. Gunther

    Gunther Idared

    Dabei seit:
    02.01.05
    Beiträge:
    29
    Hab jetzt eine andere Codierung bei den Seiteneigenschaften eingestellt (Westeuropäisch ISO Latin 1). Jetzt wandelt er Alles um, wenn ich den Text in der Entwurfsansicht reinschreibe. Ich hab noch nicht umgewandelten Text drin stehen, weil ich der Codeansicht eingegeben habe. Bei der Überprüfung wirds auch bemängelt. Wie kann ichs auf die Schnelle reparieren?
     
  12. Salzi

    Salzi Prinzenapfel

    Dabei seit:
    29.08.06
    Beiträge:
    555
    Suchen und Ersetzten im kompletten Projekt?
     
  13. Slashwalker

    Slashwalker Winterbanana

    Dabei seit:
    15.05.06
    Beiträge:
    2.190
    Bei UTF-8 müssen die Umlaute nicht geuumlt werden! Einfach äöüß ganz normal schreiben und gut ist, dafür gibt es ja UTF-8. Wenn du unbedingt uumlen willst musst du in den Voreinstellungen ISO-8859-1 bzw -15 wählen. Allerdings gibt es aus meiner Sicht keinen Grund ISO zu verwenden.

    Also lass es einfach auf UTF-8 und schreib deinen Text einfach so rein, wie er eben ist.

    Ansonsten über Apfel+F Suchen & Ersetzen. Da kannst du im Dialog auf Quelltext schalten, dann oben ü und unten ü eingeben, Haken bei Groß-Kleinschreibung setzen und auf Alle ersetzen klicken. Wenn du alle Dokumente paralell öffnest, kannst du in dem S&E Dialog auch Alle geöffneten Dokumente anwählen.

    Aber ich würde bei UTF-8 bleiben…
     
  14. Gunther

    Gunther Idared

    Dabei seit:
    02.01.05
    Beiträge:
    29
    Bei UTF-8 hatte ich die Umlaute im Quelltext. Meine Browser (die aktuellen Mac-Browser wie Safari 4.0) zerstörten die dann beim Aufruf der Seiten vom Webserver. Deshalb hab ich geändert. Sollten die UTF-8 darstellen können? Muß man die dafür einstellen?
     
  15. Slashwalker

    Slashwalker Winterbanana

    Dabei seit:
    15.05.06
    Beiträge:
    2.190
    Dann hast du im Head einen falschen Charset im Metatag angegeben.

    Ersetze:
    <meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1" />

    Mit:
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
     

Diese Seite empfehlen