1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

MAMP - Kein Zugriff auf Startseite

Dieses Thema im Forum "PHP & Co." wurde erstellt von tmconnect, 27.06.09.

  1. tmconnect

    tmconnect Meraner

    Dabei seit:
    09.12.05
    Beiträge:
    228
    Hallo,

    ich hoffe hier Hilfe zu finden, denn seit heute kann ich nicht mehr auf die Startseite "http://localhost:8888/MAMP/" zugreifen und erhalte jedesmal die Meldung

    You don't have permission to access /MAMP/ on this server.

    Vielleicht hilft diese Meldung aus der log-Datei:
    Code:
    [Sat Jun 27 16:29:02 2009] [notice] Digest: generating secret for digest authentication ...
    [Sat Jun 27 16:29:02 2009] [notice] Digest: done
    [Sat Jun 27 16:29:02 2009] [notice] Apache/2.0.59 (Unix) PHP/5.2.5 DAV/2 configured -- resuming normal operations
    [Sat Jun 27 16:29:04 2009] [error] [client ::1] Options FollowSymLinks or SymLinksIfOwnerMatch is off which implies that RewriteRule directive is forbidden: /Applications/MAMP/bin/mamp/
    Leider habe ich zu wenig Ahnung, um das zu verstehen bzw. beurteilen zu können.

    Der Apache Server und auch der MySQL Server starten einwandfrei. Wenn ich in htdocs eine PHP-Datei lege die mir phpinfo() aufruft, dann kann ich diese auch in "http://localhost:8888/" starten und erhalte alle Infos angezeigt.

    Bin für jede Hilfe dankbar.
     
  2. drlecter

    drlecter Wöbers Rambur

    Dabei seit:
    04.11.06
    Beiträge:
    6.442
    Directory Listing ist wohl nicht erlaubt (+Indexes müsste das sein) und der Fehler steht ja auch da
    Schau dir mal die Optionen unter der Directory Directive an.
     
  3. tmconnect

    tmconnect Meraner

    Dabei seit:
    09.12.05
    Beiträge:
    228
    Danke für Deine Antwort - aber mit Directory Directrive kann ich leider nichts anfangen. Wo muss ich da nachschauen?
     
  4. drlecter

    drlecter Wöbers Rambur

    Dabei seit:
    04.11.06
    Beiträge:
    6.442
    Ups, Tippfehler von mir. In der Config Datei vom Apache findest du eine Einstellungen die mit Directory beginnt.
    Also z.B. <Directory />. Da musst du mal schauen welche Optionen für das entsprechende Verzeichnis gesetzt sind und welche nicht.
     
  5. tmconnect

    tmconnect Meraner

    Dabei seit:
    09.12.05
    Beiträge:
    228
    Nein, an den Einstellungen von Apache kann's immo nicht liegen, denn die Installation habe ich ja auch schon mal neu gemacht - und diese befindet sich ja wohl in Mamp.

    Also muss es doch an irgend etwas anderem liegen.
     
  6. drlecter

    drlecter Wöbers Rambur

    Dabei seit:
    04.11.06
    Beiträge:
    6.442
    Es liegt an den Einstellungen. Wenn du MAMP benutzt, bringt der (soweit ich weis) seinen eigenen Apache mit. Da muss man halt nachschauen. Der Fehler steht doch da. Es fehlt die FollowSymLink bzw. SymLink....Option.
     

Diese Seite empfehlen