1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

MacTex zerschranzt

Dieses Thema im Forum "Officeanwendungen" wurde erstellt von Tafkas, 19.06.09.

  1. Tafkas

    Tafkas Rheinischer Krummstiel

    Dabei seit:
    25.11.06
    Beiträge:
    381
    Hi,

    ich habe ein kleines Problem mit meiner MacTeX-Distribution. Dank MacPorts habe ich mir einen Port installiert, der anscheinend von teTeX abhing. Dieses wurde installiert. Leider ist dabei anscheinend die Pfadvariable zu MacTeX verändert worden. Mittlerweile habe ich teTeX von MacPorts wieder deinstalliert. Ich kann allerdings kein LaTeX-File mit dem TextMate mehr setzten. Ich bekommen dann jedes mal folgende Fehlermeldung:

    Eine "Neuinstallation" von MacTeX brachte, wie auch das Distribution Preference Pane, nichts. Mit dem TeXShop kann ich ganz normal Dokumente setzen. Der scheint also die richtigen Einstellungen (/usr/texbin) zu kennen.

    Wie kann ich meinen TextMate wieder dazu bewegen mir LaTeX-Dokumente zu setzen?
     
  2. awk

    awk Clairgeau

    Dabei seit:
    03.07.08
    Beiträge:
    3.687
    Also, Pakete die du mit Macports geladen hast, werden unter /opt abgelegt, sodass sie deine "Primärstruktur" nicht verändern. Sollte ich nichts übersehen haben (irgendwie hat dein Beitrag die gesamte Formatierung zerschossen), dann sucht TextMate unter /opt. Da er dort nichts findet, kommt es zu den Fehlern. D.h. du musst Textmate nur den richtigen Pfad mitteilen: Textmate/Preferences/Advanced/Shell Variables und dort unter Path das entsprechende eintragen (od. hinzufügen).
     
  3. Tafkas

    Tafkas Rheinischer Krummstiel

    Dabei seit:
    25.11.06
    Beiträge:
    381
    Hast du da ein Beispiel, wie die Pfadvariable aussieht? Variable, Value?
     
  4. awk

    awk Clairgeau

    Dabei seit:
    03.07.08
    Beiträge:
    3.687
    Du solltest in diesem Fenster bereits die Variable PATH sehen. Und Value sollte eigentlich deiner Fehlermeldung entsprechen.

    Versuche unter Variable PATH einzutragen und unter Value z.B. /usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/texbin:/usr/X11/bin:
     
    #4 awk, 19.06.09
    Zuletzt bearbeitet: 19.06.09
  5. Tafkas

    Tafkas Rheinischer Krummstiel

    Dabei seit:
    25.11.06
    Beiträge:
    381
    Ich habe jetzt mal den PATH eingetragen. Da ist dann auch /usr/texbin: drin
    [​IMG]
    Allerdings bekomme ich immer noch den Fehler beim setzen.

    Im Terminal liefert mir "which pdflatex" auch
    /opt/local/bin/pdflatex

    Wie kann ich das denn auf /usr/texbin" umbiegen?
     

    Anhänge:

  6. awk

    awk Clairgeau

    Dabei seit:
    03.07.08
    Beiträge:
    3.687
    Da ist irgendetwas schief gelaufen. Eigentlich sollte bei der MacTeX Installation /etc/profile angepasst werden, sodass TextMate auch alles Nötige findet.

    Vermutlich ist in irgendeinem profile ein falscher Eintrag, aber damit kenne ich mich nicht aus. :(
    Vl. hilft dir ja die TextMate Hilfe? Einfach unter Latex/Help zu finden. Dort gibt es auch einen Abschnitt, wie man die Pfade manuell einrichtet.

    EDIT
    Ich bin übrigens gerade schwer verwirrt. Wenn ich die Shell Variable PATH auf /usr/… setze, dann sucht er dort, wenn ich sie auf /opt/… setze dann eben dort. Weswegen das bei dir nicht funktioniert, ist mir ein Rätsel.
    Wenn du den Haken vor PATH wegnimmst und CMD+R auf ein Latex Dokument anwendest, dann sollte ein Fenster erscheinen, das die Option bietet, den PATH automatisch zu setzen. Wobei das wiederum nur den PATH auf den "which pdflatex"-output setzt.
     
    #6 awk, 19.06.09
    Zuletzt bearbeitet: 19.06.09
  7. quarx

    quarx Hadelner Sommerprinz

    Dabei seit:
    17.04.05
    Beiträge:
    8.541
    Mal ganz langsam: Wie lautet der Inhalt der Dateien /etc/profile und /etc/paths.d/TeX?
     
    #7 quarx, 19.06.09
    Zuletzt bearbeitet: 19.06.09

Diese Seite empfehlen