1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

MacPro, virtueller RAM, Swap FIle zurücksetzen?

Dieses Thema im Forum "Desktop-Macs" wurde erstellt von hwschroeder, 20.06.08.

  1. hwschroeder

    hwschroeder Lambertine

    Dabei seit:
    06.09.06
    Beiträge:
    698
    Hallo,

    ich habe in meinem MacPro 4GB RAM, und im laufe des Arbeitstages wächst meine Swap File auf 2GB an (lt. iStat pro).
    Ich arbeite viel mit Parallels (WinXP 768MB), Photoshop,...
    Programm starten, arbeiten, beenden, nochmal starten...
    Ich habe den Eindruck, dass abends der Rechner immer langsamer wird, evtl. wegen den HD Zugriffen der Auslagerungsdatei.
    Und jetzt die Frage:
    Unter OS 9 gab es ein Tool MACOS PURGE, das den RAM aufgeräumt und den virtuellen Speicher wieder freigegeben hat.

    Gibt es sowas auch unter OS X ?
     
  2. Appleboy

    Appleboy Neuer Berner Rosenapfel

    Dabei seit:
    04.12.05
    Beiträge:
    1.976
    Hi,

    sowas gibt es meines Wissens nicht und brauchen tut man es auch nicht.
    OS X sollte eigentlich alleine wieder aufräumen.
    Macht es bei mir jedenfalls.

    Wie äußert sich denn der Leistungsabfall?
    Bei mir sind die Auslagerungsdateien auch riesig, ich arbeite mit mehreren virtuellen Instanzen in vmware und Parallels, nebenbei mit PS usw., und bei mir machen sich keine Leistungseinbußen bemerkbar.

    Viele Grüße

    Timo
     
  3. hwschroeder

    hwschroeder Lambertine

    Dabei seit:
    06.09.06
    Beiträge:
    698
    Äussert sich darin, dass Programme (Safari, Kalender, etc ) total lange zum starten brauchen.
    Es ist ein 8x 2.8GHz mit 4GB RAM, und da erwarte ich eigentlich nicht, dass beim starten von Safari der "Sat-1-Ball-of-Dead" kommt.

    Lt. iStat hab´ ich 930MB free memory, und trotzdem 2GB Swap.
    Nach einem Neustart ist alles ok, Swap 64MB, allerdings starte ich meinen Rechner ungern neu, der braucht mit den ganzen Zusatzgeräten ewig zum booten (> 5min).

    Aber vielleicht hängts an der Peripherie ?

    FW 800 -> WD MyBook für TimeMachine lokal und über FileSharing für einen Mini (Intervall 3h)
    USB -> Tastatur, Maus, Scanner, DVD Brenner, Cinergy S TV Empfänger, Dock für die Kamera, Dock für den iPod, 1 oder 2 USB Sticks.

    Meine Prozessorleistung ist fast immer <10%, aber vor allem Starten von Programmen ist sooooooo träge.
     
  4. Appleboy

    Appleboy Neuer Berner Rosenapfel

    Dabei seit:
    04.12.05
    Beiträge:
    1.976
    Mhh... Komisch.

    Hast du schonmal die Zugriffsrechte sowie das Volume überprüft / repariert?
    Nutzt du schon OS X 10.5.3?
     
  5. hwschroeder

    hwschroeder Lambertine

    Dabei seit:
    06.09.06
    Beiträge:
    698
    Ja, 10.5.3, ganz aktuell und Zugriffsrechte und so hab´ ich auch schon gemacht. Ich bin dran am ausprobieren, ob es was bringt, wenn ich die Programme vom Startlaufwerk auf die 2. Platte kopiere und von da starte. Ich hab´ne 320er (Mac HD) und ne 500er (Data) drin, beide SATA II
     

Diese Seite empfehlen