1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

MacPorts und OS 10.6.2

Dieses Thema im Forum "Unix & Terminal" wurde erstellt von fsking, 16.11.09.

  1. fsking

    fsking Idared

    Dabei seit:
    13.08.08
    Beiträge:
    28
    Guten Abend liebe Mac/Apple-Gemeinde,

    ich beziehe hier doch recht viel Software über die MacPorts, leider funktionieren diese seit dem Update von Leopard auf Snow Leopard nicht mehr.

    Ich habe von der SL DVD XCode installiert, dann die MacPorts und alle installierten Pakete entfernt, weil ich dachte das es daran liegt, das sich kein Paket installieren lässt.

    Danach habe ich die MacPorts wieder installiert (alles wie es auf der MacPorts Homepage steht).

    Leider brachte das keine Besserung.

    Wenn ich das Zeichenprogramm "dia" installieren will, erhalte ich folgende Fehlermeldung:
    Code:
    Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_libemf/work/libEMF-1.0.3" && /usr/bin/make -j2 all " returned error 2
    Command output: Making all in include
    Making all in libEMF
    make[2]: Nothing to be done for `all'.
    make[2]: Nothing to be done for `all-am'.
    Making all in libemf
    if /bin/sh ../libtool --mode=compile /usr/bin/g++-4.2 -DHAVE_CONFIG_H -I. -I. -I../config -I../include  -I/opt/local/include  -O2 -arch x86_64 -D_REENTRANT -DPTHREADS -MT libemf.lo -MD -MP -MF ".deps/libemf.Tpo" -c -o libemf.lo libemf.cpp; \
    	then mv -f ".deps/libemf.Tpo" ".deps/libemf.Plo"; else rm -f ".deps/libemf.Tpo"; exit 1; fi
     /usr/bin/g++-4.2 -DHAVE_CONFIG_H -I. -I. -I../config -I../include -I/opt/local/include -O2 -arch x86_64 -D_REENTRANT -DPTHREADS -MT libemf.lo -MD -MP -MF .deps/libemf.Tpo -c libemf.cpp  -fno-common -DPIC -o .libs/libemf.o
    In file included from ../include/libEMF/wine/windef.h:16,
                     from ../include/libEMF/emf.h:27,
                     from libemf.h:31,
                     from libemf.cpp:23:
    ../include/libEMF/wine/winnt.h:45:3: error: #error Unknown CPU architecture!
    ../include/libEMF/wine/winnt.h:1051:2: error: #error You need to define a CONTEXT for your CPU
    In file included from ../include/libEMF/wine/windef.h:16,
                     from ../include/libEMF/emf.h:27,
                     from libemf.h:31,
                     from libemf.cpp:23:
    ../include/libEMF/wine/winnt.h:1054: error: expected initializer before '*' token
    ../include/libEMF/wine/winnt.h:2294: error: 'PCONTEXT' does not name a type
    ../include/libEMF/wine/winnt.h:2307: error: 'PCONTEXT' has not been declared
    In file included from ../include/libEMF/emf.h:28,
                     from libemf.h:31,
                     from libemf.cpp:23:
    ../include/libEMF/wine/winbase.h:120: error: 'PCONTEXT' does not name a type
    ../include/libEMF/wine/winbase.h:1243: error: 'CONTEXT' has not been declared
    ../include/libEMF/wine/winbase.h:1377: error: expected ',' or '...' before '*' token
    ../include/libEMF/wine/winbase.h:1377: error: ISO C++ forbids declaration of 'CONTEXT' with no type
    make[1]: *** [libemf.lo] Error 1
    make: *** [all-recursive] Error 1
    
    Error: The following dependencies failed to build: libemf popt
    Error: Status 1 encountered during processing.
    
    hat jemand eine Ahnung an was das liegen könnte?

    Vielen dank für eure Hilfe und schönen abend noch.

    lg,
    fabi
     

Diese Seite empfehlen