1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

MacBook Pro-Festplatte gibt seltsame Klopfgeräusche von sich

Dieses Thema im Forum "Mobil-Macs" wurde erstellt von hzoufal, 18.10.06.

  1. hzoufal

    hzoufal Gast

    Hallo liebe AT-Community,

    seit letzten Donnerstag bin auch ich stolzer Besitzer eines 15.4" MacBook Pro (ist übrigens mein erster Mac, bin also Switcher) und bin soweit zufrieden mit dem Teil. Das einzige was mir derzeit etwas Sorge bereitet ist die Festplatte dieses Geräts (Seagate 120GB/5400rpm).

    Samstag Vormittag ist mir bei der Arbeit mit dem MBP erstmals aufgefallen, dass das Gerät in unregelmäßigen Abständen Klopfgeräusche (so ein komisches, dezentes "clonk") von sich gibt. Ich dachte zuerst, dass dieses Geräusch aus dem linken Lautsprecher käme. Aber nach einiger Zeit war ich mir dann doch ziemlich sicher, dass diese die Festplatte diese Geräusche von sich gibt. Diese hören sich ähnlich dem Geräusch an, dass die Festplatte von sich gibt, kurz bevor sich das MBP komplett ausschaltet wenn man es herunterfährt (ich nehme an, die Schreib-/Lese-Köpfe werden dabei in Parkposition gefahren). Am Freitag Abend habe ich nämlich noch sämtliche Betriebssystem- u. Programmupgrades (u.a. OSX 10.4.6 -> 10.4.8) sowie diverse Software-Installationen durchgeführt. Nun bin ich mir nicht sicher, ob es sich dabei um ein OS-relevantes Problem handelt, ob möglicherweise ein Hardware-Problem vorliegt oder ob dieses Verhalten der Festplatte normal ist.

    Gestern ist mir noch aufgefallen, dass diese Geräusche scheinbar nur im reinen Akkubetrieb auftreten dürften. Als ich das Netzteil zum Aufladen des Akkus ans MBP hängen musste, sind diese Geräusche plötzlich nicht mehr aufgetreten. Drei Stunden später, als ich das MBP nochmals kurz ohne Netzteil benutzte, konnte ich sie wieder wahrnehmen.

    Hat jemand von euch ähnliche Erfahrungen gemacht?
     
  2. pepi

    pepi Cellini

    Dabei seit:
    03.09.05
    Beiträge:
    8.741
    Ist wohl das Parken der Köpfe. Schau mal in  > Systemeinstellungen... > Energie Sparen > Batterie Betrieb nach! Dort gibs ein Hakerl für "Festplatte in den Ruhezustand versetzen (falls möglich)". Der genaue Wortlaut kann anders sein, ich betreibe mein System auf englisch und habe gerade keine Zeit das auf detusch umzuschalten.

    Nimm das Häkchen weg und schau, bzw. horche ob das Symptom nachher noch immer auftritt.
    Gruß Pepi
     
  3. hzoufal

    hzoufal Gast

    Hallo Pepi,

    vielen Dank für den Hinweis. Heute Abend, wenn ich daheim bin, werde ich diese Option deaktivieren und sehen bzw. besser gesagt hören, ob sich diese Klopfgeräusche dann auch im Batteriebetrieb aufhören.

    Mich wundert nur, dass das Gerät versucht die Festplatte teilweise in relativ kurzzeitigen Intervallen (~1 Min.) in den Ruhezustand zu versetzen, wenn man gerade nicht irgendwelche Programme laufen hat, die ständig auf die Disk zugreifen. Kann man diesen Timer für den Ruhezustand der Festplatte irgendwie erhöhen? Ich bilde mir ein, dass der disksleep-Parameter bei mir auf 10 gesetzt ist - sowohl für Netz- als auch Batteriebetrieb. Habe das gestern im Terminal-Fenster ausgelesen, indem ich das 'sudo pmset -a -g disk'-Kommando abgesetzt habe. Oder hat das damit gar nichts zu tun?

    Gruß,
    Harald
     
  4. pepi

    pepi Cellini

    Dabei seit:
    03.09.05
    Beiträge:
    8.741
    Das Beste ist wohl den DiskSleep komplett abzudrehen. Schon die Platten.
    Gruß Pepi
     
  5. hzoufal

    hzoufal Gast

    So, habe den DiskSleep jetzt komplett deaktiviert - sowohl für Batterie- als auch Netzbetrieb, hat aber leider noch immer nichts gebracht. :(
    Da ich mir sicher bin, dass ich das Problem vor meiner Update-Orgie noch nicht hatte, werde ich das Betriebssystem und die zusätzliche Software nochmals komplett aufsetzen. Bei der Gelegenheit kann ich auch gleich die ganzen unnötigen Komponenten und Testversionen von MS Office, iWorks u. dgl. weglassen. Mal sehen, ob sich etwas an dem Verhalten der Festplatte ändert.
     
  6. pepi

    pepi Cellini

    Dabei seit:
    03.09.05
    Beiträge:
    8.741
    Immer langsam mit den jungen Pferden... gleich neu Aufsetzen ist doch eine etwas drastische Maßnahme. Beschreibe doch das Geräusch noch etwas genauer! Schau mal ins Festplatten Dienstprogramm und sag uns was der SMART Status sagt.

    Man kann natürlich auch bei neuen Festplatten nie ausschließen, daß es kein Neubauschrott ist, aber es ist doch eher unwahrscheinlich. Also mal präventiv keine übermäßigen Sorgen machen, sondern immer brav Backups! :) Nachdem wir im selben Kuhdorf beheimatet sind, könnten wir einander auch mal bei einem Bier treffen und ich hör mir das an.
    Gruß Pepi
     
  7. Burn

    Burn Stechapfel

    Dabei seit:
    20.04.06
    Beiträge:
    158
    also ich habe das bei meimen Mac Book Pro auch schon festgestellt.
    Vor einem Monat, hab ich mein Book noch Tag und Nacht, zwecks Diplomarbeit,
    richtig strapaziert und da ist es mir bei Vollast öfter aufgefallen. Im Moment
    höre ich es eigentlich gar nicht mehr, wobei ich auch kaum richtig damit arbeite
    ausser mal Mails oder Apfeltalk. Laut deiner Beschreibung müsste es aber das selbe sein
    da es auch in zeitlich kurzen Abständen auftritt (oder aufgetreten ist).
    Kannst ja mal bescheid sagen, wenn du was rausgefunden hast. Ich werde meins in den nächsten
    Wochen zur Reperatur geben, da ich bei mir noch die Vermutung habe das die Lüfter nicht mehr arbeiten.
    An deiner Stelle würde ich regelmässig Sicherungskopien machen und wenn es dir dann reicht
    zum Apple Händler gehen und checken lassen.

    ciao

    Burn
     
  8. hzoufal

    hzoufal Gast

    Wie gesagt, das Geräusch hört sich wie ein dezentes, aber dennoch hörbares "clonk" oder "plonk" an, ähnlich dem Geräusch das die Festplatte macht, bevor sie in den Ruhezustand versetzt wird wenn das MBP ausgeschaltet wird. Was mich dabei verwundert ist, dass diese Symptome nur im Batteriebetrieb auftreten, nicht jedoch im Netzbetrieb.

    Könnte es sein, dass sich in der Power Management Unit irgendwas verstellt hat? Könnte ein Zurücksetzen der Power Management Unit Abhilfe schaffen? Soweit ich über die Apple Support-Seiten (Art. 303319) in Erfahrung bringen konnte, ist diese Einheit u. a. auch für das Ausschalten der Festplatte (darunter verstehe ich auch das in den Ruhezustand versetzten der Festplatte) zuständig.

    Bevor ich aber zu solch drastischen Maßnahmen greife, werde ich heute Abend - wie von Dir vorgeschlagen - mal den SMART-Status checken.

    Wenn alle Maßnahmen nicht mehr weiterhelfen, komme ich gerne auf Dein Angebot zurück und wir treffen uns mal nach der Arbeit auf ein Bier, damit ich Dir diese Geräusche demonstrieren kann.

    Gruß,
    Harald
     
  9. pepi

    pepi Cellini

    Dabei seit:
    03.09.05
    Beiträge:
    8.741
    Falls Du die CHUD-Tools installiert hast, kannst Du mit SpindownHD auch mal einen Blick auf die eingestellte Zeit machen.

    Das mit dem Bier kamma natürlich auch unabhängig von klackernden HDs machen. :)
    Gruß Pepi
     
  10. skywalker

    skywalker Rheinischer Winterrambour

    Dabei seit:
    06.06.05
    Beiträge:
    917
    habe das geräusch auch seit anfang an. alles läuft einwandfrei, smart status ist ok.
    ich mach mir keine sorgen :)
     
  11. hzoufal

    hzoufal Gast

    Ich habe die CHUD-Tools mal installiert mit SpindownHD mal nachgesehen. Die eingestellte Zeit für disksleep beträgt hier 180 Minuten, nachdem ich den Ruhezustand für die Festplatte in den Energieeinstellungen deaktivert hatte.

    SMART-Status sagt: "Überprüft".

    Und ja, das mit dem Bier können wir auf alle Fälle unabhängig davon machen... nächste Woche geht schlecht, ev. erst ab übernächster Woche. :)

    Gruß,
    Harald
     
  12. freddy.duese

    freddy.duese Bismarckapfel

    Dabei seit:
    05.11.05
    Beiträge:
    146
    Ich habe auch gelgentlich dieses "clack" geräusch. (seit Anfang an. MBP 2.0Ghz, seit Mai. LogicBoard getauscht).
    Bei mir hört das klacken auf, sobald ich einmal PhotoBooth gestartet habe. Scheint also (wie damals das Whine) etwas mit den OSX Energy Saver zu tun haben.
     
  13. pepi

    pepi Cellini

    Dabei seit:
    03.09.05
    Beiträge:
    8.741
    Na hoffentlich is bis dahin das Bier nicht aus... :oops:
    Gruß Pepi
     
  14. hzoufal

    hzoufal Gast

    Danke für den Hinweis mit PhotoBooth! Habe das jetzt selbst während ein paar Sessions mit dem MBP ausprobiert und es hat funktioniert! Kein Klacken mehr. :)

    Trotzdem kann das keine endgültige Lösung sein - ich sehe das jetzt mal als eine Art 'work-around' an, damit die Festplatte auf Dauer nicht zu sehr strapaziert wird. Das Problem tritt seit einiger Zeit nun auch schon im Netzbetrieb auf. :(

    Was ich noch ausprobieren wollte, war einen Reset der Power Management Unit vorzunehmen. Allerdings bin ich mir nicht sicher, ob der Reset überhaupt geklappt hat. Ich bin dabei so vorgegangen, wie auf der entsprechenden Apple Support-Seite beschrieben. Normalerweise sollte bei diesem Reset-Vorgang auch das NVRAM zurückgesetzt werden. Offensichtlich ist das aber bei meinem MBP nicht passiert. Wie kann ich feststellen, ob ein solcher PMU-Reset überhaupt geklappt hat?

    Trotzdem, vielen Dank für eure bisherigen Antworten und die nette Unterstützung! :)

    Gruß,
    Harald

    @Pepi: keine Angst, ich trinke Dir in der Zwischenzeit nicht schon das ganze Bier weg. ;)
     
  15. freddy.duese

    freddy.duese Bismarckapfel

    Dabei seit:
    05.11.05
    Beiträge:
    146
    Also ich hatte auch schon einige PMU Resets (vom Apple Support am Telefon beschrieben , allerdings waren die beiden Anleitungen nicht ganz gleich :) ) . Woran man erkennt ob das funkt oder nicht kann ich dir auch nicht sagen.

    Zum Klacken: Ich finds extrem eigenartig, dass ein mechanisch klingendes Geräusch wie dieses Klacken offenbar durch eine Stromsparoption des Prozessors ausgelöst wird. (PhotoBooth scheint ja die Stromsparmodi abzuschalten und beide Prozessoren anzusprechen.Das kennt man ja schon vom Whine Problem).
    Ich habe übrigens schon das neue Logic Board. Punkto Klacken hat sich dadurch nichts geändert.
    Whine ist (fast) weg. Im Netzbetrieb hört man es noch hin und wieder (weiss jemand ein Mittel dagegen?)
     
  16. pepi

    pepi Cellini

    Dabei seit:
    03.09.05
    Beiträge:
    8.741
    Du setzt voraus, daß das "Whine" vom Prozessor kommt. Das kommt aber manchmal auch vom SystemController. Bei PhotoBooth gehts konkret darum, daß es die Kamera einschaltet und somit ein weiterer USB Bus aktiviert wird.

    Ein "klacken" kann nicht vom Prozessor kommen. Die Zeiten als sowas mechanisch war sind zum Glück vorbei.

    Gegen übermäßiges Whine hilft es sicherlich iTunes ein wenig lauter zu drehen.
    Gruß Pepi
     
  17. g funk

    g funk Gast

    hallo, habe ein nagelneues mbp (2 wochen alt) und selbiges "problem" ...
    sind inzwischen lösungen aufgetaucht bzw bekannt, was das problem verursacht?
    macht mich ganz nervös, dieses geräusch .. ab und an parkt sich die platte im 30s takt; lüfter der harddisc geht gleichzeitig aus und nach ca 5s wieder an ... bei energieoptionen hab ich höhere leistung eingestellt + häckchen "festplatte nach möglichkeit in den ruhezustand versetzen" natürlich deaktiviert .. power unit reset unter anleitung vom apple support hat auch nichts gebracht ..
    weiters scheint dieser tip mit photo booth zu funktionieren, seit 20 min warte ich vergeblich :p auf das geräusch .. kann aber keine lösung sein ... über hilfe bzw tipps wäre ich äusserst dankbar!
    mfg, gf
     
  18. g funk

    g funk Gast

    ---
     
    #18 g funk, 17.12.07
    Zuletzt von einem Moderator bearbeitet: 18.12.07
  19. g funk

    g funk Gast

    ah ok ... ist der idle klick ... problem gelöst ..
     
  20. macuser321

    macuser321 Braeburn

    Dabei seit:
    23.11.07
    Beiträge:
    47
    Hi...habt ihr eine Lösung für das Problem gefunden? ich brauche bitte dringend ne Lösung???
     

Diese Seite empfehlen