1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

MacBook Pro bootet zwei Minuten

Dieses Thema im Forum "macOS & OS X" wurde erstellt von ProSpeed, 20.03.09.

  1. ProSpeed

    ProSpeed Carola

    Dabei seit:
    01.09.08
    Beiträge:
    109
    Hallo,
    ich hab seit längerem ein Problem mit meinem Mac.

    Ist ein 4,1er mit 2,4GHz und 4GB Ram, dabei 200GB HDD, Leopard hat 155 davon und davon 75 frei.
    OS ist 10.5.6

    Wie der Titel schon sagt bootet der Kasten etwas über 2min.

    Das teilt sich so auf: 0-15s: Grauer Bildschirm evtl. mit Apfel (unterschiedlich)
    15-60s: Jetzt kommt auch der Kreisel unter dem Apfel zum vorschein
    60-90s: Ein hellblauer Bildschirm bis zum Log-In Screen
    90-120s und darüber: Der Rechner lädt mein Profil nach dem einloggen.

    Wenn ich dann Safari und Mail starte kann ich nochmal locker 'ne Minute warten
    Rechte hab ich schon repariert - hilft nix.
    Startprogramme: iTunes Helper, Razer Deathadder Daemon, Growl
    Widgets hab ich schon aussortiert wie blöde, bringt aber auch nix.
    Ähnliches bei Office 2008: Word braucht auch etwa 45s zum starten.
    Boot-Laufwerk steht auf Macintosh HD.
    iSync läuft anfangs noch gerne und so lange der rotiert geht überhaupt nichts.
    PRAM Reset hat auch nicht geholfen.

    Habt ihr noch Tipps für mich, was ich machen könnte oder wo ich nachschauen kann?

    Vielen Dank schonmal!

    Grüße
    Pro
     
  2. tharwan

    tharwan Englischer Kantapfel

    Dabei seit:
    01.09.07
    Beiträge:
    1.085
    mmm. hast du vllt irgend welche kext's installiert die was komisches machen? Schau mal was die Konsole nach dem Start so ausgespuckt hat.
     
  3. salome

    salome Golden Noble

    Dabei seit:
    20.08.06
    Beiträge:
    23.757
    Was sollten die Rechte auch damit zu tun haben?
    Deaktiviere mal alle Startobjekte und schau ob der Startvorgang schneller wird. Dann kannst sie einzeln wieder aktivieren. So müsstest du auf den Bremser kommen.
    Du kannst auch in der Konsole (Dientprogramme) nachsehen, wo der Mac so lange braucht.
    Word 2008 ist effektiv nicht das schnellste Programm. Nur weil ich den Mac selten abschalte und Word + Entourage auch offen bleiben, fällt mir das nicht mehr auf. Hast du alle Office-Updates gemacht?
    salome
     
  4. ProSpeed

    ProSpeed Carola

    Dabei seit:
    01.09.08
    Beiträge:
    109
    Hallo,
    hier erstmal ein Ausschnitt aus der Konsole, der das Hochfahren und starten von Safari und Mail beinhaltet:
    Erster auffälliger Teil ist, dass Fusions dauernd vorkommt. Muss das so?

    Dann die tun.kext und tap.kext. Hängen irgendwie mit einem openVPN server zusammen. Kann man die Gefahrlos killen? Ich muss VPN nur als Client nutzen.

    Außerdem sind da noch ein paar Fehlermeldungen enthalten, kann mit jemand sagen, welchen Ursprung die haben?

    Und Growl Mail hüpft da rum, obwohl ich GrowlMail deaktiviert habe...
     
  5. awk

    awk Clairgeau

    Dabei seit:
    03.07.08
    Beiträge:
    3.687
    Ich würde im Verbose Mode starten, dann siehst du woran es liegt. (sprich wo er länger braucht)
    Das Problem könnten die kernel extensions von vmware sein.

    Und: an kext würde ich nichts ändern.
     
  6. salome

    salome Golden Noble

    Dabei seit:
    20.08.06
    Beiträge:
    23.757
    Ich bin auch nicht die begnadete Log-Leserin. Aber VMware Fusion startet immer erfolgreich. Auch die kext (Kernelextensions) scheinen ordentlich geladen zu werden
    Wo es hakt: könnte Bloothoth sein (com.aplleblued), die Druckerverwaltung übers Netzwerk (org.cups.cupsd), die Zeiteinstellung (ntp.ntpd).
    Den Growl eliminiere aus den Pref.Panes, der ist doch ohnehin nur Spielerei und stört mehr als er nutzt.
    Was das korrupte Bild betrifft: Hast du irgendwelche externen Quicklook-PlugIns installiert?
    1 Möglichkeit: Du legst einen anderen User an und schaust, wie der Mac dann startet.
    Wenn problemlos, dann liegen die Fehler nur in in deinem Haus und nicht im System.
    Um die mühsame Fehlersuche zu ersparen, würde ich jedoch gleich
    Cocktail, TinkerToolSystems oder auch applejack holen und die Wartungsarbeiten laufen lassen.
    Applejack ist deshalb zu empfehlen, weil du da im Single User Mode startest, und es werden vom System gleich kleine Reparaturen durchgeführt, dann kommt der applejack und putzt und repariert sehr ordentlich.
    Vielleicht sind dann alle diese "unbekannten keys" verschwunden.
    salome
     
  7. awk

    awk Clairgeau

    Dabei seit:
    03.07.08
    Beiträge:
    3.687
    Er braucht nur im Verbose Mode zu starten, um den Fehler zu sehen.

    Ich denke ausserdem nicht, dass die kext ordentlich geladen werden, imho wartet da eine auf eine andere. Aber das sind alles nur Mutmaßungen, für mehr fehlen die Informationen.
     
  8. salome

    salome Golden Noble

    Dabei seit:
    20.08.06
    Beiträge:
    23.757
    Also ProSpeed dann starte mit Befehl+ V und schau was da steht.

    @awk: zeigt Verbose Mode was anderes als die Konsole? Außerdem rennt doch da der Text so schnell, dass man oft gar nix lesen kann?
    Ich sag ja, ich bin keine Logausleserin (weil keine Programmierin oder Entwicklerin) , aber ich dachte "loaded succesfully" ist gut.
    Ich seh schon, was du meinst: "kextload serialization lock busy; sleeping (89 retries left) " - das hab ich natürlich überlesen. Aber an den kext herumzudoktern würde ich so wie so niemanden raten, dazu weiß ich zu wenig.
    Es hat sich ja bis jetzt niemand um die Sorgen von ProSpeed gekümmert, so hab ich weigstens die Frage wieder hoch gehoben.;)
    salome
     
  9. awk

    awk Clairgeau

    Dabei seit:
    03.07.08
    Beiträge:
    3.687
    Wenn z.B. eine kext nicht geladen werden kann, dann läuft der Text nicht mehr so schnell, sondern bleibt an dem Punkt "hängen".

    Und es kann zwar im Endeffekt erfolgreich geladen worden sein, aber wenn es eine Minute zum Laden benötigt, dann läuft trotzdem etwas schief.
     
  10. computerschreck

    computerschreck Kleiner Weinapfel

    Dabei seit:
    09.08.08
    Beiträge:
    1.142
    Nutzt Du VMWare überhaupt? Wenn Du es nicht unbedingt brauchst dann schmeiss alles raus was Du nicht brauchst, auch die VMWare kexts. Die ziehen mit Sicherheit ca. eine Minute beim Start oder sogar mehr.
     
  11. ProSpeed

    ProSpeed Carola

    Dabei seit:
    01.09.08
    Beiträge:
    109
    So, also:

    Growl hab ich rausgeworfen. tun und tap.kext braucht man nur für openvpn, da die Uni aber Cisco benutzt konnte ich die auch rauswerfen.

    Applejack ist auch gelaufen.

    Verbose Mode ist Glückssache hab ich das Gefühl. Vorhin ist er an einer Stelle hängen geblieben und hat ewig gewartet und 5x geladen, beim nächsten Start dann nicht mehr :(

    Jedenfalls sieht es jetzt so aus::

    Starten, Festplatte "heult" kurz auf, dann 5 Sekunden lang einfach ein grauer Bildschirm.
    Dann kommt der Apfel und nach weiteren fünf Sekunden kommt der Kreisel dazu. Der rotiert dann 20 Sekunden.
    Neuen Benutzer habe ich gemacht, wenn ich mich mit dem Anmelde dauert es nochmal etwa 35 Sekunden, bis er fertig geladen hat.
    Wenn ich auf meinen normalen Account umlogge ist er nach 3-4 Sek. fertig.
    Werde mal Fusion und Bootcamp plattmachen. Wollte da ja eh umbauen.
     
  12. awk

    awk Clairgeau

    Dabei seit:
    03.07.08
    Beiträge:
    3.687
    Und interessant wäre zu wissen, was an der Stelle gestanden ist.
     
  13. salome

    salome Golden Noble

    Dabei seit:
    20.08.06
    Beiträge:
    23.757
    Nach einer Putzaktion dauert der erste Start auf jeden Fall etwas länger, weil ja die Caches geleert wurden und das System alles wieder zusammensucht.

    @awk: Danke. So ein Button wäre doch praktisch.
    salome
     
  14. ProSpeed

    ProSpeed Carola

    Dabei seit:
    01.09.08
    Beiträge:
    109
    Leider weiß ich nicht mehr was dort gestanden hat. Es war gelinde gesagt kryptisch.

    So, Windows Partition ist weg, Fusion ist weg, Problem weiterhin da.

    Hier nochmal ein Ausschnitt aus der Konsole:

    [EDIT]1. Wie krieg ich die Initialisierung der Tap und Tun devices weg? (Scheinen ja ne menge Zeit zu beanspruchen) --- LÖSUNG: Library/StartUp Items/ dort die Ordner tun und tap killen--- [/EDIT]
    2. Der SecurityFixer, wieso braucht der so lange?
    3. Warum laden Safari und Mail immernoch Growl, obwohl ich Growl gekillt habe (mit dem Uninstaller)
    4. Wieso beschwert sich die Bootcachecontrol?

    So, System geht jetzt etwa 5s schneller. Weiter gehts :)
     
    #14 ProSpeed, 22.03.09
    Zuletzt bearbeitet: 22.03.09
  15. ProSpeed

    ProSpeed Carola

    Dabei seit:
    01.09.08
    Beiträge:
    109
    So, die dritte Frage ist auch beantwortet:

    Growl nistet sich in "Library/Input Managers/" ein. Habe heute mal alle Pref. und PrefPane usw. Ordner durchforstet, genauer die gesamte Nutzer und allgemeine Library (die System-Library kommt morgen dran) und alles, wirklich alles, was von alten Programmen war rausgeworfen. (Was man nicht so alles weder ausgräbt...)

    Das komplette Log vom starten sieht jetzt so aus. Weiß jemand etwas zu den Fehlern da unten?

    Muss jetzt noch GrowlMail ausfindig machen...

    Hier an der Stelle scheint es übrigens besonders zu hängen:
    Und was macht AppleTalk da komisches?
     
  16. awk

    awk Clairgeau

    Dabei seit:
    03.07.08
    Beiträge:
    3.687
    Bin gerade zu müde um mir das ganz durchzulesen. Zu dem letzten Quote: hast du einen externen Monitor am MBP hängen?
     
  17. ProSpeed

    ProSpeed Carola

    Dabei seit:
    01.09.08
    Beiträge:
    109
    Ich habe des öfteren einen ext. Monitor dran hängen. Entweder einen ACD oder einen Samsung.

    Hab das Growl Problem Gelöst:

    /Library/Mail/Bundles/GrowlMail.mailbundle
    ~/Library/Mail/Bundles/GrowlMail.mailbundle

    müssen gelöscht werden. Letzteres lebte noch...
     
    #17 ProSpeed, 23.03.09
    Zuletzt bearbeitet: 23.03.09
  18. ProSpeed

    ProSpeed Carola

    Dabei seit:
    01.09.08
    Beiträge:
    109
    So, habe heute mein System neu Aufgesetzt und abgesehen davon, dass ich jetzt noch mehr Fehlermeldungen habe sind diese beiden Kollegen hier immernoch mehrfach Vertreten:

    11.04.09 19:10:55 kernel GFX0: family specific matching fails
    11.04.09 19:10:55 kernel Matching service count = 1
    11.04.09 19:10:55 kernel Matching service count = 2
    11.04.09 19:10:55 kernel Matching service count = 2
    11.04.09 19:10:55 kernel Matching service count = 2
    11.04.09 19:10:55 kernel Matching service count = 2
    11.04.09 19:10:55 kernel Matching service count = 2
    11.04.09 19:10:55 kernel GFX0: family specific matching fails
    11.04.09 19:10:56 kernel GFX0: family specific matching fails

    Hat jemand eine Ahnung, was sich dahinter verbirgt? Daran ackert der Rechner auch im Verbose-Mode die längste Zeit.
     

Diese Seite empfehlen