1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  2. Unsere jährliche Weihnachts-Banner-Aktion hat begonnen! Wir freuen uns auf viele, viele kreative Vorschläge.
    Mehr dazu könnt Ihr hier nachlesen: Weihnachtsbanner 2016

    Information ausblenden

macbook neu aufgesetzt - java will nimmer....

Dieses Thema im Forum "OS X-Developer" wurde erstellt von BastiM, 14.01.08.

  1. BastiM

    BastiM Jonagold

    Dabei seit:
    07.03.07
    Beiträge:
    20
    Hi Leute, hab diese Woche Leopard auf meinem macbook neu aufgesetzt...
    Da ich gerade an meiner Diplomarbeit arbeite (bzw. in java3d programmiere), habe ich versucht alles wieder so einzurichten wie es vorher war...

    Also erst die 1.5.2er Java3D jars eingespielt, dann eclipse installiert und das Projekt vom Repository geladen.

    Wenn ich die java Applikation nun aber starten will bekomme ich folgenden Fehler:

    Java 3D [dev] 1.5.2-build1-experimental 19 Nov 2007 10:22:16 PST

    Exception in thread "main" java.lang.NoClassDefFoundError: javax/media/opengl/GLException
    at java.lang.Class.forName0(Native Method)
    at java.lang.Class.forName(Class.java:164)
    at javax.media.j3d.Pipeline$1.run(Pipeline.java:143)
    at java.security.AccessController.doPrivileged(Native Method)
    at javax.media.j3d.Pipeline.createPipeline(Pipeline.java:138)
    at javax.media.j3d.MasterControl.loadLibraries(MasterControl.java:926)
    at javax.media.j3d.VirtualUniverse.<clinit>(VirtualUniverse.java:280)
    at NewGui.<init>(NewGui.java:216)
    at NewGui.main(NewGui.java:1204)




    Ich glaube nicht dass ich damals irgendwas anders gemacht hab... Ich kann aus dem Fehler auch nix rauslesen. bin für jeden tip dankbar

    ciao
    basti
     
  2. appahappa

    appahappa Ingrid Marie

    Dabei seit:
    28.03.07
    Beiträge:
    270
    Was heisst: "jars eingespielt"? Und wie startest du die Anwendung aus Eclipse heraus? Wird die Anwendung in Eclipse sauber compiliert? (Window -> Show View -> Problems)

    Schau mal zuerst nach ob in deinem Eclipse-Projekt die Jars eingetragen sind. Projekteigenschaften -> Java Build Path -> Libraries
     

Diese Seite empfehlen