1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Mac Mail zeigt Umlaute bei XP-Empfängern nicht richtig an

Dieses Thema im Forum "Mailprogramme" wurde erstellt von ötte, 28.11.07.

  1. ötte

    ötte Gast

    Hallo,
    bei mir gibt es ein Problem mit Mail.
    Mac Mail zeigt Umlaute bei XP-Empfängern nicht richtig an. Außerdem können eingefügte Bilder von Windows Nutzern nicht geöffnet werden.
    Welche "dauerhafte" Einstellung muß ich vornehmen?
    MFG
    Ötte
     
  2. doeme89

    doeme89 Pomme Miel

    Dabei seit:
    27.12.06
    Beiträge:
    1.476
    Hallo ötte!

    Das mit dem Text wird wohl irgendwas mit der Codierung zu tun haben, welche die Windows-Empfänger eingestellt haben. Bis jetzt konnte ich keine ähnlichen Probleme feststellen.

    Wenn du Bilder hinzufügst (übers Menü / über Button), musst du die Option "Anhänge Windows-Kompatibel senden" anwählen. Ob es beim neuen Mail (Leopard) eine dauerhafte Lösung gibt, weiss ich leider nicht. Sinnvoll wärs auf jeden Fall!

    Gruss
     
  3. ötte

    ötte Gast

    Hallo doeme89,
    wenn ich die Codierung umstelle klappt es. Die Codierung stellt sich aber immer wieder auf "automatisch". Da ich nicht immer weiß, ob es sich um MAC oder Windows-Empfänger handelt, suche ich eine dauerhafte Lösung.
    Ich habe jetzt schon Endourage ausprobiert, Mail + Adressbuch gefallen mit aber besser.
    Gruß Ötte
     
  4. doeme89

    doeme89 Pomme Miel

    Dabei seit:
    27.12.06
    Beiträge:
    1.476
    So wie ich das sehe kann man die Text-Codierung nicht dauerhaft einstellen, sowohl beim senden, als auch beim Empfangen. Mit welchen Programmen arbeiten denn deine Windows-Empfänger?
     
  5. switchermaniac

    switchermaniac Starking

    Dabei seit:
    18.01.07
    Beiträge:
    223
    Du benutzt Mail 2XX?

    Mail beenden, Terminal öffnen und folgendes eingeben:
    defaults write com.apple.mail NSPreferredMailCharset "ISO Latin 1"
    Terminal schließen.

    Zurückkehren zur ursprünglichen Einstellung kannst du mit:
    defaults delete com.apple.mail NSPreferredMailCharset

    Ansonsten kannst du natürlich auch immer mit "reinem" Text auf Nummer sicher gehen, aber das möchtest du vielleicht nicht. ;)

    Bei Anhängen solltest du "Windowskompatibel senden" aktivieren.
     
  6. ötte

    ötte Gast

    Hallo doeme89,
    Hallo switchermaniac,
    ich gehe davon aus, dass die meisten Windows-Empfänger mit Outlook arbeiten.

    Switchermaniac, danke für deine Info. Ich benutze Mail Version 2.1.1 (752.3).
    Leider stellt sich die Text-Codierung immer von "ISO Latein1" bei jeder neuen Mail wieder auf "Automatisch" um. Mache ich etwas falsch?
    MFG
    Ötte
     
  7. doeme89

    doeme89 Pomme Miel

    Dabei seit:
    27.12.06
    Beiträge:
    1.476
    Ich denke mal "Automatisch" meint das, was in der Voreinstellung gespeichert ist. Diese kannst du mit dem Terminalbefehl von switchermaniac ändern.
     
  8. nggalai

    nggalai Roter Stettiner

    Dabei seit:
    23.05.07
    Beiträge:
    957
    Hallo ötte,

    meines Wissens nach funktioniert der default-Trick nicht mit der aktuellen Mail-Version für Tiger. Mail wählt automatisch das Encoding für die ausgehenden Mails, welches „klein genug“ ist, um alle verwendeten Zeichen darzustellen. Das funktioniert allerdings nur mit reinen Text-Mails (Plain Text) wirklich sauber; bei HTML/RTF-Mails gibt’s die bekannten Probleme, vorwiegend mit Outlook-Usern.

    Mail 3 für Leopard soll dieses Problem übrigens nicht mehr haben.

    Liebe Grüße,
    -Sascha
     
  9. switchermaniac

    switchermaniac Starking

    Dabei seit:
    18.01.07
    Beiträge:
    223
    Ich benutze auch Mail 2.1.1 (OS X 10.4.11) und habe das mal eben ausgetestet. ;)

    Terminaleintrag wie beschrieben.
    Mail-Einstellung: Formatierter Text
    Mail gesendet an gmx-Account.
    Empfang unter XP mit Outlook 2003
    Der Satz "Gmx nützt den großen schönen Ärztehäusern" wurde korrekt dargestellt.

    Allerdings in einer anderen Systemschriftart - kann man aber auch übers Terminal einstellen (Forumssuche), was ich nicht gemacht habe, da ich normalerweise keine formatierten E-Mails versende.
     
  10. ötte

    ötte Gast

    Hallo Switchermaniac,
    vielen Dank für eure Infos.
    Ich habe jetzt noch einmal in Terminal nachgesehen. Der eingegebene Befehl (defaults write com.apple.mail NSPreferredMailCharset "ISO Latin 1") erscheint dort nicht mehr. Wird er nicht automatisch gespeichert?
    (Entschuldigung, bin Neuling bei MAC.)
    Bei mir steht im Terminalfenster nur:
    Last login: Thu Nov 29 09:27:26 on ttyp1
    Welcome to Darwin!
    öttes-computer:~ EOK$

    Habe ich etwas falsch gemacht?

    MFG
    Ötte
     
  11. doeme89

    doeme89 Pomme Miel

    Dabei seit:
    27.12.06
    Beiträge:
    1.476
    Das ist klar, du hast ja in dem Fall auch das Terminalfenster geschlossen... ;)
    Wenn du übers Menü einen Befehl auswählst kannst du ihn nachher auch nicht nachverfolgen. :)

    Wenn du den Befehl richtig eingegeben hast, sollten die Voreinstellungen (defaults) geändert worden sein.
     
  12. ötte

    ötte Gast

    Ich habe den Befehl von Switchermaniac kopiert und eingefügt. Kann ich irgendwo kontrollieren ob die Voreinstellungen wirklich geändert wurden?

    Bei jeder neuen Mail steht es wieder auf "automatisch".
    Es funktioniert einfach nicht.

    Hat jemand noch eine andere Idee?
    MFG
    Ötte
     
  13. doeme89

    doeme89 Pomme Miel

    Dabei seit:
    27.12.06
    Beiträge:
    1.476
    Wie schon gesagt: "Automatisch" bedeutet in Mail soviel wie "Wie in der Voreinstellung gespeichert", und die hast du ja mit dem Terminalbefehl geändert! Wenn du jetzt eine Mail mit "Automatisch" verschickst, kommt sie dann falsch an?

    Die Änderungen kannst du in der Voreinstellungsdatei selber nachsehen:
    <User> -> Library -> Preferences -> com.apple.mail.plist
    (Alle Voreinstellungen die sich auf den Benutzer beziehen befinden sich im Ordner "Preferences".)
     
  14. ötte

    ötte Gast

    Hallo doeme89,
    danke für deine Hilfe.
    Ich habe die "com.apple.mail.plist" gefunden. Sind sehr viele Einträge, die ich nicht verstehe.
    Wie kann ich jetzt ersehen, das die Codierung geändert ist?
    MFG
    Ötte
     
  15. doeme89

    doeme89 Pomme Miel

    Dabei seit:
    27.12.06
    Beiträge:
    1.476
    Das ist der Terminalbefehl, der die Voreinstellungen auf die gewünschte Codierung ändert:
    Gehen wir mal alles Schritt-für-Schritt durch:
    defaults write: ist der eigentliche Befehl, er braucht aber nähere Angaben welche man hinter dem Befehl schreibt.
    com.apple.mail: ist die Datei/Voreinstellung, die geändert werden soll.
    NSPreferredMailCharset: das ist eine Zeile innerhalb der Datei (du schreibst ja es gibt noch viele...) und diese Zeile eben, ändert man auf "ISO Latin 1".

    Wenn du jetzt also in diesem plist-File suchst, dann wirst du irgendwo die Zeile NSPreferredMailCharset finden. Am besten benutzt du die Suchfunktion des Programms in dem du öffnest!

    Hoffe du hast nach all dem trotzdem noch einen guten Eindruck vom Mac, sowas kommt aber ehrlich selten vor! Dafür sieht man in solchen Momenten immer wieder zu was UNIX an sich alles könnte...
     
  16. ötte

    ötte Gast

  17. doeme89

    doeme89 Pomme Miel

    Dabei seit:
    27.12.06
    Beiträge:
    1.476
    Das wäre dann die Methode ohne Terminal... aber sicher DIE Lösung wenns nicht klappte! Falls du den erwähnten Property List Editor nicht findest, musst du ihn zuerst installieren. Der ist auf der CD/DVD bei den Developer Tools dabei...

    Gruss, doeme
     

Diese Seite empfehlen