1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

mac leopard, ping auf hostname klappt nicht

Dieses Thema im Forum "Mobil-Macs" wurde erstellt von finarfin, 11.10.08.

  1. finarfin

    finarfin Golden Delicious

    Dabei seit:
    05.10.08
    Beiträge:
    6
    Hallo,

    ich habe folgendes Problem:
    In meinem Heimnetzwerk kann ich von meinem MacBook pro keinen Rechner mittels hostname anpingen. Unter Angabe der IP geht es.

    Wenn ich die Namen (hostnamen) der Rechner in die /etc/hosts eintrage findet das MacBook die anderen Rechner natürlich. Als DNS-Server ist mein Router angegeben, genau wie bei den anderen Rechnern im Netz. Nun bin ich etwas sprachlos, wieso klappt es von den anderen Rechnern aber nicht vom MacBook?

    Meinen Dank im Voraus, Gruß
    finarfin
     
  2. MacMark

    MacMark Biesterfelder Renette

    Dabei seit:
    01.01.05
    Beiträge:
    4.709
    Was für andere Rechner?
    Wie lautet Dein Befehl exakt?
     
  3. finarfin

    finarfin Golden Delicious

    Dabei seit:
    05.10.08
    Beiträge:
    6
    Nun,

    z.B. so mit IP:
    Code:
    ping -c4 192.168.2.21
    
    und so mit Hostname:
    Code:
    ping -c4 meinDesktopPC
    
     
  4. MacMark

    MacMark Biesterfelder Renette

    Dabei seit:
    01.01.05
    Beiträge:
    4.709
    Da fühlen sich die Windows-PeeCees offenbar unter ihrem Namen nicht angesprochen.
     
  5. pepi

    pepi Cellini

    Dabei seit:
    03.09.05
    Beiträge:
    8.741
    meinDesktopPC ist nur dann ein qualifizierter Hostname wenn Du entweder eine SearchDomain hast, oder .local für mDSN Auflösung anhängst.
    Gruß Pepi
     
  6. finarfin

    finarfin Golden Delicious

    Dabei seit:
    05.10.08
    Beiträge:
    6
    Ok,

    mit .local klappt es. Ist es denn immer so unter UNIX, dass man .local anfügen muß?
    Auf dem Desktop-PC läuft Ubuntu(Linux) und dort brauche ich auch kein .local. Auf dem MacBook ist keine Suchdomain eingetragen und auch nicht auf dem Desktoprechner. Hatte mal versucht den Router als Suchdomain zu definieren, leider ohne Erfolg. Was würde sich denn dort anbieten um das .local nicht mehr machen zu müssen?
     
  7. MacMark

    MacMark Biesterfelder Renette

    Dabei seit:
    01.01.05
    Beiträge:
    4.709
    Unter System Preferences - Network - Advanced - DNS - Search Domains trägst Du "local" ein. Dann brauchst Du es nicht mehr tippen. Änderungen werden erst nach dem Fenster-Schließen der Preferences wirksam.

    Die Router-IP sollte unter DNS-Servers stehen. Wenn der Mac selbst nicht den Namen auflösen kann, dann fragt er den Router und der fragt nötigenfalls den Router beim Provider.

    Wenn Du Lust hast, trag auch noch "apple.com" als Search Domain ein. Dann tippe im Browser mal "store" und schau, was passiert …
     
  8. finarfin

    finarfin Golden Delicious

    Dabei seit:
    05.10.08
    Beiträge:
    6
    Ok,

    das wars, klappt alles wie es soll! Hatte bei meinem ersten Suchdomain-Versuch auch .local eingetragen, anstatt nur local (ohne Punkt). Das ging natürlich nicht. local allein geht und arbeitet so wie ich es möchte. Dann klappt die Datenbankanbindung auch wieder wie sie sollte.
    :)

    Gruß
    finarfin
     
    MacMark gefällt das.

Diese Seite empfehlen