1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

lokales Wordpress

Dieses Thema im Forum "CMS" wurde erstellt von iMacuser91, 31.03.08.

  1. iMacuser91

    iMacuser91 Kaiser Wilhelm

    Dabei seit:
    21.12.06
    Beiträge:
    174
    Hallo,

    (für eigentliche Frage weiter unten gucken)

    VORGESCHICHTE:
    ich habe mir vor kurzem Wordpress heruntergeladen und installiert (gestern auf Version 2.5 erneuert) und wollte alles lokal testen bevor ich es dann hochlade.
    Leider habe ich da ein Problem, die Permalinks.
    Die normale Struktur ist ja eher hässlich beziehungsweise nichtssagend, da sie nur ?post=X bzw. ?page_id=X enthält.
    Ich hab dann mal versucht das zu ändern (in Wordpress) wozu man mod_rewrite und .htaccess braucht.
    Alles schön und gut, beides scheint da zu sein (keine Fehlermeldung), funktioniert aber nicht, ich bekomme immer einen amüsanten 404 angezeigt und das egal wie ich die Permalinks einstelle, außer beim Default.

    Man ist ja nicht dumm und sucht mal nach mod_rewrite Konfiguration mit Google und bekommt ein hilfreiches Tutorial.
    Terminal geöffnet und httpd.conf gesucht (/ect/httpd/httpd.conf) und nach den angegebenen Zeilen gesucht. Die waren auch nicht auskommentiert, sondern ganz normal - nur sie hatten eine andere Quelle (libexec.... oder so).
    Hab ich mir gedacht das kann ja nicht falsch sein, könnte auch nur ein Unterschied Apache 1.3.41 zu 2 sein.
    Also in der httpd.conf war alles richtig, mod_rewrite sollte funktionieren - weiter geht die Suche...
    .htaccess mit vi im Terminal geöffnet - nichts drin - mit chmod die Rechte mal auf -rwx-rwx-rwx- geändert und Wordpress nochmal die Permalinks versuchen lassen - immer noch nichts.
    Hab mir dann das WP Plugin AskApache RewriteRules Viewer heruntergeladen und mal geguckt, was so in der .htaccess Datei steht - angeblich legt Wordpress mehrere Regeln an aber die Datei selbst ist leer.
    Habe dann immer weiter gesucht aber bin zu keiner Lösung gekommen.




    EIGENTLICHE FRAGE:
    Kann mir jemand helfen, dass ich das mit der RewriteEngine hinbekomme?

    Lokal ist es ein Apache 1.3.41 auf Tiger (+PHP 5 und MySQL die aktuellste Version)

    Falls es hilft hier noch meine Quellen:
    Hauptquelle
    #2 - kaum benutzt, zu komplex
    #3
    #4

    chmod (auch mal mit -f) -rwx-rwx-rwx- /Users/*name*/Sites/wordpress/.htaccess
    -> rein technisch bin ich ein Terminalneuling

    Zum Anhang: wenn ich auf 'go edit' klicke kommt ein weiterer 404, da wp-admin/template.php nicht vorhanden ist (nie war(?))
     

    Anhänge:

    #1 iMacuser91, 31.03.08
    Zuletzt bearbeitet: 31.03.08
  2. TaTonka

    TaTonka Neuer Berner Rosenapfel

    Dabei seit:
    19.03.06
    Beiträge:
    1.961
    Ich habe meine Permalinks "basierend auf Datum und Name", und meine .htaccess sieht so aus:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    vllt hilfts dir ja als referenz/vergleich..
     
  3. zeno

    zeno Lane's Prinz Albert

    Dabei seit:
    05.11.05
    Beiträge:
    4.898
    In der httpd.conf, schau da mal bei <Directory...> ob .htaccss überhaupt etwas ändern dürfen an der Config
     
  4. iMacuser91

    iMacuser91 Kaiser Wilhelm

    Dabei seit:
    21.12.06
    Beiträge:
    174
    <Directory />
    Options FollowSymLinks
    AllowOverride None
    </Directory>

    da sollte dann wohl eher

    AllowOverride on

    oder so stehen?
    ansonsten werd ich jetzt mal die Wordpress .htaccess Zeilen in die .htaccess Datei manuell reinschreiben, vielleicht hilft das

    EDIT: Wenn ich mit dem Terminal 'vi .htaccess' (im richtigen Verzeichnis) eingebe, dann steht unten Permission denied
     
    #4 iMacuser91, 02.04.08
    Zuletzt bearbeitet: 02.04.08
  5. zeno

    zeno Lane's Prinz Albert

    Dabei seit:
    05.11.05
    Beiträge:
    4.898
    Hat der Webserver überhaupt Rechte die .htaccess zu lesen? Das Problem hatte ich nämlich gestern auch mit Wordpress und mod_rewrite ;)
     
  6. iMacuser91

    iMacuser91 Kaiser Wilhelm

    Dabei seit:
    21.12.06
    Beiträge:
    174
    Keine Ahnung, aber da er lokal ist und so ziemlich alles, was mod_rewrite und .htaccess laut diversen Anleitungen ermöglicht, aktiviert ist, denke ich er sollte schon die Rechte haben.
    Aber die .htaccess Datei ist schreibgeschützt, ich werde sie mal löschen und ne neue anlegen, vielleicht hilft das ja (sie ist ja einfach leer)


    EDIT: Ich bin nochmal alles durchgegangen und hab .htaccess gelöscht und neu angelegt, mit den Rechten 766 (jeder darf lesen + schreiben und ausführen nur ich) und es geht, in der Datei steht jetzt endlich das was Wordpress reinschreibt, aber es funktioniert immer noch nicht - entweder ?post=X oder nen 404...

    EDIT2:
    Das hier bezog sich auf die httpd.conf:
    <Directory />
    Options FollowSymLinks
    AllowOverride None​
    </Directory>

    EDIT3:
    könnte es am lokalen Server liegen?
     

    Anhänge:

    #6 iMacuser91, 03.04.08
    Zuletzt bearbeitet: 03.04.08

Diese Seite empfehlen