1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Logic und externe Synthesizer asynchron ...

Dieses Thema im Forum "Musikproduktion" wurde erstellt von Ionas_Elate, 02.12.08.

  1. Ionas_Elate

    Ionas_Elate Beauty of Kent

    Dabei seit:
    12.10.06
    Beiträge:
    2.143
    Hallo!
    Ich nutze die neuste Version von Logic Studio (Studentenversion, falls das von Belang ist) und habe folgendes Problem:
    Wenn ich meinen Roland SH-201 ansteuere kommt es logischerweise zu einer geringen Latenz, was sich wohl nicht vermeiden lässt. Viel schlimmer jedoch ist, dass er manche Noten absolut nicht im Takt spielt. Dabei sind es keine besonders schnell aufeinander folgenden Anschläge (Lediglich 1/8).
    Kann ich das irgendwie ausgleichen?
    Außerdem stört mich noch, dass die Audiospur, nach der Aufnahme versetzt ist.
    Gibt es eine Möglichkeit meine Probleme zu lösen?
    Eventuell durch die Latenzeinstellungen in Logic?
    Das Programm, das ich für meinen Synthesizer installiert habe hat auch einen Eintrag in den Systemeinstellungen hinterlassen, mit dem sich die Audio Buffer Größe, Recording Margin und Recording Timing einstellen lassen.
    Wäre super, wenn ihr mir da behilflich sein könntet.
    Danke!
     
  2. Cram

    Cram Salvatico di Campascio

    Dabei seit:
    21.12.06
    Beiträge:
    428
    Hi Ionas

    Du kannst in Logics Einstellungen unter Midi die Ansprechzeit verändern. Hatte das Problem auch einmal und weiss noch, wie ich damals einige Zeit mit Rumpröbeln verbracht habe. Mehr kann ich Dir im Moment nicht sagen, da ich grad das Programm nicht zur Hand habe. Es ist auf jeden Fall lösbar. ;)

    Gruss

    C.
     
  3. Ionas_Elate

    Ionas_Elate Beauty of Kent

    Dabei seit:
    12.10.06
    Beiträge:
    2.143
    Es funktioniert nicht :(
    Ich habe an sämtlichen Parametern rumgeschraubt, die irgendetwas mit der Latenz zu tun haben könnten ...
    Ich habe mal einen Screenshot von den Systemeinstellungen des SH-201 gemacht, falls da etwas nicht stimmt.
    http://www.speedyshare.com/292501378.html
    Langsam geht mir das echt auf die nerven ...
    Is wie gesagt nur beim externen so. Interne Synths funktionieren prächtig und taktgenau.
    Danke trotzdem!

    EDIT:
    Mir reichts langsam echt ...
    Hier ein kurzes Sample, damit ihr wisst, womit ich mich gerade rumschlagen muss :)
    Einfach nur Viertel, die eigentlich im Takt sein sollten ...
    http://rapidshare.com/files/169954688/Audio_1_07.aif.html
     
    #3 Ionas_Elate, 03.12.08
    Zuletzt bearbeitet: 03.12.08
  4. Scotch

    Scotch Ananas Reinette

    Dabei seit:
    02.12.08
    Beiträge:
    6.242
    Ich muss gestehen, dass ich das Problem nicht 100%ig verstanden habe, insb. nicht, ob du die Aussetzer und Latenzprobleme mit MIDI, Audio, oder dem Mischbetrieb hast, also z.B. eine Audio- und MIDI-Spur synchron abspielen willst.

    Die Settings vom SH-201, die du verlinkt hast, sind allerdings fuer den Audio-Teil und deine Einstellungen dort sind sehr aggressiv - die meisten "hauptberuflichen" Audio-Interfaces laufen so nicht sauber. Probiere es mal mit nur 50-75% Buffer und setz den "Recording Margin" (ich rate mal, dass es sich dabei um die Latenzeinstellung handelt) auf 10-14msec. Was "Recording Timing" macht kann man nur raten (was sagt das Handbuch?), aber diese Einstellung wird in jedem Fall von der Samplerate abhaengen: Solltest du also ggf. Audiotracks, die mit verschiedener Samplerate (und evtl. auch noch verschiedener Aufloesung) aufgenommen worden sind und nicht transkodiert/konvertiert wurden gleichzeitig abspielen, passiert da alles moegliche - nur meist nichts sinnvolles ;)

    Falls du die Probleme mit MIDI hast: Spur solo schalten. Wenn das Problem immer noch besteht, Kabel durchmessen. Falls du den USB-to-Host-Anschluss verwendest: Gibt es einen geraetespezifischen Treiber fuer den SH-201, der ggf. nicht installiert wurde? Was sagen die MIDI-Einstellungen unter MacOS?

    Sollten die Probleme beim synchronen Abspielen von Audio- und MIDI-Spuren auftreten, bzw. bei der Synchronisation von MIDI-Spuren, die ueber den SH-210 und ueber VSTis ausgegeben werden, dann gibt es eine Vielzahl an Massnahmen, die man ergreifen kann - dafuer sollten die oben angesprochenen grundsaetzlichen Audio- bzw. MIDI-Probleme allerdings ausgeschlossen sein.

    HTH,
    Dirk
     
    Ionas_Elate gefällt das.
  5. Ionas_Elate

    Ionas_Elate Beauty of Kent

    Dabei seit:
    12.10.06
    Beiträge:
    2.143
    Also ich bilde mir ein es kling etwas besser (nachdem ich an den Systemeinstellungen rumgeschraubt habe ...)
    Wo kann man in OS X bitte die midi Einstellungen vornehmen?
    Danke schonmal!
    Mein Problem ist nicht so sehr die Synchronität einzelner Spuren, sondern dass der SH-201 sich "verspielt" :)
     
  6. Scotch

    Scotch Ananas Reinette

    Dabei seit:
    02.12.08
    Beiträge:
    6.242
    Im Ordner "Dienstprogramme" gibt's ein Programm, mit dem der ganze OS X MIDI Set-up verwaltet wird. Weiss' nicht genau, wie es heisst (und sitze gerade auch an keinem Mac :)), aber MIDI kommt im Programmnamen vor ;)

    Hab' ich kapiert, aber ich habe immer noch nicht verstanden, ob das mit MIDI- oder Audiospuren passiert, oder nur beim gemischten Betrieb usw. - siehe oben.

    Gruss,
    Dirk
     
  7. Ionas_Elate

    Ionas_Elate Beauty of Kent

    Dabei seit:
    12.10.06
    Beiträge:
    2.143
    Nicht mit den Audiospuren (ja wobei... wenn das midi das verbockt wirkt sich das auch auf die audiospur aus)
    also es tritt auch auf, wenn ich nicht aufnehme, sondern den synthie nur töne spielen lasse.
    Ich schau mal in die Midi einstellungen.
    Danke
     
  8. Ionas_Elate

    Ionas_Elate Beauty of Kent

    Dabei seit:
    12.10.06
    Beiträge:
    2.143
    Also der Roland erscheint in den Midi einstellungen.
    Mit einem anderen USB kabel habe ich es auch ohne erfolg probiert :(
    Das mit dem Midi interface will nich funktionieren.
    Das wird vom AU Plugin zwar erkannt aber es lässt sich nicht synchronisieren ...
    Schade ...
    Im Midi Setup von Mac OS X kann man keine Einstellungen vornehmen, oder?
     
  9. Ionas_Elate

    Ionas_Elate Beauty of Kent

    Dabei seit:
    12.10.06
    Beiträge:
    2.143
    Juchuuuu ich habs geschafft! :)
    Ich werde es dir verraten, wen du mir versprichst, mich nicht für dumm zu verkaufen ^^
    Die Spur von der das midi kam hatte ich als AU - SH-201 Plugin eingestellt was irgendwie nicht so geklappt hat...
    Also als Softwareinstrument und nicht als MIDI. Warum kam denn dann trotzdem ein Sound? Komisch ...
    Aber es funktioniert nun und das ist die Hauptsache! :)
    Jetzt kann ich halt softwaremäßig keine Änderungen am Sound mehr vornehmen.
    Danke!
     
  10. Scotch

    Scotch Ananas Reinette

    Dabei seit:
    02.12.08
    Beiträge:
    6.242
    Weil das Plug-In fuer den SH-201 meines Wissens nur die Benutzeroberflaeche des SH-201 in Software abbildet, aber keine eigene Tonerzeugung enthaelt.

    Doch, auch das geht, du koenntest z.B. die Settings in einem leeren Track mit dem SH-201 Plug-In vornehmen und einfach dafuer sorgen, dass die Spuren mit den Noten, die an den SH-201 gesendet werden einen Takt spaeter anfangen. Vmtl. ist das Problem aber viel trivialer zu loesen, indem du z.B. nicht MIDI-Spuren mischst, die einmal direkt ueber den MIDI-Port des SH-201 ausgeben und einmal ueber das Plug-In. Eine andere Loesung ist, weiter mit der Latenzkompensation des Plug-Ins zu experimentieren.

    Viel Erfolg auch weiterhin,
    Dirk
     

Diese Seite empfehlen