1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

localhost funktioniert nicht

Dieses Thema im Forum "Webhosting/DSL-Anbieter" wurde erstellt von Wavemaster, 21.12.08.

  1. Wavemaster

    Wavemaster Golden Delicious

    Dabei seit:
    17.12.07
    Beiträge:
    11
    Hallo liebe Community,

    habe folgendes Problem:

    Ich hab vor ner Woche mein System mit einem TimeMachine-Image wiederhergestellt, weil ich die HDD in meinem MacBook Pro gewechselt habe.

    Nun zeigt er mir folgenden Fehler an, wenn ich mit Safari http://localhost bzw. 127.0.0.1 aufrufe

    Safari kann den Server nicht finden.
    Safari kann die Seite „http://localhost/“ nicht öffnen, da Safari den Server „localhost“ nicht finden kann.

    Systemeinstellungen -> Sharing -> Web-Sharing ist an

    MFG
    Wavemaster


    Mein System:
    MacBook Pro late 2007
    2,4Ghz
    4GB RAM
    GeForce 8600M GT
    OS X 10.5.5
     
  2. OleHH

    OleHH Damasonrenette

    Dabei seit:
    27.11.07
    Beiträge:
    494
    Hab mich noch nicht so mit dem WebSharing befasst, aber was genau willst du erreichen? Wenn auf deinem Rechner kein Webserver irgendwo läuft ist klar, dass er unter http://localhost nichts findet.
     
  3. Wavemaster

    Wavemaster Golden Delicious

    Dabei seit:
    17.12.07
    Beiträge:
    11
    ein Webserver sollte also laufen - sollte
     
  4. vcr80

    vcr80 Doppelter Melonenapfel

    Dabei seit:
    06.11.08
    Beiträge:
    3.352
    schwachsinn, ein server ist in os x integriert

    sollte, correct, bei mir tuts das auch...
    hat time machine auch alles wieder hergestellt, was dort hin gehört?
     
  5. OleHH

    OleHH Damasonrenette

    Dabei seit:
    27.11.07
    Beiträge:
    494
    Ah ok. Wusste nicht, ob WebSharing ein Webserver ist oder ob man damit seine Internetverbindung freigibt. Dann sorry.
     
  6. OleHH

    OleHH Damasonrenette

    Dabei seit:
    27.11.07
    Beiträge:
    494
    Danke für diese überaus nette Belehrung. Wie ich schon geschrieben habe, habe ich mich mit WebSharing noch nicht befasst. Und nur dass ein Server integriert ist bedeutet nicht, dass er auch läuft.
     
  7. vcr80

    vcr80 Doppelter Melonenapfel

    Dabei seit:
    06.11.08
    Beiträge:
    3.352
    bitte gerne

    ich mich auch nicht ;)

    wie man sieht ;)
     
  8. Wavemaster

    Wavemaster Golden Delicious

    Dabei seit:
    17.12.07
    Beiträge:
    11
    @alle: nicht streiten ;)

    @vrc: TimeMachine hat erfolgreich alles wiederhergestellt.
    Hatte noch keinerlei Probleme mit irgendwas anderem.
     
  9. vcr80

    vcr80 Doppelter Melonenapfel

    Dabei seit:
    06.11.08
    Beiträge:
    3.352
    der ordner websites in deinem benutzerordner is eh auch da, oder?
     
  10. Wavemaster

    Wavemaster Golden Delicious

    Dabei seit:
    17.12.07
    Beiträge:
    11
    ja, wobei ich den nicht direkt für Seiten benutze (da liegen Projekte drin)

    Mein Ziel ist eine Vorschau der Seiten in meinem HTML-Editor (Coda)
     
  11. vcr80

    vcr80 Doppelter Melonenapfel

    Dabei seit:
    06.11.08
    Beiträge:
    3.352
    soweit ich weiß, ist der Websites Ordner der httpdoc ordner, und was nicht da drinnen ist kann von anderen nicht angezeigt werden, aber zumindest sollte der inhalt angezeigt werden, wenn du localhost eingibst...

    vl ist was mit dem apache server kaputt....

    sonst könntest du MAMP runter laden, wenns dir eh ned um den Zugriff geht
     
  12. Wavemaster

    Wavemaster Golden Delicious

    Dabei seit:
    17.12.07
    Beiträge:
    11
    das denke ich mir auch... nur hab ich keinen blassen Schimmer, was genau

    das will ich nicht, weil es das Problem nicht löst sondern mir einen zweiten Apache installiert (wäre etwas komisch, oder?)

    eben darum gehts mir doch (halt lokale Vorschau auf HTML- und PHP-Objekte)
     
  13. vcr80

    vcr80 Doppelter Melonenapfel

    Dabei seit:
    06.11.08
    Beiträge:
    3.352
    php unterstützt der built-in apache aber eh nicht, gelle?
     
  14. Wavemaster

    Wavemaster Golden Delicious

    Dabei seit:
    17.12.07
    Beiträge:
    11
    php ist installiert (ging zumindest vor der Wiederherstellung noch)

    (wobei ich nicht sagen kann, ob die Wiederherstellung dran schuld ist - mir würde nur sonst nichts einfallen, was ich falsch gemacht hab...)
     
  15. vcr80

    vcr80 Doppelter Melonenapfel

    Dabei seit:
    06.11.08
    Beiträge:
    3.352
    mamp ist ein so schön dezentes programm, das speziell für Mac OS X ist und dir dann MySQL, PHP und Apache zur Verfügung stellt.

    Wenn in dem Thread keine weiteren Lösungsansätze kommen (wünsch dir das Gegegenteil), dann wäre MAMP wirklich zu empfehlen.

    Ich habe allerdings nix mehr im Petto, tut leid
     
  16. Wavemaster

    Wavemaster Golden Delicious

    Dabei seit:
    17.12.07
    Beiträge:
    11
    ich mir auch ;)

    danke trotzdem erstmal, vll findet sich ja noch jemand, der sich damit auskennt oder das Problem auch schonmal hatte...
     
  17. Wavemaster

    Wavemaster Golden Delicious

    Dabei seit:
    17.12.07
    Beiträge:
    11
    *in Verzweiflung den Thread nach oben schieb*

    Hat wirklich niemand eine Lösung für mein Problem?
     
  18. vcr80

    vcr80 Doppelter Melonenapfel

    Dabei seit:
    06.11.08
    Beiträge:
    3.352
    doch mamp...
     
  19. Jamsven

    Jamsven London Pepping

    Dabei seit:
    21.11.07
    Beiträge:
    2.046
    Doch, sogar "out of box", du musst nur in der /etc/apache2/httpd.conf die Raute vor der Zeile LoadModule php5_module libexec/apache2/libphp5.so entfernen.

    Dann Websharing aus und wieder einschalten.
     
    #19 Jamsven, 30.12.08
    Zuletzt bearbeitet: 30.12.08
    vcr80 gefällt das.
  20. vcr80

    vcr80 Doppelter Melonenapfel

    Dabei seit:
    06.11.08
    Beiträge:
    3.352
    genial! thx!
     

Diese Seite empfehlen