1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

lightbox funktioniert nicht

Dieses Thema im Forum "PHP & Co." wurde erstellt von waXve, 24.07.09.

  1. waXve

    waXve Braeburn

    Dabei seit:
    12.11.07
    Beiträge:
    45
    Hallo zusammen
    Ich bin schon ein bischen am verzweifeln, weil ich den Fehler nicht finde.

    Ich habe mich mal an der javascript lightbox versucht, aber irgendwie will das ding nicht funktionieren. Ich habe auch noch keine erfahrung mit javascript, verstehe aber etwas von html und php.

    Ich nutze firefox 3.5 und die Aktuelle version von XAMPP (1.0.1)

    Ich habe folgenden Quelltext:
    Code:
    <?php session_start() ?>
    <!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
    "http://www.w3.org/TR/html4/loose.dtd">
    <html>
        <head>
            <title>
            lightbox test
            </title>
            <link rel="stylesheet" href="css/lightbox.css" type="text/css" media="screen">
            <script src="js/prototype.js" type="text/javascript"></script>
            <script src="js/scriptaculous.js?load=effects" type="text/javascript"></script>
            <script src="js/lightbox.js" type="text/javascript"></script>
    
        </head>
        <body>
            <?php
            if ($_SESSION['login'])
            {
                ?>
                <h1>Test f&uuml;r Lightbox</h1>
                <br>
                <a href="/praktikum/bilder/31490x-0001.jpg" rel="lightbox[roadtrip]"><img style="border: 0px solid ; width: 200px; height: 149px;" alt="Rathaus" src="/praktikum/bilder/31490x-0001.jpg"></a>
                <br>
                <a href="/praktikum/bilder/lightboxdemo_2.jpg" rel="lightbox[roadtrip]"><img style="border: 0px solid ; width: 200px; height: 149px;" alt="Blaue Blume" src="/praktikum/bilder/lightboxdemo_2.jpg"></a>
                <br>
                <a href="/praktikum/bilder/pb_logo.jpg" rel="lightbox[roadtrip]"><img style="border: 0px solid ; width: 200px; height: 149px;" alt="Tr&auml;nendes Herz" src="/praktikum/bilder/pb_logo.jpg"></a>
                <br>
                <?php
    
            }
            else
            {
                include ('zum_login.html');
            }
            ?>
        </body>
    </html>
    
    meine Verzeichnisstruktur sieht wie folgt aus:
    http://www.bilder-hochladen.net/files/1dwl-3-jpg.html

    Ich finde einfach den Fehler nicht. er könnte auch an der verzeichnisstruktur selbst liegen. Oder vielleicht habe ich auch bloß irgendein blödes Zeichen vergessen.

    Bitte helft mir...

    Ich bedanke mich für eure Hilfe schon einmal ganz Herzlich im vorraus
     
  2. el caramba

    el caramba Doppelter Prinzenapfel

    Dabei seit:
    04.08.07
    Beiträge:
    441
    was genau geht denn nicht? wird das bild nicht angezeigt oder der effekt? da es ja wenigstens als link das bild öffnen muss warum gibste die links nicht einfach mit
    bilder/31490x-0001.jpg statt /praktikum/bilder/31490x-0001.jpg an?
     
  3. DubiDuh

    DubiDuh Zwiebelapfel

    Dabei seit:
    20.05.08
    Beiträge:
    1.288
    <script src="js/scriptaculous.js?load=effects,builder" type="text/javascript"></script>

    Füge mal den builder hinzu. Das läuft bei mir so.
     
  4. waXve

    waXve Braeburn

    Dabei seit:
    12.11.07
    Beiträge:
    45
    Jetzt funktionierts...

    Vielen Dank.
     

Diese Seite empfehlen