1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  2. Unsere jährliche Weihnachts-Banner-Aktion hat begonnen! Wir freuen uns auf viele, viele kreative Vorschläge.
    Mehr dazu könnt Ihr hier nachlesen: Weihnachtsbanner 2016

    Information ausblenden

libnet installiert oder nicht???

Dieses Thema im Forum "Unix & Terminal" wurde erstellt von Viwaldi, 27.08.05.

  1. Viwaldi

    Viwaldi Gast

    Also ich versuche gerade ein Programm über das Terminal zu installieren. Da kommt dann irgendwann die Fehlermeldung

    Code:
    configure: error: Incorrect libnet version. libnet >= 1.1.2.1 required
    
    also bin ich nochmal zu libnet gegangen und wollte das nochmal installieren und da kam dann das hier
    Code:
    Making install in include
    Making install in libnet
    make[3]: Nothing to be done for `install-exec-am'.
    /bin/sh ../../mkinstalldirs /usr/include/libnet
     /usr/bin/install -c -m 644 libnet-asn1.h /usr/include/libnet/libnet-asn1.h
     /usr/bin/install -c -m 644 libnet-functions.h /usr/include/libnet/libnet-functions.h
     /usr/bin/install -c -m 644 libnet-headers.h /usr/include/libnet/libnet-headers.h
     /usr/bin/install -c -m 644 libnet-macros.h /usr/include/libnet/libnet-macros.h
     /usr/bin/install -c -m 644 libnet-structures.h /usr/include/libnet/libnet-structures.h
     /usr/bin/install -c -m 644 libnet-types.h /usr/include/libnet/libnet-types.h
    make[3]: Nothing to be done for `install-exec-am'.
    /bin/sh ../mkinstalldirs /usr/include
     /usr/bin/install -c -m 644 libnet.h /usr/include/libnet.h
    Making install in src
    /bin/sh ../mkinstalldirs /usr/lib
     /usr/bin/install -c -m 644 libnet.a /usr/lib/libnet.a
     ranlib /usr/lib/libnet.a
    make[2]: Nothing to be done for `install-data-am'.
    Making install in sample
    make[2]: Nothing to be done for `install-exec-am'.
    make[2]: Nothing to be done for `install-data-am'.
    make[2]: Nothing to be done for `install-exec-am'.
    make[2]: Nothing to be done for `install-data-am'.
    ich bin mir aber sicher, dass das auch die richtige Version von libnet ist denn am Anfang heißt es

    Code:
    beginning autoconfiguration process for libnet-1.1.2.1...
    
    Jetzt weiß cih nicht mehr weiter was heißt eigentlich „make[2]: Nothing to be done for `install-data-am'.”

    Danke für eure Tipps
     
  2. quarx

    quarx Hadelner Sommerprinz

    Dabei seit:
    17.04.05
    Beiträge:
    8.541
    Ein paar Details mehr wären nicht schlecht. Hast Du libnet via Fink installiert, welche Version? Was bekommst Du bei
    Code:
    dpkg -l |*grep libnet
    für eine Versionsnummer angezeigt? Und das zu installierende Programm ist ebenfalls Fink/DebianPorts-Paket oder ein Tar-Archiv?
    Es kann sein, dass Du parallel mehrere Versionen von libnet installiert hast und das configure-Skript nur die ältere findet.
     
  3. Viwaldi

    Viwaldi Gast

    Ok ich hab den Befehl eingeben, kam dabei das hier raus:

    Code:
    dpkg -l | *grep libnet
    tcsh: *grep: No match.
    Ich hatte versucht, libnet mit Fink zu installieren, aber die Version, die in Fink angeben war war zu alt. Also hab ich mir das Paket aus dem Netz runtergeladen. Dann im GUI entpackt (war eine .tar.gz Datei) und im terminal mit dem Befehl „./configure; sudo make install;“ „installiert“. Dann dachte ich das wär gegessen, aber anscheinend nicht. Ich habe in den Befehl ein kleines l eingegeben. Sollte doch eins sein, oder???
     
  4. quarx

    quarx Hadelner Sommerprinz

    Dabei seit:
    17.04.05
    Beiträge:
    8.541
    Hmm, Fremdpakete habe ich mir unter Fink noch nicht installiert. Du wirst aber auf jeden Fall auf das Problem stoßen, dass die Standard "make configure; make; make install"-Strategie die Kompilate an die falsche Stelle kopiert. Damit Du eine aktuelle libnet unter Fink benutzen kannst, musst Du die wahrscheinlich unterhalb des Fink-Ordners /sw korrekt einklinken. Also so was Ähnliches wie
    Code:
    configure --prefix=/sw
    benutzen.
    Ich würde aber erstmal nachschauen, ob nicht doch via Fink eine aktuelle Version von libnet installierbar ist. Entweder als Source-Paket (die sind meist aktueller als die vorkompilierten Binärpakete) oder im unstable-Zweig suchen. Kennste Dich da aus oder brauchst Du noch mehr Informationen?
    (die Syntax bei dpkg haste korrekt eingetippt, Copy&Paste hätte auch gefunzt... ;))
     

Diese Seite empfehlen