1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

leopard nach neustart eher eine schnecke

Dieses Thema im Forum "macOS & OS X" wurde erstellt von linga, 11.06.08.

  1. linga

    linga Gast

    hey,
    seit einiger zeit fällt mir auf, dass mein mbp nach einem neustart deutlich länger als zu beginn benötigt, um sauber zu laufen.
    bis ich überhaupt ein programm via dock starten kann, vergehen sicher 20 sekunden und es dauert dann nochmal gute 30 sekunden, bis das erste programm läuft. dann normalisiert sich langsam alles und spätere programmstarts gehen flott.
    als das OS noch frisch war, musste ich lediglich roundabout 5 sekunden warten. in so krasser ausprägung kenne ich diese verlangsamung nichtmal von windows, weshalb ich halbwegs überascht bin.

    da ich mich mit dem mac noch nicht so gut auskenne, würde ich gerne von den erfahreneren wissen, welche einflüsse dafür verantwortlich sein können? was staut sich da an datenmist zusammen, dass ich so lange warten muss?
    die mir bekannten möglichkeiten der systempflege führe ich regelmäßig durch (OnyX, rechtereparatur, saubere deinstallation von apps, caches leeren, usw.)
    als startobjekte definiert habe ich lediglich growl, launchbar, alarmclock und nicrosoft database (office 08).

    vielen dank!
     
  2. Nighthawk

    Nighthawk Linsenhofener Sämling

    Dabei seit:
    16.12.06
    Beiträge:
    2.558
    Ich kann nur sagen, dass ich die selbe Erfahrung mache. Auch ich hab fast keine Startup-Objekte.
     
  3. j33n5

    j33n5 Horneburger Pfannkuchenapfel

    Dabei seit:
    18.12.06
    Beiträge:
    1.405
    Onyx etc. würde ich weglassen.. Vor Allem den Cache würde ich unangetastet lassen, da er unter anderem das Starten der Apps schneller macht ^^.

    Immer wieder gerne verlinkt.

    Oder das:

     
  4. linga

    linga Gast

    die im link enthaltenen infos sind mir alle bekannt. seit 10.5. braucht man sich auch keine gedanken mehr um die ausführung von cronjobs zu machen, da osx nun selbst versäumte cronjobs nachholt, usw.

    caches zu löschen hat durchaus vorteile. die daraus resultierenden geschwindigkeitseinbußen betreffen nur den nächsten start einer app, die caches werden dann neu (schlank) erzeugt. um das reguläre starten von apps geht es hierbei jedoch eher nicht. trotzdem vielen dank!
     
  5. j33n5

    j33n5 Horneburger Pfannkuchenapfel

    Dabei seit:
    18.12.06
    Beiträge:
    1.405
    Das ist meine persönliche Erfahrung. Wenn ich den Cache leere und dann neu starte, braucht alles länger, weil kextd beispielsweise ziemlich viele Resourcen frisst.
     
  6. Macbeatnik

    Macbeatnik Golden Noble

    Dabei seit:
    05.01.04
    Beiträge:
    24.947
    was sagen denn die logs, eventl. findest du da die Spassbremse. und was hat sich in der Zwischenzeit getan, in der Zeit von "schnellen" Start zum jetzt langsamen, neue Erweiterungen eingeladen, anderes Wlan oder ähnliches, zusätzliche Menüleistenobjekte, oder dort etwas anders eingestellt, anderes Datumsformat für die Uhr oder ein Tool, das z.B. Temperaturen anzeigt etc.
     
  7. pepi

    pepi Cellini

    Dabei seit:
    03.09.05
    Beiträge:
    8.741
    Was kein Wunder ist wenn Du ihm den kextcache klaust. :) Muß er ja alles neu machen und das dauert eben ein wenig. Genaugenommen sieht man daran wie erfolgreich Apple hier Cachingtechniken einsetzt.

    Zu beachten wäre, daß auch andere Hintergrundprozesse als nur "Anmeldeobjekte" existieren. So werden beispielsweise auch PrefPanels oder MenuExtras geladen die aber in den AnmeldeObjekten nicht aufscheinen weil sie keine normalen Applikationen sind.

    Was auch gut bremsen kann sind PPC only Prozesse auf intel Macs. Da muß erst die Rosetta angeworfen werden und das dauert.
    Gruß Pepi
     
  8. j33n5

    j33n5 Horneburger Pfannkuchenapfel

    Dabei seit:
    18.12.06
    Beiträge:
    1.405
    Genau, deswegen Finger weg von Cache-Cleanern.
     
  9. Head

    Head Freiherr von Berlepsch

    Dabei seit:
    03.07.04
    Beiträge:
    1.100
    wieviel festplatte hast du frei? mehr als 12-15gb sind zu empfehlen, hab ich mal gelesen...
     
  10. linga

    linga Gast

    das ist das problem. ne menge. und ich kann keinen punkt bestimmen, ab dem es dann tatsächlich so radikal langsamer wurde, besonders, weil ich eher selten überhaupt neustarte (jetzt noch weniger).
    nun, chacheprobleme sind es nicht und es ist wohl auch eher eine frage der persönlichen einstellung, ob man die von zeit zu zeit mal neu aufbauen möchte.
    logs sind eine gute idee. das werde ich direkt mal überprüfen. von den weiteren hintergrundtasks habe ich leider wenig ahnung, meine mac erfahrungen sind noch nicht sonderlich ausgereift.

    über die wlan sache habe ich mir auch schon gedanken gemacht. ich nutze hier ne time capsule aber da die verbindung erst auf befehl hergestellt wird, hab ich das eigentlich auch ausgeschlossen.

    festplattenplatz ist auch noch genügend vorhanden, ppc apps laufen soweit ich weiss ja sowieso nicht mehr nach den letzten updates und einige geliebte bei mir auch schon länger nicht mehr, da quicktime wohl irgendwie den start unterbindet.

    edit: eine vor monaten eigentlich deinstallierte littlesnitch version hat alle 10 sekunden nach sich selbst gesucht. nach nochmaliger deinstallation sind die ständigen aufrufe weg, der leopard lahmt aber noch immer. sonst kann ich nichts auffälliges finden, auch laufen weiter keine hintergrundprozesse.
     
    #10 linga, 11.06.08
    Zuletzt von einem Moderator bearbeitet: 11.06.08
  11. linga

    linga Gast

    keiner?
     
  12. Casi

    Casi Spartan

    Dabei seit:
    21.12.07
    Beiträge:
    1.601
    Ich würd das auch gerne wissen. Bei mir isses genau so lahm, wähnred die gleichen iMacs (meiner Freunde) super schnell starten. Ich glaub langsam, dass es etwas mit little Snitch zu tun hat. Keiner meiner Freunde hatte LIttleSnitch instaliert und ich habe es in- und kurze Zeit später wieder deinstalliert... Hast du ja auch, wenn ich mich net verlesen habe.

    Hm...
     
  13. landplage

    landplage Admin
    AT Administration

    Dabei seit:
    06.02.05
    Beiträge:
    21.482
    Hast Du mal die Aktivitäten aller Prozesse angesehen? Vielleicht läuft da noch ein mit angemeldeter Benutzer im Hintergrund oder ein Druckjob spoolt vor sich hin.

    Überhaupt: Ist ein neu angelegter Benutzer auch so langsam?
     
  14. linga

    linga Gast

    nichts dergleichen, leider. der benutzerwechsel geht schnell - zurück zu meinem problemaccount allerdings auch, tritt also nur nach neustart auf. ich werde mal die gesamten konsolenmeldungen durchsehen beim nächsten neustart...
     
  15. landplage

    landplage Admin
    AT Administration

    Dabei seit:
    06.02.05
    Beiträge:
    21.482
    Ich meinte nicht, ob der Benutzerwechsel schnell geht, sondern ob der Mac beim Starten unter einem neu angelegten Benutzer auch so langsam ist.
     
  16. linga

    linga Gast

    ich hab was in der syslog gefunden:

    letzteres verwundert mich etwas. da vergehen nach dem fehler 15 sekunden, ohne das weiter was passiert. sieht ganz so aus, als sei hier das problem

    @landplage: hab ich noch nicht versucht

    folgendes gibt mir auch zu denken, betrifft aber nur den bootprozess

    mein leo is ne update version auf tiger.
     
    #16 linga, 13.06.08
    Zuletzt von einem Moderator bearbeitet: 13.06.08
  17. Macbeatnik

    Macbeatnik Golden Noble

    Dabei seit:
    05.01.04
    Beiträge:
    24.947
    Einige "ältere" Prozesse sind wohl noch nicht an launchd angepasst und werfen diese Meldung aus, ich denke, aber das bedeutet nichts, das kannst du als Fehler ausschließen. Interessanter wären de richtigen Hänger, also die Prozesse die zum abarbeiten richtig Zeit brauchen.
    Eine Startverzögerung kann z.B. auch in einem verstellten systemuiServer hängen, löscht/verschiebt man hier die zugehörige .plist(com.apple.systemuiserver.plist) wird eine neue erstellt und die dann hoffentlich mit richtigen Werten.
    Ansonsten, hast du einen USB Hub angeschlossen, auch der verursacht mit angeschlossenen Geräten manchmal Fehler
     
  18. Tekl

    Tekl Fairs Vortrefflicher

    Dabei seit:
    01.06.05
    Beiträge:
    4.622
    Was passiert denn, wenn du deinen Mac mal im Safemode startest? Also beim Startton die Shift-Taste gedrückt halten. Sobald die Benutzerauswahl oder dein Benutzer erscheint (dauert lange), solltest du nochmals neu starten, da beim Safemode nicht alles geladen wird. Danach sollte einiges internes aufgeräumt sein und nach einem weiteren Neustart wieder flott laufen.
     
  19. linga

    linga Gast

    das usb hub hab ich mal abgezogen, wird leider nicht schneller.
    safemode habe ich auch versucht, danach sogar 2 mal neugestartet und nun hat es vom nutzer anmelden bis firefox endlich auf gegangen ist stolze 1:20 gedauert.
     
  20. Macbeatnik

    Macbeatnik Golden Noble

    Dabei seit:
    05.01.04
    Beiträge:
    24.947
    Diese 1.20 sind ja in den logs dokumentiert, wo hängt er da? Den kleinen Blocker werden wir schon finden und ihn dann den Jogi Löw für Montag als Unterstützung schicken;)
     

Diese Seite empfehlen