1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Leo update und Server geht nicht

Dieses Thema im Forum "macOS & OS X" wurde erstellt von Steglich, 26.10.07.

  1. Steglich

    Steglich Querina

    Dabei seit:
    06.01.04
    Beiträge:
    183
    Gerade habe ich auf Leo geupdated (wie ich das denglisch hasse:)), und jetzt kann ich nicht mehr auf meinen Server zugreifen.

    Im Browser bekomme ich folgende Fehlermeldung:
    Forbidden
    You don't have permission to access /~thomas_steglich/index.html on this server.

    Die Zugriffsrechte des Sites Verzeichnisses sollten in Ordnung sein:
    ich: Lesen & Schreiben
    (unbekannt): Nur Lesen
    everyone: Nur Lesen

    Unter Sharing ist Websharing aktiviert.

    Wie kann ich auf meinen Webserver wieder zugreifen?
     
  2. Steglich

    Steglich Querina

    Dabei seit:
    06.01.04
    Beiträge:
    183
    http://127.0.0.1/ geht

    Wenn ich die Seite

    http://127.0.0.1/

    aufrufe, bekomme ich die Meldung, dass Apache läuft.
     
  3. MacMan2

    MacMan2 Gast

  4. dahui

    dahui Carmeliter-Renette

    Dabei seit:
    22.10.06
    Beiträge:
    3.303
    leo hat deine httpd.conf überschrieben denke ich, ich hoffe du hast ein fullbackup :-[ das manuelle nachziehen von php5 und mysql 4/5 steht bei mir dann nämlich auch noch gleich an.

    dahui
     
  5. Steglich

    Steglich Querina

    Dabei seit:
    06.01.04
    Beiträge:
    183
    leider

    leider habe ich kein Full Back Up, aber auf einem zweiten Rechner noch eine identische alte Installation.

    Wo finde ich die richtige httpd.conf?
     
  6. dahui

    dahui Carmeliter-Renette

    Dabei seit:
    22.10.06
    Beiträge:
    3.303
    etc/httpd/
     
  7. Steglich

    Steglich Querina

    Dabei seit:
    06.01.04
    Beiträge:
    183
    leider nicht

    Leider funktioniert die httpd.conf vom anderen System nicht.
    Soll ich einmal versuchen die entropy Version zu installieren?
    Immerhin hatte ich diese vorher.
     
  8. Katzenfutter

    Katzenfutter Kaiser Wilhelm

    Dabei seit:
    16.12.06
    Beiträge:
    174
    die /etc/httpd enthält meine alte httpd.conf.
    Leopard hat wohl den Apache komplett woanders installiert.
    Weiß jemand wo?
     
  9. Katzenfutter

    Katzenfutter Kaiser Wilhelm

    Dabei seit:
    16.12.06
    Beiträge:
    174
    Nachtrag:
    schaut alle mal unter /etc/apache2 =)
    Viel Spaß bei der Neukonfiguration!

    Bringt Entropy die Module für Apache2 mit!?

    Wurde jemals kommuniziert, dass Apache2 mit Leopard ausgeliefert wird?
     
  10. Katzenfutter

    Katzenfutter Kaiser Wilhelm

    Dabei seit:
    16.12.06
    Beiträge:
    174
    Äh, ja =)
     
  11. Steglich

    Steglich Querina

    Dabei seit:
    06.01.04
    Beiträge:
    183
    Lösung?

    Unter der folgenden Adresse:
    http://discussions.apple.com/thread.jspa?threadID=1187457&tstart=15

    fand ich diese Lösung:
    mit der ich mein Verzeichnis Websites wieder zum laufen brachte.
     
  12. Steglich

    Steglich Querina

    Dabei seit:
    06.01.04
    Beiträge:
    183
    Lösung für MySQL

    Unter Tiger hatte ich MySQL nachinstalliert, und nach dem Update auf Leopard ließ es sich zwar über das Prefpane starten, beziehungsweise lief voreingestellt, aber php fand die Datenbanken nicht.

    folgende Seite:
    http://docs.info.apple.com/article.html?artnum=302977

    brachte mir diese Lösung:
    Und siehe da alles läuft wieder: PHP und MySQL
     
  13. MacMark

    MacMark Biesterfelder Renette

    Dabei seit:
    01.01.05
    Beiträge:
    4.709
    Die Rechte sollten dabei so aussehen, Beispiel mit /etc/apache2/users/macmark.conf:
    -rw-r--r-- 1 root wheel 143B Aug 4 2006 macmark.conf
     
  14. robertmk

    robertmk Normande

    Dabei seit:
    04.09.07
    Beiträge:
    583
    Hallo ich habe komisch seit einigen Tagen das selbe Problem!

    Das habe ich gleich ausprobiert, aber die Datei mit diesem Inhalt existiert! Mir ist gerade dann aufgefallen, dass alles funktioniert, wenn ich "File Sharing" aktiviere?! Was ist den das?

    Ist FS deaktiviert, dann bekomme ich auch die Meldung mit den Zugriffsrechten! Es kann doch nicht sein, das ich für den Webserver auch AFP Sharing aktivieren muss!


    Edit: Ok noch folgende Ergänzung: Wenn ich in File Sharing unter meinem Benutzer die Rechte für Everyone auf "kein Zugriff" setze (und FS deaktiviere), dann bekomme ich die Zugriffsmeldung des Webservers. Ist Everyone auf Lesen (und FS deaktiviert) dann kommt die Webseite! :(


    Edit2: Kann mir jemand sagen, wie ich die Rechte für Leo's Webserver setzen kann, ohne Everyone auf "Lesen" (File Sharing) zu setzen?
     
    #14 robertmk, 18.12.07
    Zuletzt bearbeitet: 18.12.07
  15. robertmk

    robertmk Normande

    Dabei seit:
    04.09.07
    Beiträge:
    583
    ok, habe mich für mich eine Lösung gefunden: Everyone auf Lesen setzen und den Gast Account komplett deaktivieren. Gefällt mir nicht wirklich, aber so gehts. Vielleicht hat jemand noch eine bessere Idee dafür?
     

Diese Seite empfehlen