1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

[LaTeX] Keine Umlaute

Dieses Thema im Forum "LaTeX" wurde erstellt von Bier, 01.11.07.

  1. Bier

    Bier Pomme au Mors

    Dabei seit:
    24.08.07
    Beiträge:
    867
    Hi!

    Kann mir wer sagen warum ich bei

    http://www.nopaste.org/p/aS3IzQ8Ilb

    diesem Text keine Umlaute bekomme?

    [​IMG]

    Eigentlich hatte ich die mit dem LaTeX Header bisweilen immer... doch seit 10.5 mit Full TeXLive2007 aus MacTeX nicht mehr.

    Komisch...
     
  2. ArrowDebreu

    ArrowDebreu Klarapfel

    Dabei seit:
    24.01.07
    Beiträge:
    281
    ersetz einfach
    \usepackage[utf8]{inputenc} % direkte Angabe von Umlauten im Dokument
    durch
    \usepackage[applemac]{inputenc} % direkte Angabe von Umlauten im Dokument
    oder willst du das nicht?
     
    Bier gefällt das.
  3. Bier

    Bier Pomme au Mors

    Dabei seit:
    24.08.07
    Beiträge:
    867
    Doch, solange andere meine pdf lesen können ;)

    Das hat mir auch ne Menge anderer Kleinfehler beseitigt. Nice one!
     
  4. Nogger

    Nogger Damasonrenette

    Dabei seit:
    05.11.05
    Beiträge:
    494
    Nun da der Fehler erkannt ist (Kodierung im Editor anders als Latex mitgeteilt): Es wäre sinnvoller im Sinne der Interoperabilität im Quelltext wieder UTF-8 einzustellen, und dann auch im Editor ebenso UTF-8 zu aktivieren.
     
  5. Bier

    Bier Pomme au Mors

    Dabei seit:
    24.08.07
    Beiträge:
    867
    Das war Textmate auf UTF8... das hätte ich sonst ja sofort gemerkt.
     
  6. Nogger

    Nogger Damasonrenette

    Dabei seit:
    05.11.05
    Beiträge:
    494
    Das ist etwas verwirrend. Wenn du in Latex sagst, der Text ist applemac codiert, und dann wird alles korrekt gesetzt und dargestellt, dass war die Datei auch vom Editor in dem Zeichensatz abgespeichert und nicht in UTF8. Alles andere ergibt keinen Sinn. Wenn du in TextMate die Datei offen hast, dann zeigt File -> Re-Open With Encoding einen Haken bei UTF8? Sehr merkwürdig.
     
  7. Bier

    Bier Pomme au Mors

    Dabei seit:
    24.08.07
    Beiträge:
    867
    Hmm... ah, TM öffnet in MacRoman trotz dessen, dass standardmäßig UTF8 eingestellt ist.
     
  8. Nogger

    Nogger Damasonrenette

    Dabei seit:
    05.11.05
    Beiträge:
    494
    Kann es sein, dass du die Datei (evtl. in einem anderen Editor) mit MacRoman Zeichensatz gespeichert hast? Dann wird TextMate das wohl erkennen und die Datei als MacRoman öffnen.
     
  9. Bier

    Bier Pomme au Mors

    Dabei seit:
    24.08.07
    Beiträge:
    867
    Wahrscheinlich dieses eklige TeXShop...
     

Diese Seite empfehlen