1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Landeseinstellung: ständig immer wieder US-Tastuatur!

Dieses Thema im Forum "macOS & OS X" wurde erstellt von pedepe, 07.07.09.

  1. pedepe

    pedepe Idared

    Dabei seit:
    01.07.08
    Beiträge:
    27
    Landeseinstellung-ständig US-Tastuatur!

    Bei einem unserer ansonsten identischen iMacs (OS X 10.5.7) aktiviert sich seit einiger Zeit nach Neustart oder Benutzerwechsel oft (aber nicht immer!) bei Landeseinstellungen -> Tastaturmenü die Einstellung US. Man kann natürlich nach dem Start wieder die deutsche Tastatur aktivieren, aber das nervt auf Dauer gewaltig. Das Problem tritt nur auf einem Rechner auf. Die Rechner sind von der Software her beinahe identisch. Wir denken es ist ein Softwareproblem, konnten aber die das Problem verursachende "schädliche Software" bislang leider nicht identifizieren.
    Wie bekommt man das wieder hin, bzw. wo liegt der Grund für den spontanen Tastaturwechsel?

    vielen dank ...
     
  2. MacAlzenau

    MacAlzenau Golden Noble

    Dabei seit:
    26.12.05
    Beiträge:
    19.401
    Mit cmd-Leertaste kann man zwischen zwei Tastaturbelegungen wechseln (kann sein, daß das in den Systemeinstellungen eingestellt werden muß oder daß das Tastaturmenü in der Menüleiste angezeigt werden muß), das kann ein Auslöser sein für ungewollte Änderungen, oder es hilft zumindest, rasch wieder auf Deutsch umzustellen.
     
  3. rc4370

    rc4370 Wöbers Rambur

    Dabei seit:
    09.03.09
    Beiträge:
    6.528
    setze mal in den systemeinstellungen unter sicherheit einen haken bei "kennwort für jede geschützte systemeinstellung".
    kontrolliere ob in den landeseinstellungen unter "tastaturmenü" NUR deutsch markiert ist.
     
  4. SeeEmWeiKey

    SeeEmWeiKey Jonagold

    Dabei seit:
    19.01.09
    Beiträge:
    21
    Hallo "pedepe",

    kann mich "MacAlzenau" nur anschließen.

    Mich hat das früher auch genervt. Inzwischen habe ich die Umstellung der Tastatursprache per Shortcut einfach abgestellt.

    Zu finden in den Systemeinstellungen/Tastatur & Maus/Tastaturkurzbefehle – vor "Tastaturmenü" Häkchen raus.

    Grüßle
    Stefan:)
     
  5. pedepe

    pedepe Idared

    Dabei seit:
    01.07.08
    Beiträge:
    27
    ...leider keine Lösung in Sicht!

    ...vielen Dank für die Hinweise...habe alle ausprobiert...das Problem ist unverändert vorhanden! Leider! Scheinbar kennt niemand den tieferen Grund!
     
  6. Rastafari

    Rastafari Golden Noble

    Dabei seit:
    10.03.05
    Beiträge:
    17.902
    So etwas tritt immer wieder als Seiteneffekt auf, wenn man sich als (freigeschalteter) root-Benutzer an der GUI anmeldet.
    Boote von der Leo System-DVD. Das Modul "Kennworte zurücksetzen" beinhaltet auch eine weitere Funktion um die Rechte der Benutzerordner zu korrigieren. Versuch das.
     
  7. pedepe

    pedepe Idared

    Dabei seit:
    01.07.08
    Beiträge:
    27
    ...leider zum wiederholten Male: DIE LANDESEINSTELLUNG STELLT SICH IMMER WIEDER AUF US-TASTATUR. Alle Lösungsvorschläge (auch der von Rastafari) fruchten leider nix. Ich denke, dass vielleicht NIEMAND eine Lösung kennt, denn evtl. ist es einfach ein bislang UNGELÖSTES Softwareproblem oder so...???
     
  8. Macbeatnik

    Macbeatnik Golden Noble

    Dabei seit:
    05.01.04
    Beiträge:
    24.957
    Es könnte an der zuständigen Voreinstellungsdatei liegen, die kann defekt oder nicht schreibfähig sein, so dass deine Einstellungen nur bis zum Neustart oder zum Benutzerwechsel halten und dann eben wieder zurückfallen in die US Einstellung.
    Die Voreinstellungsdatei ist die
    com.apple.HIToolbox.xxxxxxxxx.plist (xxxxx…)steht für eine beliebige Zahlenfolge.
    Die Datei liegt in DeinBenutzer/Libary/Preference/ByHost.
    Diese solltest du verschieben/Löschen, sie wird anschliessend neu angelgt, ich würde nach dem Löschen den Rechner neustarten und du musst anschliessend evetnl. Einstellungen fürs Tastaturlayout neu machen.
     
  9. Atelis

    Atelis Akerö

    Dabei seit:
    01.03.07
    Beiträge:
    1.831
    Das Problem hatten wir doch jetzt schon so oft? Ist dein Loginpanel auch auf englisch? Ich meine nicht die Tastaturbelegung, aber steht dort "Password"?

    Bei einem Rechner hat es bei mir geholfen das Combo-Update 10.5.8 aufzuspielen. Wenn das noch nicht klappen sollte, versuch es mal mit folgenden Terminalzeilen:

    Code:
    sudo rm -f /var/log/CDIS.custom
    sudo "/System/Library/CoreServices/Language Chooser.app/Contents/MacOS/Language Chooser"
     

Diese Seite empfehlen