1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Kennwort-Eingabe leitet nicht weiter

Dieses Thema im Forum "macOS & OS X" wurde erstellt von wfatnwfp, 21.02.09.

  1. wfatnwfp

    wfatnwfp Erdapfel

    Dabei seit:
    21.02.09
    Beiträge:
    5
    Hallo zusammen,
    ich habe seit heute Probleme mich auf meinem MacBook anzumelden. Das Kennwort wird zwar erkannt ich werde aber direkt wieder zurueck zur Kennworteingabe geleitet. Aus dieser Schleife komme ich nicht raus.
    Jetzt muss ich diesen Beitrag ueber meine boot camp/windows partition schreiben, das geht eigentlich gar nicht.
    Also wenn jemand eine idee hat was ich da machen koennte waere ich sehr dankbar....
    Viele Gruesse
    Wolfgang
     
  2. GunBound

    GunBound Pohorka

    Dabei seit:
    23.06.05
    Beiträge:
    5.666
    Tönt nach einem Softwarefehler.
    Geh mal diese Schritte der Reihe nach durch:
    1. Mit gedrückter Shift-Taste aufstarten (dauert etwas länger; Taste loslassen, sobald der Regenwurm kommt: [​IMG]). Jetzt versuchen, dich anzumelden.
    2. Wenn das nicht geklappt hat: Mit S (Apfel+S) gedrückt aufstarten — nicht erschrecken: Eine weisse Schrift auf schwarzem Hintergrund erscheint. Danach siehst du unten irgendwo einen Satz wie "If you wish to boot the system:" mit einer Kommandozeile dahinter. Diese (zur Sicherheit) eingeben (Achtung: "/" ist das Minussymbol, Ypsilon ist Z und umgekehrt [amerikan. Layout]). Danach rm /Library/Preferences/com.apple.loginwindow.plist eingeben (und zwar genau so!). Jetzt mit reboot das System neustarten.
    Hilft das nicht? Dann überlege ich mir noch anderes Zeugs.
     
  3. wfatnwfp

    wfatnwfp Erdapfel

    Dabei seit:
    21.02.09
    Beiträge:
    5
    Vielen Dank, hat leider nix geaendert. Weder mit der shift Taste noch ueber Apfel s. Bei der Apfel s Variante kam die Meldung `no such file or directory` ich habe einen screenshot angehaengt wenn dir noch was einfaellt waere ich sehr dankbar ich bin gerade in Pakistan und der naechst Applestore ist vermutlich in Moskau... oder so
     

    Anhänge:

  4. GunBound

    GunBound Pohorka

    Dabei seit:
    23.06.05
    Beiträge:
    5.666
    Du musst zwischen "rm" und dem Pfad einen Abstand einfügen, sonst klappt es nicht.
    Edit: Wenn es dann immer noch nicht geht, dann gib den Vorschlag ein, der kommt ("If you want to make modifications to files:"):
    Code:
    /sbin/mount -uw /
    Danach die "rm blablabla" -Zeile nochmals eingeben.
     
  5. wfatnwfp

    wfatnwfp Erdapfel

    Dabei seit:
    21.02.09
    Beiträge:
    5
    Hallo! das geht leider auch nicht... ich hab nochmal meine Versuche angehaengt
    Gruesse
     

    Anhänge:

  6. GunBound

    GunBound Pohorka

    Dabei seit:
    23.06.05
    Beiträge:
    5.666
    Das ist allerdings extrem seltsam, weil…
    …das Filesystem laut Bild 2 nicht beschreibbar ist
    …du mit dieser Methode eingeschränkten Zugriff hast (und das mit root!)

    Sorry, ich bin mit meinem Latein am Ende.
    Tipp, wenn Niemand eine Lösung hat: Wenn du einen Zweit-Mac hast, dann verbinde die beiden via FireWire-Kabel, starte vom "Defekten" mit gedrückter Taste "T" auf, und er erscheint beim Zweiten als Festplatte. Dann die Daten sichern und das System neu aufspielen.
     
  7. drlecter

    drlecter Wöbers Rambur

    Dabei seit:
    04.11.06
    Beiträge:
    6.442
    Der Mount Befehl darf nicht mit einem / enden. Also /sbin/mount -uw /
    Danach solltest du die Datei löschen können.
     
  8. luk!

    luk! Wohlschmecker aus Vierlanden

    Dabei seit:
    22.04.08
    Beiträge:
    236
    probier es mal mit genau der Eingabe der Vorschläge, sprich:
    /sbin/fsck -fy [Enter]
    /sbin/mount -uw / [Enter]
    rm /Library/Preferences/com.apple.loginwindow.plist [Enter]
    reboot [Enter]

    Ich nehme mal an, dass standardmäßig read-only gemounted wird, was den Fehler in Bild 2 erkären würde...

    MfG
    luk!

    PS: in diesem (englischen) Artikel werden noch ein paar Ansätze beschrieben; der Verfasser hatte offenbar das gleiche Problem: http://dltj.org/article/macosx-launchservices-login-loop-fix/
     
    #8 luk!, 22.02.09
    Zuletzt bearbeitet: 22.02.09
  9. GunBound

    GunBound Pohorka

    Dabei seit:
    23.06.05
    Beiträge:
    5.666
    Es könnte auch sein, dass der Befehl zum Mounten des Systems falsch ist; gib anstatt "/sbin/mount -uw /" mal "/sh/etc/rc" ein (war zumindest bei Tiger so; dies ist sozusagen die letzte Lösung).
     
  10. GunBound

    GunBound Pohorka

    Dabei seit:
    23.06.05
    Beiträge:
    5.666
    Also sollte der Befehl /sbin/mount -uw heissen? Wäre das nicht etwas komisch (mit dem Schrägstrich steht er ja oben im Single User-Mode; er braucht ja ein System, das er booten kann)?
     
  11. drlecter

    drlecter Wöbers Rambur

    Dabei seit:
    04.11.06
    Beiträge:
    6.442
    Schau mal auf das dritte Bild. Er hat /sbin/mount/ -uw geschrieben. Da fehlt ein Leerzeichen. Es steht ja auch beim booten richtig. Man braucht das einfach nur abschreiben. Also:
    /sbin/mount -uw /
    Luk sagte das ja schon weiter oben. Es hat es einfach falsch eingegeben.
     
    GunBound gefällt das.
  12. GunBound

    GunBound Pohorka

    Dabei seit:
    23.06.05
    Beiträge:
    5.666
    Es ist ein ganz anderes Problem: Ich bin zu blöde! :D

    Der Mac braucht ja zu wissen, welche Datei er wo löschen soll!

    @Thread-Ersteller: Lass das /sbin/mount -uw weg, gib stattdessen Folgendes ein:
    Code:
    [COLOR="DarkSlateGray"]ls /users[/COLOR]
    #Jetzt erscheinen Namen, darunter auch ein "Shared". Merk dir den Namen deines Accounts (du kannst diesen ersten Befehl überspringen, wenn du den Kurznamen [den neben deinem Häuschen] auswendig weisst).
    #Jetzt dorthin wechseln:
    [COLOR="DarkSlateGray"]cd /users/(dieser Name)/Library/Preferences[/COLOR]
    #Jetzt bist du im gewünschten Ordner
    #Endlich die Datei löschen:
    [COLOR="DarkSlateGray"]rm com.apple.loginwindow.plist[/COLOR]
    #Ist noch nicht fertig. Jetzt noch eine zweite Datei löschen:
    [COLOR="DarkSlateGray"]cd /Library/Preferences[/COLOR]
    [COLOR="DarkSlateGray"]rm com.apple.loginwindow.plist[/COLOR]
    #Das sollte es gewesen sein. Wenn du dich immer noch nicht anmelden kannst, dann ist am System etwas böse schief gegangen!
    Anzumerken ist: Gib erst etwas ein, wenn links das hier steht: :/ root #
     
  13. wfatnwfp

    wfatnwfp Erdapfel

    Dabei seit:
    21.02.09
    Beiträge:
    5
    hat leider alles nix gebracht... aber danke fuer die vielen infos... geh mir jetzt nen PC kaufen und installiere Linux
     
  14. GunBound

    GunBound Pohorka

    Dabei seit:
    23.06.05
    Beiträge:
    5.666
    Gleich so heftig?
     

Diese Seite empfehlen