1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

keine VNC Session über ipsec Tunnel möglich

Dieses Thema im Forum "macOS & OS X" wurde erstellt von Murmler, 25.10.06.

  1. Murmler

    Murmler Fuji

    Dabei seit:
    07.09.06
    Beiträge:
    37
    Hallo zusammen,

    hat jemand eine Idee, warum ich keine VNC (Chicken of VNC) Sitzung über einen VPN-Tunnel (IPSecuritas IPsec) starten kann? Bin ich vor Ort, also innerhalb des LANs der Gegenstelle, funktioniert VNC dagegen einwandfrei. An der VNC Server/Client Konfiguration dürfte es somit eigentlich nicht liegen. Habe es mit 4 oder 5 verschiedenen Servern probiert, jeweils ohne Erfolg. Andere Dienste funktionieren jedoch einwandfrei über den ipsec Tunnel (z.B. Shares über SMB).

    Jemand ne Idee wo ich hier den Fehler suchen muss? Über Ideen, Vorschläge und Tipps wär ich sehr dankbar!

    Grüße
    Murmler

    Konfig:
    MacBook Pro, OS X 10.4.8
    Chicken of VNC (2.0b4), IPSecuritas 3.0 Beta 14
    VPN Gegenseite: Watchguard Firebox III; WinNT,Win2003 und Linux Server mit UltraVNC
     
  2. ezi0n

    ezi0n Leipziger Reinette

    Dabei seit:
    07.07.05
    Beiträge:
    1.786
    also einfachste frage: sind die services über den tunnel überhaupt erlaubt? man kann ja auf der watchguard die services definieren die über den tunnel erlaubt sein sollen ..
     
  3. Murmler

    Murmler Fuji

    Dabei seit:
    07.09.06
    Beiträge:
    37
    Ja, ipsec User haben Berechtigungen für den Watchguard Dienst "any" (der mit dem Loch in der Mauer). Es sollte diesbezüglich also keine Einschränkungen geben. Im FW-Log konnte ich ebenfalls nichts verdächtiges finden. Werd das Ganze mal unter Windows mit dem MUVPN ipsec-Client von Watchguard versuchen. Wenn es dort funktioniert, dann gibts zumindest kein firewalltechnisches Problem.
     
  4. ezi0n

    ezi0n Leipziger Reinette

    Dabei seit:
    07.07.05
    Beiträge:
    1.786
    schau mal was die FB III mit den antwortpaketen macht, bzw log mal den tunnel genau und check dann die logs was da falsch läuft ..
     
  5. Murmler

    Murmler Fuji

    Dabei seit:
    07.09.06
    Beiträge:
    37
    Problem gelöst!

    Hatte total übersehen bzw. vergessen, dass ich die VNC Server per 'AuthHost' Registry Eintrag zusätzlich abgesichert habe und nur Clients aus unserem LAN ohne Rückbestätigung authentifiziert habe. Während ich also versucht habe eine VNC Session zu eröffnen, ging auf der anderen Seite ein Fenster auf "Press accept....usw" um die Remote Sesssion zuzulassen. Habe den AuthHost parameter angepasst und voila...alles funktioniert :)

    Dennoch vielen Dank für die Beiträge!
     

Diese Seite empfehlen