1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Keine Internetverbindung trotz Netzwerkverbindung (Wi-Fi)

Dieses Thema im Forum "iPhone" wurde erstellt von Boaschtl, 23.09.08.

  1. Boaschtl

    Boaschtl Granny Smith

    Dabei seit:
    23.09.08
    Beiträge:
    14
    Hey Jungs/Mädlz,
    Ich hoff' ma, dass mir jemand bei meinem Problem helfen kann:
    Bei meinem IPhone 3G "besteht keine Verbindung zum Internet" (sagt mein Safari-Browser und der App-Store), obwohl ich über Wi-Fi eine Verbindung zu meinem AirPlus G+ Router habe... Das IPhone hat das Netzwerk sofort erkannt, ich habe den Netzwerkschlüssel eingegeben und man sieht auch einen Haken vor dem Netzwerk (bei falschen Netzwerkschlüssel wäre mir das wohl gemeldet worden), das in meinem Fall "default" heißt. Die Signalstärke ist auch voll und wird oben links angezeigt. Die IP-Adresse des IPhones: 169.254.251.254
    Teilnehmermaske 255.255.0.0, restliche Felder sind leer
    IP des PC's 192.168.0.101

    Hab schon gehört, dass es mit einer evtl. MAC-Sperre oder Ähnlichem zusammenhängen könnte, habe allerdings zu diesem Thema nichts in der Anleitung des Routers gefunden...

    Ich brauche echt dringend Hilfe (wie ihr wahrscheins gemerkt habt ^^)
    Danke im Voraus :D
     
  2. gKar

    gKar Maunzenapfel

    Dabei seit:
    25.06.08
    Beiträge:
    5.362
    Die IP-Adresse des IPhones: 169.254.251.254
    Teilnehmermaske 255.255.0.0, restliche Felder sind leer
    IP des PC's 192.168.0.101

    Also das kann nicht funktionieren. Die IP des iPhones müsste auch mit 192.168.0. beginnen, wenn die Teilnetzmaske vom Netzwerk (nicht die im iPhone angezeigte) 255.255.255.0 ist. Ist sie wirklich 255.255.0.0, so muss die Adresse zumindest mit 192.168. beginnen, die Null ist dann egal.

    Außerdem dürfen natürlich DNS-Server und Gateway nicht leer sein: Ohne Gateway kein Weg aus dem lokalen Netz ins Internet und ohne DNS keine Auflösung von Namen wie "www.xyz.de" zu IP-Adressen.

    Normalerweise sollte das iPhone auf "DHCP" eingestellt sein. Das steht für Dynamic Host Configuration Protokol und bedeutet, dass das iPhone sich einfach beim Router meldet und ihn nach allen notwendigen Einstellungen fragt. Dann müsste es die vier Adressen (IP, Netzmaske, Gateway und DNS) automatisch korrekt setzen. Tut es das nicht, erhält es wohl nicht die korrekten Daten vom Router. Den Fehler würde ich dann eher beim Router als beim iPhone suchen. Durch Tippen auf "Lease erneuern" kann der Datenabruf vom Router erneut probiert werden.

    Wenn DHCP wirklich nicht funktioniert und Du den Fehler auf dem Router nicht findest, gibt's immer noch die Möglichkeit, das iPhone von Hand zu konfigurieren. Lass Dir dann auf Deinem Mac/PC die Einstellungen (dessen IP, Netzmaske, DNS-Adresse und Gateway) anzeigen und übertrage diese Daten ins iPhone, wobei Du nur die IP-Adresse veränderst (hinten z.B. statt der 101 eine 102 anhängen). Hast Du neben iPhone und dem Mac/PC noch andere Geräte im Netzwerk, musst Du allerdings sicherstellen, dass Du eine IP nimmst, die kein anderer Teilnehmer schon benutzt.

    Edit: Sehe gerade, dass die Gateway-Einstellung vom iPhone als "Router" bezeichnet ist.
     
  3. Boaschtl

    Boaschtl Granny Smith

    Dabei seit:
    23.09.08
    Beiträge:
    14
    ja das war mir eig klar, dass das nicht funktionieren kann...das problem ist nur, dass das iphone, sobald ich die netzwerkeinstellungen verlasse, wieder die ip auf 169... und die teilnehmermaske auf 255... umstellt. das feld "router" ist wieder leer, nur "dns" bleibt, wie ich es eingestellt habe.
    die felder such-domains und client-id sind übrigens auch leer
    ich konnte auch direkt nach dem einstellen nicht ins inet
    Danke
     
  4. Boaschtl

    Boaschtl Granny Smith

    Dabei seit:
    23.09.08
    Beiträge:
    14
    hey leute,
    also an den einstellungen meines iphones kann die sache nicht liegen, konnte mich heute problemlos ins internet in unserem kollegstufenzimmer einloggen. das netzwerk wurde sofort erkannt, netzwerkschlüssel eingegeben und schwups...konnte ich surfen, in den app store, wetter,...

    es muss also an den einstellungen meines routers liegen. entweder habe ich wirklich eine mac-sperre oder nur für ein gerät kabellosen zugriff (notebook in meinem fall) oder sonst ein problem, das ihr mir vielleicht helfen könnt zu beseitigen. wenn mir einer weiterhelfen kann, dann bitte gleich alle einzelschritte aufzeigen, bin net so der fachmann ;)

    ich wunder mich trotzdem, warum mir dhcp immer, wenn ich mit dem netzwerk "verbunden" bin, diese komische 169.254... IP und 255.255....teilnetzmaske zuschreibt ^^
     
  5. gKar

    gKar Maunzenapfel

    Dabei seit:
    25.06.08
    Beiträge:
    5.362
    Meine Rede ;)

    Bei der Router-Konfig. kann ich Dir so kaum helfen. Aber schau doch einfach mal durch dessen Einstellungen, meines Wissens sind die D-Link-Einstellungen gar nicht so unübersichtlich und sogar mit Hilfe-Funktion. Ob da z.B. ein MAC-Filter eingerichtet ist oder keiner, sollte doch leicht zu erkennen sein.
     
  6. Boaschtl

    Boaschtl Granny Smith

    Dabei seit:
    23.09.08
    Beiträge:
    14
    also die konfigurationen waren meiner meinung nach jetzt auch nix besonderes...MAC-filter ist auf jeden fall keiner eingerichtet, an was könnte es noch liegen?
    ich hab diese dumme verbindung ja eig auch schon, der router zeigt mich aber auch nicht an.
    was hat es mit dieser IP 169.254.215.254 auf sich, die sich immer wieder von selbst einstellt?!
    der pc hat ja so eine 192.168.xxxxxxxx
     
  7. Berndi

    Berndi James Grieve

    Dabei seit:
    06.09.07
    Beiträge:
    136
    Diese 169.254.x.x-Adressen sind sogenannte automatische private IPs, die werden vergeben wenn ein Netzwerkgerät keine IP zugewiesen bekommt.
    Eigentlich müsste dein iPhone eine 192.168.x.x-Adresse vom Router bekommen.
     
  8. Boaschtl

    Boaschtl Granny Smith

    Dabei seit:
    23.09.08
    Beiträge:
    14
    Und wie kann ich meinen Router dazu überreden mir so eine 192.168.x.x Adresse zuzuweisen ;) ?
     
  9. Berndi

    Berndi James Grieve

    Dabei seit:
    06.09.07
    Beiträge:
    136
    Dein Notebook hat ja die 192.168.0.101 als Adresse -ist diese Adresse fest zugewiesen (manuell eingetragen) oder erhältst du die automatisch?

    Edit: Schau mal ob im Router der DHCP-Server aktiviert ist.
     
    #9 Berndi, 24.09.08
    Zuletzt bearbeitet: 24.09.08
  10. Boaschtl

    Boaschtl Granny Smith

    Dabei seit:
    23.09.08
    Beiträge:
    14
    also die 101. hat der pc, notebook 102.
    woran kann ich das erkennen?
    ich seh grad, dass der adresstyp von dhcp zugewiesen wird, falls du das meinst

    jeps..aktiviert
     
    #10 Boaschtl, 24.09.08
    Zuletzt bearbeitet: 24.09.08
  11. Boaschtl

    Boaschtl Granny Smith

    Dabei seit:
    23.09.08
    Beiträge:
    14
    ich seh grad, dass der adresstyp von dhcp zugewiesen wird, falls du das meinst
     
  12. Boaschtl

    Boaschtl Granny Smith

    Dabei seit:
    23.09.08
    Beiträge:
    14
    ja ist aktiviert
     

Diese Seite empfehlen