Kein Simulator in Xcode

Dieses Thema im Forum "iOS-Developer" wurde erstellt von hen007ry, 10.06.18.

  1. hen007ry

    hen007ry Golden Delicious

    Dabei seit:
    01.04.17
    Beiträge:
    11
    Hi,
    ich habe Xcode erneut installiert (hatte es mal gelöscht) und jetzt gibt es kein simulator mehr.
    Kann man den woanders neu installieren?

    Danke schon mal im voraus
    Henry
     

    Anhänge:

  2. MacApple

    MacApple Schmalzprinz

    Dabei seit:
    05.01.04
    Beiträge:
    3.585
    Hast du ein altes, bestehendes Projekt geöffnet oder ein neues erstellt? Falls ersteres, besteht das Problem auch bei neuen Projekten?

    Sonst schau mal in den Ordner ~/Library/Developer/CoreSimulator/Devices nach, ob da was drin ist. Wenn da was drin ist und trotzdem keine Simulatoren angezeigt werden, würde ich den Inhalt da löschen und in Xcode über den Menüpunkt „Devices and Simulators“ (Apfel-Shift-2) die Simulatoren neu erstellen.
     
  3. hen007ry

    hen007ry Golden Delicious

    Dabei seit:
    01.04.17
    Beiträge:
    11
    Wenn ich ein neues Projekt erstelle, dann gibt es den simulator.

    bei mir gibt es kein Ordner "devices" in core simulator.
     
  4. hen007ry

    hen007ry Golden Delicious

    Dabei seit:
    01.04.17
    Beiträge:
    11
     

    Anhänge:

  5. MacApple

    MacApple Schmalzprinz

    Dabei seit:
    05.01.04
    Beiträge:
    3.585
    Also dann liegt es wohl am Projekt. Du kannst mal versuchen, die „Derived Data“ zu löschen. Den Pfad dafür findest du in den Xcode Einstellungen unter „Locations“.

    Dann dürftest du in neuen Projekten aus keine Simulatoren angezeigt bekommen. Welche Xcode Version hast du denn da? Du hast auch in dem Library-Ordner deines Users geguckt?
     
  6. hen007ry

    hen007ry Golden Delicious

    Dabei seit:
    01.04.17
    Beiträge:
    11
    Ok sorry. Also den Ordner gibt es. die Xcode version ist: Version 9.4 (9F1027a) Soll ich den Inhalt von devices jetzt löschen?

    Und was soll ich mit dem Pfad machen?
    Sorry bin noch ein Xcode Anfänger
     

    Anhänge:

  7. hen007ry

    hen007ry Golden Delicious

    Dabei seit:
    01.04.17
    Beiträge:
    11
  8. hen007ry

    hen007ry Golden Delicious

    Dabei seit:
    01.04.17
    Beiträge:
    11
    wie kann man jetzt den simulator in das Projekt laden? hast du da eine idee?
     
  9. MacApple

    MacApple Schmalzprinz

    Dabei seit:
    05.01.04
    Beiträge:
    3.585
    Da das Problem bei neuen Projekten nicht auftritt, nein.

    Klick auf den Pfeil rechts neben dem Pfad, dann wird ein Finder-Fenster geöffnet. Lösche alles, was dem Ordner „Derived Data“ liegt.
     
  10. hen007ry

    hen007ry Golden Delicious

    Dabei seit:
    01.04.17
    Beiträge:
    11
    Das habe ich jetzt gemacht und xcode danach neugestartet. Leider ist es immer noch nicht da
     
  11. hen007ry

    hen007ry Golden Delicious

    Dabei seit:
    01.04.17
    Beiträge:
    11
    ah hab jetzt die antwort! bei mir gab es einen Fehler da ich bei "ios deployment target" ios 12 ausgewählt hatte