1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Kein Java 6 für Leo?

Dieses Thema im Forum "macOS & OS X" wurde erstellt von Slashwalker, 22.12.07.

  1. Slashwalker

    Slashwalker Winterbanana

    Dabei seit:
    15.05.06
    Beiträge:
    2.190
    Hallo,
    ich wollte mir heute Java 6 herunterladen und musste feststellen das es nur für Tiger verfügbar ist. Das entsprechende Update stammt vom 13.12.2007. Finde ich nicht Okay, das die das "alte" System bevorzugen.
     
  2. Paul__

    Paul__ Jamba

    Dabei seit:
    07.08.06
    Beiträge:
    58
  3. Slashwalker

    Slashwalker Winterbanana

    Dabei seit:
    15.05.06
    Beiträge:
    2.190
    Hmm ich bin kein ADC Mitglied. Ich brauch Java 6 nur für ColdFusion, damit ColdFusion auf neue Methoden in java.io.File zugreifen kann. Bin nicht mal sicher, ob da nicht die JRE reicht.
     
  4. crossinger

    crossinger Doppelter Melonenapfel

    Dabei seit:
    30.07.06
    Beiträge:
    3.369
    Wo hast du denn diese dubiosen Infos her? Das, was Apple als "Java Release 6" bezeichnet, war ein Update für Java 1.5 und 1.4. Die "6" ist eine Apple-interne Zählung und hat nix mit "Java6" zu tun!

    Und im Übrigen reicht zum Download des bereits zitierten Pakets auch eine kostenlose ADC-Mitgliedschaft.

    Du bist nicht sehr gründlich im Lesen von Informationen... o_O

    *J*
     
  5. Slashwalker

    Slashwalker Winterbanana

    Dabei seit:
    15.05.06
    Beiträge:
    2.190
    Okay. Ich hab mich jetzt als ADC angemeldet und dieses Java 6 runtergeldaen und installiert. Ist aber leider nicht das, was ich meine. Zumindest enthält diese Version auch nicht die von mir gesuchte Methode in java.io.File.

    Eidth sagt:
    Auszug aus dem ColdFusion Administrator:

    JVM Details
    Java Version 1.5.0_13
    Java Vendor Apple Inc.
    Java Vendor URL http://www.apple.com/
    Java Home /System/Library/Frameworks/JavaVM.framework/Versions/1.5.0/Home


    Da sollte 1.6.0_x stehen damit es funzt.

    Aber OS X ist ja sooo fortschrittlich.
     
    #5 Slashwalker, 22.12.07
    Zuletzt bearbeitet: 22.12.07
  6. mpete

    mpete Gast

    Hi,

    bei der Java 6 für OSX handelt es sich um eine Beta, die zum Testen frei gegeben wurde. Mit dem ganz klaren Hinweis, dass es nicht operativ eingesetzt werden sollte.

    Daher wird es auch nicht per Default zur Standard JVM des Betriebsystems. Da es eben für Entwickler gedacht ist, die sich mit der Materie befassen wollen. Sonst wundern sich nachher alle das Applet/Anwendung XY unter OSX immer abstürzt. Also falls Du wirklich mit der Beta arbeiten möchtest, dann stell die Standard JVM auf Java 6 um. (Sollte unter Dienstprogramme->Java->Java Einstellungen gehen)

    Ach ja, läuft auch momentan nur mit Core 2 Duo Prozessoren. Da ich nur einen Core Duo habe, kann ich nicht beurteilen wie gut die Version funktioniert.

    Gruss,
    Matthias
     
  7. Slashwalker

    Slashwalker Winterbanana

    Dabei seit:
    15.05.06
    Beiträge:
    2.190
    Unter Dienstprogramme -> Java -> Java Einstellungen listet er mir nur J2SE 1.4.2 und J2SE 5.0 auf. Der Installer von Java 6 lief aber ohne Fehlermeldung durch. In System/Library/Frameworks/JavaVM.framework/Versions gibt es auch einen Ordner 1.6.0

    Es ärgert mich halt, das OS X in dem Punkt Windows & Linux hiterher hinkt.
     
  8. Slashwalker

    Slashwalker Winterbanana

    Dabei seit:
    15.05.06
    Beiträge:
    2.190
    Super, auf Dosen läuft JAVA 6 Update 3 stabil ! Egal ob Windows oder Linux. Schande.
    Close it.
     
  9. Bier

    Bier Pomme au Mors

    Dabei seit:
    24.08.07
    Beiträge:
    867
    Langsam wird es Zeit... Seifenblasengefahr bei Apple.
     

Diese Seite empfehlen