1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

kein Internet, obwohl ping <IP> und host <URL> ok

Dieses Thema im Forum "macOS & OS X" wurde erstellt von haribald, 08.01.06.

  1. haribald

    haribald Gast

    Hallo

    ich habe ein merkwürdiges Problem. Mein OSX 10.2.8 ist via linux gateway und router am Internet angeschlossen. Das OSX ist als DHCP-Client mit manuell eingetragenen (funktionierenden) DNS-Servern konfiguriert.
    Default route ist der Linux-GW
    Das Internet funktioniert nicht. Die Fehlersuche ergibt etwas ganz seltsames: DNS-Auflösung funktioniert offensichtlich, aber nur zum Teil. Im Terminal sieht das so aus:
    prompt% host www.euro.yahoo.akadns.net
    www.euro.yahoo.akadns.net has address 217.12.3.11
    prompt% ping 217.12.3.11
    PING 217.12.3.11 (217.12.3.11): 56 data bytes
    64 bytes from 217.12.3.11: icmp_seq=0 ttl=248 time=77.562 ms
    64 bytes from 217.12.3.11: icmp_seq=1 ttl=248 time=49.298 ms
    ^C
    --- 217.12.3.11 ping statistics ---
    2 packets transmitted, 2 packets received, 0% packet loss
    round-trip min/avg/max = 49.298/63.43/77.562 ms

    prompt% ping www.euro.yahoo.akadns.net
    ping: unknown host www.euro.yahoo.akadns.net



    D.h., host <URL>, ping <IP> gehen, aber ping <URL> nicht..

    Gibt es jemanden, der das erklären kann??
     
  2. mathilda

    mathilda Leipziger Reinette

    Dabei seit:
    17.02.05
    Beiträge:
    1.787
    Hallo und Herzlich Willkommen auf AT!

    Zu Deinem Problem: Ich vermute, dass das host-Programm Deinen DNS fragt, den Du in den Systemeinstellungen eingetragen hast. Das Ping-Programm scheint aber Deinen Router zu fragen, und der kann den Namen nicht auflösen.

    Ich würde folgendes probieren:

    1. Lege in der dhcpd.config zwei DNS-Server fest. Zum einem den Router selbst und zum anderen den von Dir eingetragenen DNS-Server. Bei mir sieht das so aus:
    Code:
    option domain-name-servers 192.168.1.2, 192.168.1.1, 213.157.0.194, 213.157.0.193;
    2. Mache folgende Einträge in /etc/resolv.conf:
    Code:
    search
    nameserver 192.168.1.1
    nameserver 213.157.0.194
    nameserver 213.157.0.193
    Zur Erklärung: Der Rechner, auf dem ich obige Einstellungen habe, hat die IP 192.168.1.2. Mein Router hat die Adresse 192.168.1.1.
     
  3. haribald

    haribald Gast

    Zu Deinem Problem: Ich vermute, dass das host-Programm Deinen DNS fragt, den Du in den Systemeinstellungen eingetragen hast. Das Ping-Programm scheint aber Deinen Router zu fragen, und der kann den Namen nicht auflösen.

    Kann das im Moment nicht testen, aber das würde alles erklären. Auf dem Linux-GW ist kein DNS-Server drauf. Werde es gleich ausprobieren. Vielen Dank!
     
  4. mathilda

    mathilda Leipziger Reinette

    Dabei seit:
    17.02.05
    Beiträge:
    1.787
    Da muss auch gar kein DNS-Server laufen. Die DNS-Anfragen werden einfach weitergeleitet.

    Hier nochmal die beiden Dateien mit den notwendigen Eintraegen:

    1. dhcpd.config
    Code:
    option domain-name-servers 192.168.1.1, 213.157.0.194, 213.157.0.193;
    2. /etc/resolv.conf:
    Code:
    search
    nameserver 213.157.0.194
    nameserver 213.157.0.193
     
  5. haribald

    haribald Gast

    Lösung

    Hallo,

    habe rausgefunden, woran das Problem lag:
    Mein (linux-) DHCP-Server legt im (mac-) resolv.conf den Eintrag
    "domain local" an.
    Dies führt dazu, dass der mac alle URL-Anfragen mit ".local" erweitert und sie mit seinem eigenen resolver-Eintrag (Verz. /etc/resolver) über die IP 224.0.0.251 aufzulösen versucht. Das geht natürlich dann nicht.
    Die Änderung beim Server in "domain search" löst das Problem.
    (Warum der Mac ".local" an alle Anfragen anhängt, verstehe ich allerdings nicht. So macht er zB aus "ping www.google.com" die Anfrage "ping www.google.com.local"...)


    gruss
     
  6. mathilda

    mathilda Leipziger Reinette

    Dabei seit:
    17.02.05
    Beiträge:
    1.787
    Hm, das koennte Sinn ergeben.

    Dein Mac haengt deswegen .local an, weil ihm vorgegeben wird, sich in dieser Domaene aufzuhalten (faelschlicherweise).
     

Diese Seite empfehlen