1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  2. Unsere jährliche Weihnachts-Banner-Aktion hat begonnen! Wir freuen uns auf viele, viele kreative Vorschläge.
    Mehr dazu könnt Ihr hier nachlesen: Weihnachtsbanner 2016

    Information ausblenden

Joomla Backend odyssee

Dieses Thema im Forum "CMS" wurde erstellt von Tom Blues, 10.09.09.

  1. Tom Blues

    Tom Blues Braeburn

    Dabei seit:
    20.02.09
    Beiträge:
    43
    Hallo Freunde,

    versuche seit drei Tagen verzweifelt Joomla lokal ans laufen zu bringen. Aber alle ausprobierten alternativen MAMP, XAMPP stoßen irgendwo an ihre Grenzen. Entweder stimmen die Rechte nicht, oder das Backend läuft nicht sauber und bleibt bei der Installation von Modulen einfach auf einer leeren index.php stehen.
    Nun also wollte ich PHP und MySQL für den Standardwebserver von Snow Leopard installieren, aber oh schreck, obwohl XAMPP gelöscht ist, musste ich feststellen, dass er offensichtlich die ini Dateien des Standardservers umkonfiguriert hat. Jedenfalls verweisst der Server immer noch auf die XAMPP Startseite, die nicht mehr existiert.

    Wie kann ich a) den Standardserver wieder auf den Installationszustand zurückbringen? (Meine Time Capsule ist grad zur Reparatur bei Apple :( )
    b) Kann mir jemand einen Releasestand von MAMP o. XAMPP und Joomla nennen, der Zuverlässig miteinander läuft?

    Viele Grüße

    Sebastian
     
  2. DubiDuh

    DubiDuh Zwiebelapfel

    Dabei seit:
    20.05.08
    Beiträge:
    1.288
    Ich hab das aktuellste XAMPP und aktuellstes Joomla... nutze allerdings Windows und es läuft ohne Probleme? :/

    Sorry, dass ich nicht weiterhelfen kann...
     
  3. Tom Blues

    Tom Blues Braeburn

    Dabei seit:
    20.02.09
    Beiträge:
    43
    Also, ich hab das Problem mittlerweile gefunden. Sowohl der Standardwebserver von Snow Leopard, die aktuelle MAMP und die aktuelle XAMPP Version, laufen alle mit PHP 5.3 welches von Joomla! bisher nicht unterstützt wird.

    So'n Pech.
     
  4. creative7even

    creative7even Jerseymac

    Dabei seit:
    23.02.05
    Beiträge:
    454
    Habe gerade einen Testinstall mit php 5.3 durchgeführt - und konnte keine Probleme feststellen.
    Worin genau liegt das Problem? Fehlermeldungen,...?

    lg
     
    #4 creative7even, 11.09.09
    Zuletzt bearbeitet: 11.09.09
  5. Tom Blues

    Tom Blues Braeburn

    Dabei seit:
    20.02.09
    Beiträge:
    43
    Keine Fehlermeldungen, aber diverse Komponenten (z.B. JoomlaPack, VirtueMart oder JoomFish) lassen sich entweder gar nicht erst installieren, oder funktionieren nicht sauber). Während der Installation wird eine leere Seite angezeigt und das war's dann.
    Ich habe keine Ahnung was dabei tatsächlich schief läuft, aber es scheint zahlreiche Probleme zu geben:

    http://forum.joomla.org/viewtopic.php?f=518&t=417086

    Ich habe daher mehrere Releases von XAMPP und MAMP ausprobiert, die entweder alle auf PHP 5.3 setzen, oder auf Snow Leopard nicht lauffähig waren.

    Die Möglichkeiten die ich nun sehe sind: Auf Joomla 1.6 warten und hoffen, dass dann 5.3 unterstützt wird, oder PHP 5.2 für den Betrieb auf Snow Leopard zu kompilieren und mit dem Standardapache aus der Webfreigabe zu verwenden. Beides scheint mir nicht wirklich zufriedenstellend zu sein.

    Welchen Webserver hast Du den benutzt? Hast Du mysql installiert und arbeitest mit dem Standardserver? Das habe ich bislang nicht getan. Da Joomla! auf der Webseite auf die inkompatiblität mit PHP 5.3 hinweist hab ich nach anderen Alternativen gesucht, aber bislang keine lauffähige gefunden. Bei den Problemen von Joomla scheint es sich gleich um mehrere zu handeln. Ich hab ein bisschen gegoogelt und herausgefunden, dass der Webhoster bplaced ein workaround für Joomlabetreiber durchführt. Dabei werden aber diverse Dateien getauscht, was natürlich vom Standard abweicht und ggf. weitere Probleme nach sich zieht.
    http://forum.bplaced.net/viewtopic.php?f=6&t=10318&start=20

    Ich scheue mich ein bisschen davor PHP 5.2 auf Snow Leopard zu kompilieren. Erstens kenne ich mit den Apple Developer Tools nicht aus, und zweitens hab ich noch keine Vorstellung ob und wie ich 5.2 parallel zu 5.3 implementieren kann.
     
  6. creative7even

    creative7even Jerseymac

    Dabei seit:
    23.02.05
    Beiträge:
    454
    ich verwende Leopard (10.5.x) mit dem Standard-Indianer sowie php5.3 von Marc Lyanage (installer package: http://www.entropy.ch/software/macosx/php/)
    Code:
    apache:
    Server version: Apache/2.2.11 (Unix)
    Server built:   Feb  3 2009 01:54:45
    
    php:
    PHP 5.3.0 (cli) (built: Jul 13 2009 19:11:32)
    
    die weisse Seite erscheint weil 1) ein Fehler auftritt und 2) php- error_reporting deaktiviert ist.
    Zum aktivieren die php.ini suchen. Wo finde ich die?
    Einfach eine php-Seite mit folgenden Inhalt erstellen und im Browser aufrufen - nach "path to php.ini" suchen...
    Code:
    <?php phpinfo(); ?>
    php.ini editieren, nach unten angeführten Optionen suchen und anpassen:
    Code:
    error_reporting = E_ALL & ~E_NOTICE
    display_startup_errors = On
    
    speichern und Apache neu starten...

    dann würde ich den Fehlermeldungen nachgehen und den Code fixen. Ein Kompilieren von php würde ich nicht empfehlen - das gestaltet sich aufwändiger als man vielleicht vermutet...
     

Diese Seite empfehlen