Java auf Mac OS

#Dennis

Pferdeapfel
Mitglied seit
19.06.14
Beiträge
79
Ah okay.

Ich verstehe ja da ist der Java Ordner, dort ist allerdings nur ein 1.6 von früher installiert, sollte dort jetzt auch 1.8 drin sein?

Wenn ich in Eclipse -> Einstellungen -> installed JRE's gehe wird mir das Java SE 6 angezeigt, wenn ich dann auf den Button "Search" klicke, findet er das Java SE 8. Ich kann dann ein Projekt erstellen und die Komponenten von Java 8 verwenden. Allerdings nicht ausführen, ist der Compiler dafür nicht ausgelegt?
 

Mief

Gloster
Mitglied seit
17.04.14
Beiträge
65
Welche Version von Eclipse hast du? 4.2 Juno oder 4.3 Kepler oder 4.4 Luna?
 

#Dennis

Pferdeapfel
Mitglied seit
19.06.14
Beiträge
79
zur Zeit 4.3 Kepler. Kann ich das updaten auf Luna oder muss ich es deinstallieren und neu installieren ?
 

Mief

Gloster
Mitglied seit
17.04.14
Beiträge
65
Du musst dir die 4.4 extra runterladen.
Edit: Du kannst auch mehrere Versionen von Eclipse gleichzeitig nutzen. Ohne sinnvollen Grund währe das aber Blödsinn :) (ich muss das leider :( )
 

#Dennis

Pferdeapfel
Mitglied seit
19.06.14
Beiträge
79
Okay, es läd :)

Kann ich den alten Eclipse und Workspace Ordner einfach in den Papierkorb ziehen oder muss ich noch anders "aufräumen" ?
 

Mief

Gloster
Mitglied seit
17.04.14
Beiträge
65
Wenn du noch keine Projekte gemacht hast, kannst du die Workspace löschen (musst du aber nicht). Wenn du schon Projekte gemacht hast, würden die mit gelöscht werden.

Aber das alte Eclipse selbst kannst mitsamt Ordner löschen.
 

#Dennis

Pferdeapfel
Mitglied seit
19.06.14
Beiträge
79
Super vielen Dank!

Eine letzte Frage hätte ich noch.

Wenn ich jetzt ein Java Projekt anlege, habe ich folgende Auswahlmöglichkeiten für das JRE:

Use an execution environment JRE -> Da steht JavaSE-1.8

oder

Use a project specific JRE -> JAVA SE 8 (1.8.0_05)

Wähl ich das erste kann ich keine javafx Komponenten, beim zweiten funktioniert alles wie gewünscht,
kannst du mir sagen wieso das so ist und wo der Unterschied ist?
 

Mief

Gloster
Mitglied seit
17.04.14
Beiträge
65
Das weiß ich nicht. Ich wähle beim Projekt erstellen immer aus, dass es die aktuellste Version nehmen soll. Bis jetzt hat immer alles funktioniert. Ich nutze allerdings auch noch Eclipse 4.2, gezwungener Maßen. Aber wenn es mit der einen Einstellung geht, ist es ja gut. Aber dann muss du aufpassen, dass du nach einen Java-Update auch immer das aktuellste Patch ausgewählt hast (die Zahl nach dem _ )
Edit: Merke grad, dass ich immer die erste Möglichkeit wähle (hups), (ich habe ein deutsches Sprachpaket installiert und da heißt das anders)
 
  • Like
Wertungen: #Dennis