1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Java 1.5 installiert aber noch immer über 1.4 compiliert

Dieses Thema im Forum "macOS & OS X" wurde erstellt von mary, 11.01.06.

  1. mary

    mary Gast

    Hallo,

    ich mir Java 1.5 neu installiert. Es wird laut Shell aber(java version) immer noch mit der alten Version compiliert. Wie kann ich das ändern?

    Vielen Dank im voraus
    Mary
     
  2. mullzk

    mullzk Linsenhofener Sämling

    Dabei seit:
    04.01.04
    Beiträge:
    2.529
    hehe, da liest einer die readme-files nicht. tststssss...

    du musst nur den current-symlink in /System/Library/Frameworks/JavaVM.framework/Versions umbiegen, dann ist 1.5 standard.
     
  3. mary

    mary Gast

    darunter kommen bei mir noch viel mehr verzeichnisse:
    1.3
    1.3.1
    1.4
    1.4.2
    1.5
    1.5.0
    A
    Current
    CurrentJDK

    wie mache ich das?
     
  4. mullzk

    mullzk Linsenhofener Sämling

    Dabei seit:
    04.01.04
    Beiträge:
    2.529
    cd /System/Library/Frameworks/JavaVM.framework/Versions/
    sudo rm CurrentJDK
    sudo ln -s 1.5 CurrentJDK
     
  5. mary

    mary Gast

    Danke
    :)
     
  6. bluejay

    bluejay Ingol

    Dabei seit:
    27.12.03
    Beiträge:
    2.082
    Für wen, der das Terminal nicht so mag sollte auch der folgende Weg funktionieren:
    Programme/Dienstprogramme/Java/J2SE 5.0/Java Preferences in den Preferences dann unter Allgemein im Popupmenü J2SE 5.0 auswählen und unten unter Java Programm Laufzeit-Einstellungen ebenfalls J2SE 5.0 an die oberste Stelle verschieben.
    Das sollte dann auch funktionieren.
     
  7. mary

    mary Gast

    das hatte ich nämlich gemacht und dabei wird nur die browser einstellung auf java 1.5 geändert. in der shell ist nix passiert!!!
     
  8. bluejay

    bluejay Ingol

    Dabei seit:
    27.12.03
    Beiträge:
    2.082
    Der untere Teil der Einstellung sollte aber nicht nur die Browsereinstellung verändern, dachte ich zumindest immer. o_O
     
  9. mary

    mary Gast

    also ich hatte beides auf 1.5 geändert. und erst der tip von mullzk hat funktioniert
     
  10. bluejay

    bluejay Ingol

    Dabei seit:
    27.12.03
    Beiträge:
    2.082
    Dann werde ich das wohl auch mal probieren. Danke.
     

Diese Seite empfehlen