1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

iWeb+ohost.de

Dieses Thema im Forum "Webhosting/DSL-Anbieter" wurde erstellt von philipxD, 04.04.08.

  1. philipxD

    philipxD Friedberger Bohnapfel

    Dabei seit:
    22.12.07
    Beiträge:
    532
    Guten Tag.
    Kann zwar sein, dass es darüber schon ein paar Freds gibt, die darüber reden, jedoch wollte ich fragen, wie ich meine in iWeb erstellte Website auf ohost.de hochkriege?
    Durch den FTP-Support habe ich schon die fertige Website (index.html und Dateien) auf den Server mit Hilfe von Cyberduck hochgeladen habe, dachte ich, dass es nur fertig wäre. Falsch gedacht.
    Nun kommt immer foglende Meldung:
    Code:
     
    Parse error: syntax error, unexpected T_STRING in /usr/export/www/hosting/philiposxd/index.html on line 1
    Da ich kaum Ahnung von Programmieren und HTML habe, hoffe ich, dass ihr mir weiterhelfen könnt. Versucht es bitte relativ einfach für mich darzustellen, wie ich nun vorgehen soll.




    PS.: Meine Website lautet: http://philiposxd.ph.ohost.de/
     
  2. zeno

    zeno Lane's Prinz Albert

    Dabei seit:
    05.11.05
    Beiträge:
    4.898
    Die erste Zeile in deinem Dokument beginnt zufällt mit <?xml.... ?
     
  3. philipxD

    philipxD Friedberger Bohnapfel

    Dabei seit:
    22.12.07
    Beiträge:
    532
    wie finde ich heraus, wie die erste zeile anfängt?

    edit:
    habe es mit TextWrangler versucht:
    das ist die erste Zeile:
    <?xml version="1.0" encoding="UTF-8"?><!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"><html xmlns="http://www.w3.org/1999/xhtml"><head><title></title><meta http-equiv="refresh" content="0;url= Philips_Website/Willkommen.html" /></head><body></body></html>
     
  4. philipxD

    philipxD Friedberger Bohnapfel

    Dabei seit:
    22.12.07
    Beiträge:
    532
    was muss ich jetzt machen?
     
  5. zeno

    zeno Lane's Prinz Albert

    Dabei seit:
    05.11.05
    Beiträge:
    4.898
    Aus
    Code:
    <?xml version="1.0" encoding="UTF-8"?>
    Code:
    <?php echo '<?xml version="1.0" encoding="UTF-8"?>'; ?>
    machen, dann sollte es klappen.
     
  6. philipxD

    philipxD Friedberger Bohnapfel

    Dabei seit:
    22.12.07
    Beiträge:
    532
    danke
    aber jetzt kommt folgende Fehlermeldung:
    Parse error: syntax error, unexpected T_STRING in /usr/export/www/hosting/philiposxd/Philips_Website/Willkommen.html on line 1
     
  7. zeno

    zeno Lane's Prinz Albert

    Dabei seit:
    05.11.05
    Beiträge:
    4.898
    Okay, jetzt der lustige Teil für dich, du ersetzt das von oben in jeder .html Datei die von iWeb erstellt wurde ;)
     
  8. philipxD

    philipxD Friedberger Bohnapfel

    Dabei seit:
    22.12.07
    Beiträge:
    532
    ah
    danke!
    versuche ich gleich mal...
    ich sage dann mal bescheit, wenn es klappt...
     
  9. Gartenzwerg

    Gartenzwerg Leipziger Reinette

    Dabei seit:
    08.01.08
    Beiträge:
    1.778
    Ich hatte das Problem auch und bin einfach zu Kilu gewechselt. Einfacher und besser. Achja, auf deiner Website musst du die Umlaute und so noch verändern, in Safari werden ü, ä, ö und ß fehlerhaft angezeigt.
     
  10. philipxD

    philipxD Friedberger Bohnapfel

    Dabei seit:
    22.12.07
    Beiträge:
    532
    kann man das ändern?
     
  11. Gartenzwerg

    Gartenzwerg Leipziger Reinette

    Dabei seit:
    08.01.08
    Beiträge:
    1.778
    Du müsstest bei jedem einzelnen Umlaut einen Code umschreiben oder so. Wenn du die Website änderst, musst du es alles wieder neu machen. Das dauert viel zu lange. Also einfach ein paar Sätze so umschreiben, dass dort keine Wörter mehr mit Umlauten vorkommen und den Rest in ue, ae, oe und ss. So hab ich es gemacht. ;) Wie hast du deine Website dann eigentlich hochgeladen bekommen? Hast du auf jeder Seite den HTML Code so editiert, wie zeno es gesagt hat? :oops:
     
  12. philipxD

    philipxD Friedberger Bohnapfel

    Dabei seit:
    22.12.07
    Beiträge:
    532
    @Gartenzwerg
    Kilu sieht ganz gut aus. Ich werde es gleich mal ausprobieren. danke!
    und ja, ich habe das bei jeder Seite gemacht. Es waren zum Glück nicht all zu viele. Habe mal kurzer Hand Smultron als Editor genommen. Und es klappte auch. Bloß das Problem mit dem Umlauten war vorhanden.
     
  13. Gartenzwerg

    Gartenzwerg Leipziger Reinette

    Dabei seit:
    08.01.08
    Beiträge:
    1.778
    Ja. Das kann ich dir nur raten. Ohost und funpic, da musst du immer wieder die Quellcodes überarbeiten meines Wissens. Mit Kilu ist das alles angenehmer. Achso, und les dir die Anleitung zum Hosten bei Kilu durch. Da steht so manches drin, was dir eine Menge Stirn runzeln ersparen könnte, ich spreche aus Erfahrung.
    Du musst 3 Ordner erstellen, falls sie noch nicht auf deinem Server stehen, nämlich tmp, logs und www. In www musst du alle Dateien ziehen. Beim einloggen musst du hinter deinem Benutzernamen noch ein '@1' machen. Das ist alles, was zu beachten ist. Wenn du nicht mehr weiterkommst kannst du dir ja Meinen Thread durchlesen. Wollte nur helfen :eek: Aber ich denke, dass schaffst du schon alleine und bist nicht so doof wie ich ;)
     
    #13 Gartenzwerg, 04.04.08
    Zuletzt bearbeitet: 05.04.08
  14. philipxD

    philipxD Friedberger Bohnapfel

    Dabei seit:
    22.12.07
    Beiträge:
    532
    ahja
    bei Kilu habe ich das Problem mit den Websiten weiterhin. Kann ich das irgendwie wegmachen?
     
  15. C64

    C64 Halberstädter Jungfernapfel

    Dabei seit:
    12.04.06
    Beiträge:
    3.836
    Die Seite ist ganz nett gemacht. Vielleicht kannst du deine Eltern oder dein Taschengeld überzeugen, einen ganz kleinen Webspace irgendwo zu "kaufen". Dann hast du normalerweise diese Probleme nicht - und auch keine Werbung;)
     
  16. philipxD

    philipxD Friedberger Bohnapfel

    Dabei seit:
    22.12.07
    Beiträge:
    532
    da habe ich auch keine werbung. und warum soll ich zahlen, wenn es auch kostenlos geht? Eigentlich ist es ja ganz gut
    Es ist nur ein einziges Problem vorhanden, und das nennt sich Umlaute...
     
  17. philipxD

    philipxD Friedberger Bohnapfel

    Dabei seit:
    22.12.07
    Beiträge:
    532
    also, hätte jemand eine lösung mit den umlauten? was müsste ich machen?
     
  18. philipxD

    philipxD Friedberger Bohnapfel

    Dabei seit:
    22.12.07
    Beiträge:
    532
    es ist zum weinen...
     
  19. Gartenzwerg

    Gartenzwerg Leipziger Reinette

    Dabei seit:
    08.01.08
    Beiträge:
    1.778
    Les dir einfach diese Seite meines Threads durch. Du hast aber auch eine PN. Entweder kostenpflichtigen Webspace und so oder eben umschreiben, umschreiben umschreiben.. oder halt bei jeder neuen Änderung an deiner Website alles neu ändern im Quelltext. Hast ja ne PN. ;)
     
  20. philipxD

    philipxD Friedberger Bohnapfel

    Dabei seit:
    22.12.07
    Beiträge:
    532
    Ich habe das Problem jetzt anders gelöst...
    Unter Windows benutzte ich den Webeditor NetAuthor (gibt es nicht mehr, habe ich von Freund). Der kann die ganzen Umlaute auf Knopfdruck umwandeln. Die Website ist nun fertig! http://philipos.kilu.de
     

Diese Seite empfehlen