1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

iWeb HP Darstellung in versch.Browsern

Dieses Thema im Forum "Webhosting/DSL-Anbieter" wurde erstellt von Gabriele67, 14.09.08.

  1. Gabriele67

    Gabriele67 Jonagold

    Dabei seit:
    19.01.08
    Beiträge:
    20
    Liebe Gemeinde,

    gerade habe ich eine HP gebastelt und bei mobile me hochgeladen.
    Wenn Ihr mal gucken wollt:
    http://web.me.com/gabriele.roesing/Website/Willkommen.html
    Mit Safari:
    http://web.me.com/gabriele.roesing/Website/wir_sind...html
    gibt es bei der Vorstellung der zweiten Person in dem Kasten links einen grünen Balken, der teilweise über der Schrift gelandet ist. In iweb wird es aber so abgebildet, wie es sein soll, und wie es witzigerweise auch der Firefox abbildet. Probiert die gleiche Seite mal mit dem Fuchs aus.
    Schon peinlich, daß der Apple-eigene Browser da Mist macht, oder? *gg*

    Allerdings werden bei Safari bei den Bildern auf dieser Seite (bzw. überall, aber auf der Seite sieht man es am deutlichsten) die Schatten, die ich haben wollte, abgebildet - bei Firefox nicht.
    Außerdem fehlt beim Firefox in der Navigationszeile oben der Link zur Startseite "Willkommen"

    Liegt das vielleicht an dem Theme das ich gewählt habe (BoBop)?

    Das ist meine erste HP, die ich mache und ich bin maßlos enttäuscht wieder mal auf die Versprechungen reingefallen zu sein..(sorry, ich höre schon wieder auf mit dem Frust-Geschwafel)

    Also meine Frage: mit welchem Programm kann auch ein Halb-Voll-Depp wie ich eine HP erstellen, die so abgebildet wird, wie ich sie gemacht habe? Oder muß ich bei iweb irgendwas beachten?
    Habt Ihr einen Tipp?

    Vielen Dank im Voraus!

    Gabriele
     
    #1 Gabriele67, 14.09.08
    Zuletzt bearbeitet: 14.09.08
  2. Mac-Rookie

    Mac-Rookie Königsapfel

    Dabei seit:
    25.07.05
    Beiträge:
    1.204
    Hhhmmm ich kann bei keinem Browser nennenswerte Unterschiede sehen... Welches OS hast du? Welche Browser-Version? Welche iWeb Version?

    Getestet von mir:

    OSX Leopard 10.5.4 + Safari + FF3 + Opera
    Linux OpenSuse 10.3 + FF + Konqueror
    Vista + IE7 + FF3 + Opera + Safari

    Sorry, kann dir da nicht weiter helfen....
     
  3. Gabriele67

    Gabriele67 Jonagold

    Dabei seit:
    19.01.08
    Beiträge:
    20
    Hallo!
    Danke für's gucken! Komisch, kann es sein, daß nur bei mir dieser Fehler angezeigt wird?
    http://web.me.com/gabriele.roesing/Website/wir_sind...html
    bei der Vorstellung der zweiten Person (zweites Bild) ist links vom Bild ein hellblauer Kasten. Darin ist ein kleiner grüner Balken, der eigentlich zwei Textabschnitte voneinander trennen soll. Das tut er aber nur bei Firefox, nicht bei Safari
    Ich verwende
    Firefox: 3.0.1
    Safari: 3.1.2
    Mac OsX: 10.5.4
    iweb: 2.0.4

    Das Problem mit den Schatten scheint ein Bug in iweb zu sein, wie ich jetzt rausgekriegt habe.
    Aus irgendwelchen Gründen stellt Firefox jetzt den Link zur Starseite dar.
    Vielleicht magst Du ja nochmal gucken wegen dieses grünen Balkens? Soll man vielleicht bei iweb gar keine grafischen Elemente IN Textfelder schieben? Kann es sein, daß es bei sowas immer zu Abbildungsfehlern kommen kann?
    Danke!
    Gabriele
     
  4. Camthalion

    Camthalion James Grieve

    Dabei seit:
    24.05.07
    Beiträge:
    136
    Hallo Gabriele!

    Ich habe mir eure Seite auch mal angesehen. Ja, im Safari kann auch ich diesen Fehler sehen, in Firefox nicht. Wie dieser Fehler zustande kommt, kann ich Dir allerdings auch nicht sagen, dazu müsste man die komplette iWeb-Datei mal sehen. Hab mir zwar mal den Quellcode angesehen, aber leider zu wenig Zeit, das genauer zu untersuchen.
    Ich habe allerdings mindestens noch einen Fehler gefunden, der sowohl in Safari als auch in FF auftritt: auf der Seite "Willkommen" wird der oberste Farbbalken nicht richtig dargestellt. Er wird von einem weissen Balken getrennt, in dem die Links zu den anderen Unterseiten stehen.

    Du solltest selbst erstellte Seiten vor der Veröffentlichung in einem lokalen Ordner auf der Festplatte veröffentlichen und anschliessend mit verschiedenen Browsern testen.
    Solche Probleme, wie sie auf eurer Seite auftreten wirst Du auch mit anderen sogenannten WYSIWYG-Editoren, wie iWeb, immer wieder haben. Das Problem ist die freie Platzierung von Grafiken, die sehr schwierig umzusetzen ist.
    Willst Du eure Seite wirklich genauso haben, wie Du es Dir vorstellst, solltest Du mit einem anderen Web-Layout-Programm arbeiten, wie z.B. Dreamweaver von Adobe. Ist dann aber auch deutlich schwerer für Laien.

    Ansonsten aber ist eure Seite sehr gut gelungen und interessant.
    CU Gerd
     
  5. Gabriele67

    Gabriele67 Jonagold

    Dabei seit:
    19.01.08
    Beiträge:
    20
    Lieber Gerd,
    vielen Dank für Deine Mühe! Deine Hintergrundinformationen wirken deutlich entspannend auf mich. Wenn es normal ist, daß WYSIWYG-Dinger suboptimal sind, dann muß man sich eben in einer gewissen Demut üben, wenn man sich nicht professionalisieren kann / will. Ich habe die Seite jetzt sowieso umgestellt - sie war den Mädels zu bunt und dort sind nun weniger Fehler aufgetreten, weil sie eben auch grafisch reduzierter ist. ich habe sie auch im Querformat angelegt (war ein wenig mhsam, weil man jede neue Seite (außer denen, die man duplizieren konnte) neu einstellen mußte - die vorgegebenen Textfelder dieser Verbreiterung dann aber nicht mitmachten, und per hand eingestellt werden mußten. Wenn Dich dieses testfeld auch interessiert:
    http://web.me.com/gabriele.roesing/Website_3/Willkommen.html
    Nochmal danke und viele Grüße!
    Gabriele
     
  6. Camthalion

    Camthalion James Grieve

    Dabei seit:
    24.05.07
    Beiträge:
    136
    Hallo Gabriele!
    Nur kurz, da ich auf Schicht bin: Werde mir eure Seite heute Abend in Ruhe ansehen. Auf dem iPhone sieht es ganz gut aus, das Design gefällt mir auf jeden Fall besser. Mehr dnn später.
    CU Gerd
     
  7. Camthalion

    Camthalion James Grieve

    Dabei seit:
    24.05.07
    Beiträge:
    136
    Sieht gut aus!

    Hallo Gabriele!
    So, wieder zu Hause und gleich mal die Seiten besucht. Sieht sehr gut aus, das Design gefällt mir sehr gut. Ist sehr schlicht und auf das Wesentliche reduziert. Besser als der erste Versuch, wenn ich das so sagen darf.

    Das Problem bei der Web-Seitengestaltung ist folgendes: Will man volle Kontrolle über das genaue Layout kommt man um richtige HTML-Editoren nicht herum. WYSIWYG-Editoren versuchen das beste aus dem zu machen, was der (unbedarfte) User möchte und "stricken" daraus einen sehr aufwendigen, oftmals fürchterlichen Code. Ich habe vor vielen Jahren meine Homepage noch komplett per Hand in einem simplen Editor geschrieben, weil es WYSIWYG noch nicht gab. Heute habe ich dazu auch keine Zeit und Lust mehr und mache das jetzt auch mit iWeb, versuche aber, das Design nicht zu aufwändig zu machen.

    Falls Du Lust hast, Deine Seite freier zu bearbeiten, sieh Dir mal "NVU" an, der ist ganz gut geeignet, an seinen Seiten etwas zu optimieren. Ist ein HTML-Editor, der sowohl Quellcode- als auch WYSIWYG-Bearbeitung zulässt.

    Für Deine weitere Arbeit an eurer HP wünsche ich noch viel Spass.
    Noch kurz: habe auf der Seite "Bilder" einen Rechtschreibfehler entdeckt:) , wenn Du ihn findest, darfst Du ihn behalten ;)
     
  8. Utz Gordon

    Utz Gordon Schöner von Nordhausen

    Dabei seit:
    15.07.07
    Beiträge:
    316
    Hi,


    ich habe ähnliche Probleme und muss deinen Thread dafür mal hijacken, sorry. Bei mir wird auf dem Weg von iWeb auf einer Seite grundsätzlich immer der ganze Text versaut und ich finde einfach nicht den Grund heraus.


    Hier geht's zum Thread: KLICK



    Und scho bin ich auch schon wieder weg.
     

Diese Seite empfehlen