1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

iWeb 2.0.1 Blog "Einträge" Workaround

Dieses Thema im Forum "macOS & OS X" wurde erstellt von dark-hawk, 17.08.07.

  1. dark-hawk

    dark-hawk Ontario

    Dabei seit:
    14.01.05
    Beiträge:
    342
    Leider hat auch das Update 2.0.1 nicht das Problem mit dem Umlaut "ä" inder Ordnerstruktur der Blogeinträge gelöst. Daher hab ich mir das ganze Problem jetzt nochmal genauer angeschaut.
    Für alle Mutigen: Man kann die Lokalisierung von iWeb anpassen!! und zwar muss man dazu einen rechtsklick auf das iWeb-Symbol machen und da auf "Paketinhalt zeigen dort Content -> Resources -> German.Iproj
    darin befindet sich die datei "Localizable.strings" dort findet man in der Zeile 728 den Quell des Problems: "Entries" = "Einträge";
    Ich habe hier einfach das "ä" durch ein "a" ersetzt. Veröffentlicht man nun die Seite neu heißt der Ordner "Eintrage" und nicht mehr "Einträge" auch die Links passen entsprechend. So kann man sich erstmal behelfen bis Apple mitbekommt das hier was nicht stimmt.
    Alles natürlich auf eigenes Risiko, der Rechtsweg ist ausgeschlossen ;)
     
  2. Tekl

    Tekl Fairs Vortrefflicher

    Dabei seit:
    01.06.05
    Beiträge:
    4.622
    Wo besteht denn das Problem? Bei mir scheint's zu funktionieren.
     
  3. dark-hawk

    dark-hawk Ontario

    Dabei seit:
    14.01.05
    Beiträge:
    342
    Das Problem besteht bei mir und einigen anderen darin das Blogs auf dem Webserver in einem Ordner "Einträge" gespeichert sind (mit iWeb 1.1.2 war das noch anders gelöst). Geht man nun auf eine Blogseite und klickt einen Blogeintrag an (z.b. unten auf "Weiterlesen...") wird man auf eine html verlinkt die im Ordner "Einträge" liegt. Da "Einträge" aber einen Umlaut nämlich da "ä" enthält kommt es bei einigen Webservern zu Problemen die darin resultieren das der Webserver versucht das "ä" zu interpretieren und das nicht schaft und dadurch eine 404 Seite anzeigt. Es hat vermutlich was mit den Charsets zu tun die man im Apache als Standard angibt. Da aber nicht alle Leute an die Apache Config ihres Webspace rankommen stand man vor einem echten Problem.
     
  4. Tekl

    Tekl Fairs Vortrefflicher

    Dabei seit:
    01.06.05
    Beiträge:
    4.622
    Bei mir klappt das mit dem "Weiterlesen ...".
     
  5. dark-hawk

    dark-hawk Ontario

    Dabei seit:
    14.01.05
    Beiträge:
    342
    Dann ist dein Webserver vermutlich passend konfiguriert, wo hostest du denn? Und das Problem betrift nur iWeb 2.0.x
     
  6. Tekl

    Tekl Fairs Vortrefflicher

    Dabei seit:
    01.06.05
    Beiträge:
    4.622
    Ich habe .Mac und nutze das neue iWeb. Deiner Frage nach zu urteilen, veröffentlichst du in einem Ordner.
     
  7. dark-hawk

    dark-hawk Ontario

    Dabei seit:
    14.01.05
    Beiträge:
    342
    Ja da hast du wohl recht, bei .Mac tritt das Problem bei mir auch nicht (mehr) auf. Da funktioniert das schon seit einigen Tagen, anfangs hatte aber auch .Mac bei mir (hab sowohl .Mac als auch einen externen Server) Probleme damit. Aber der Workaround richtet sich tatsächlich an nicht-.Mac Nutzer bzw an die bei denen das Problem auftritt.
     
  8. WDPX

    WDPX Gast

    Hallo,

    hatte auch das iWeb-Einträge-Problem. Und ja, das liegt dann am Webserver. Man kann aber nicht erwarten, dass der Server "richtig" eingestellt ist, denn ein wirkliches "richtig" gibt es da leider nie. Ist i.d.R. ja Linux und das wird sowieso überall anders aufgesetzt. Ich habe 2 Server, bei denen bei beiden SUSE 10 und PLESK 8.1 drauf ist. Und doch ist alleine die Ordnerstruktur eine völlig andere und die Webspaces liegen auf beiden an völlig unterschiedlichen Orten. Das nur mal so generell. Der Tipp hier ist Gold wert. Daran hatte ich noch gar nicht gedacht. Vielen dank! :-D
     
  9. Tekl

    Tekl Fairs Vortrefflicher

    Dabei seit:
    01.06.05
    Beiträge:
    4.622
    Würde nicht evtl. auch folgendes Abhilfe bringen?

    .httaccess um AddDefaultCharset utf-8 ergänzen.
     
  10. dark-hawk

    dark-hawk Ontario

    Dabei seit:
    14.01.05
    Beiträge:
    342
    @Tekl: das hab ich auch schon probiert, bringt aber noch mehr durcheinander. Die Lokalisierung anzupassen ist definitiv der einfachste Weg.
     
  11. Tekl

    Tekl Fairs Vortrefflicher

    Dabei seit:
    01.06.05
    Beiträge:
    4.622
    Ok, war auch nur ein Gedanke.
     
  12. deadofnight

    deadofnight Pferdeapfel

    Dabei seit:
    27.03.06
    Beiträge:
    78
    Vielen Dank erstmal für den Tipp - habe ihn jetzt auch endlich mal gefunden. Wie hast Du das editiert? Auf meinem Macbook wird OmniOutliner vorgeschlagen -konnte den entsprechenden Parameter auch ändern, aber leider nicht die entsprechende Datei verändern sondern nur an einem neuen Ort abspeichern...

    Please Help

    Oder gibt es mittlerweile noch eine bessere Lösung zu dem Problem?
    Finde es wirklich erstaunlich, dass dieser Effekt mit dem neuen iWeb Update nicht behoben wurde! Ist man von Apple ja gar nicht gewohnt, sowas...
     
  13. dark-hawk

    dark-hawk Ontario

    Dabei seit:
    14.01.05
    Beiträge:
    342
    ich hab das mit textmate gemacht. solte aber eigentlich mit den meisten üblichen texteditoren klappen, zb bbedit usw
     
  14. deadofnight

    deadofnight Pferdeapfel

    Dabei seit:
    27.03.06
    Beiträge:
    78
    Alles klar . verstanden. Hab's einfach mit textedit gemacht, ging wunderbar.
    Nochmals Danke für den Tipp!!

    Werde nur einfach die Verwunderung über Apples "Schlamperei" nicht los...
     
  15. dark-hawk

    dark-hawk Ontario

    Dabei seit:
    14.01.05
    Beiträge:
    342
    naja, ich denke es kommt auch ein bisschen auf die Konfiguration des Webservers an. auf .mac funktioniert es auch mit "Einträge" (habe beides .mac und eigenen server). Aber es ist halt mit Umlauten immer soeine Sache, krisensicherer ist es die Lokalisation anzupassen, damit klappt es immer
     

Diese Seite empfehlen